Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/01/2016, à 17:29

philippe010

problème avec DAC TEAC UD503

Bonjour,

j'ai un problème avec un nouveau DAC teac UD503; JACK ne veut plus démarrer avec lui alors qu'il démarrait sans problème avec mon ancien DAC un HRT microstreamer

J'ai les messages suivant :
ERROR: ALSA: cannot set hardware parameter for play
ERROR: ALSA connot configure playback channel.
ERROR: Cannot initialize driver
ERROR: JackServer::Open failed with -1
ERROR: Failed to open server

J' ai regardé un peu partout mais pas trouvé par quel bout prendre le problème
je devrais probablement avoir le même problème avec un UD501.

Avant de le renvoyer ( ce serait vraiment dommage) je fais appel à la communauté.
Par avance merci

Dernière modification par philippe010 (Le 30/01/2016, à 17:30)

Hors ligne

#2 Le 14/02/2016, à 23:23

dja75

Re : problème avec DAC TEAC UD503

Bonjour,

Le patch kernel a été validé et en cours de propagation sur ubuntu.

Probleme de timing usb avec l'interface du teac nt/ud-503.
Il concerne également l'UD-501 dans une moindre mesure.

Si vous êtes pressé, vous pouvez l'installer vous-même:
snd-usb-audio-patch

Hors ligne

#3 Le 15/02/2016, à 04:22

philippe010

Re : problème avec DAC TEAC UD503

Bonjour,

merci pour la réponse ... j'étais déjà tombé sur ce post; la solution que j'ai trouvé est de retourner l'appareil et de me le faire rembourser.
La manipulation était de nature nettement plus complexe que celle que je suis habitué à faire et selon certains avec un résultat aléatoire.
J'ai choisi, pour le remplacer, une solution ou DAC et ampli-casque sont séparés ...  avec un DAC pour lequel je suis sûr qu'il fonctionne sous Ubuntu; je ferais évoluer mon DAC en fonction des évolutions diverses des enregistrements du marché .. Je me bats maintenant avec de classiques problème de XRUN ..

Cdt

Dernière modification par philippe010 (Le 15/02/2016, à 05:11)

Hors ligne

#4 Le 17/02/2016, à 12:22

dja75

Re : problème avec DAC TEAC UD503

Bonjour,

Pour vos problemes de xrun, si vous cherchez le bitperfect, donc sans resampling, vous devriez supprimer jack
(et bien sur pulseaudio) et passer en direct sur alsa. C'est un simple fichier (asound.conf) et ca limite donc les
couches software.

Pour le Teac, c'est dommage. Je ne sais pas ce que vous avez pris en solution dac et ampli-casque, mais le ud-503 et
son ampli casque avec la double sortie balanced sont exceptionnels. Je l'utilise en sortie XLR monitoring et en casque.
J'ai eu précédemment les deux micromega mydac/myzic, ca tournait bien pour le prix, puis un excellent ud-501 que
j'ai déplacé à mon bureau (sur casque akg k701). Le ud-503 est définitivement le meilleur, il reste chez moi celui-là.
Pour le patch (c'est moi guillaume), ca régle totalement le probleme avec les teac dont je dispose.
Changement transparent de freq/format, dsd, pcm... Il vient d'être intégré dans les kernels ubuntu donc doit ou
devrait etre dispo en maj. J'ai recu la validation sur l'intégration dans le 3.16.y-ckt (extendedstable).

bonne journée.

Hors ligne

#5 Le 19/02/2016, à 21:10

philippe010

Re : problème avec DAC TEAC UD503

Bonjour,

la manip semblait trop complexe pour moi; j'ai laissé tomber :

"Pour vos problemes de xrun, si vous cherchez le bitperfect, donc sans resampling, vous devriez supprimer jack
(et bien sur pulseaudio) et passer en direct sur alsa. C'est un simple fichier (asound.conf) et ca limite donc les
couches software."
Pouvez-vous m'en dire plus ? Pouvez-vous expliquer quel est le problème avec JACK ?
Jack est-il nécessaire ? Faut il un noyau low latency ou RT ? 
J'ai lu une grande quantité de post sur le sujet; le problème est que chacun y va de son affirmation sans explications et les conclusions peuvent être radicalement différentes voire opposées .. alors quand on est pas un expert pointu on est perdus .. tout cela juste pour écouter de la musique.. 

Comme DAC j'ai un hrtmicrostreamer associé à un ampli casque Lehmann linear;pour aller au delà de 96000 je ferais évoluer le DAC  j'ai pu tester ampli et pre ampli du UD503 avec  le dac hrt mais le dac du UD503 pas pu faire marcher.

merci

cdt

Dernière modification par philippe010 (Le 19/02/2016, à 22:10)

Hors ligne

#6 Le 21/02/2016, à 21:58

dja75

Re : problème avec DAC TEAC UD503

Bonjour,

Jackd, c'est un passe-plat si vous voulez. Multi-source, multi-sortie.
Il dispose d'une trés faible latence, ca fonctionne trés bien mais si vous n'avez qu'un lecteur audio, et un dac, c'est totalement inutile de l'activer.

Pulseaudio, c'est, comment dire, inutile de manière générale... A la base, c'est pour simplifier la détection de device, la configuration, dans le cadre d'une machine desktop.
Le problème de ce truc, c'est que c'est catastrophique à configurer hors des sentiers battus, et ca resample. Donc pour le bit-perfect, on oublie complétement, c'est contre-productif.

Historiquement, vous avez deux layers son dans Linux, je parle du kernel, l'OSS (qui est en fin de vie) et Alsa.
Jackd et Pulseaudio utilisent donc alsa... et se mettent entre ce qui veut jouer de l'audio et alsa.
Donc si vous n'avez pas jack ni pulseaudio, votre lecteur tapera directement sur alsa.

Alsa, c'est un simple fichier de config: /etc/asound.conf (ou sur le user ~/.asound.conf).
Ca configure la couche Kernel, donc les interfaces audio hardware que vous avez.
Pour le bitperfect par exemple de l'UD-503, c'est aussi simple que ca, deux lignes:

pcm.!default { type hw card UD503 }
ctl.!default { type hw card UD503 }

Pour savoir le nom de votre carte, il suffit de taper ceci:

# aplay -l
...
card 2: UD503 [UD-503], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Le nom à mettre dans 'card', c'est donc le premier. juste aprés le 'card X:'.
Vous n'avez rien à relancer. Alsa charge sa configuration au moment où votre player se connecte à l'interface audio alsa.
Si vous êtes en 'user' et non en root, il faut que votre user appartiennent au groupe qui est autorisé à activer alsa.
Il suffit de le rajouter au groupe 'audio' comme ceci:

# sudo adduser <myuser> audio

Ensuite, il suffit d'utiliser un lecteur, 'mpd' par exemple, qui va lire la musique et l'envoyer sur l'interface alsa.
'mpd' a le grand interet d'etre un serveur, et vous interagissez avec lui avec des clients. Il y en a plein, notamment pour Android, Apple, linux etc..
Donc pas besoin d'avoir un écran sur la machine, le serveur tourne tout le temps et attend que vous lui disiez de lire tel ou tel fichier.
Ma configuration mpd du device (/etc/mpd.conf):

audio_output {
	type		"alsa"
	device		"default"
	name		"UD503"
	auto_resample 	"no"
	auto_channels	"no"
	auto_format	"no"
	use_mmap	"yes"
#	mixer_type	"software"  # desactivé pour le UD-503 - controle de volume du preamp integre
	mixer_type  "disabled"
        # Good bandwidth
	period_time	"50000"
	buffer_time	"2500000"
	dsd_usb		"yes"
}

Ici on voit bien que le resample, changement de format sont désactivés. Donc c'est du bitperfect. Le format du fichier est envoyé tel quel au device de lecture.
Vous avez l'ensemble de ma conf ici: gp

Le kernel RT, c'est un petit extra mais ce n'est pas nécessaire bien sûr.
Ca vous permet de baisser la latence du kernel pour certains process, pour simplifier ils peuvent devenir en quelque sorte ultra prioritaire sur les I/O systeme et CPU.
Donc ca vous permet de prioriser les interrupts (IRQ) du bus USB par exemple, et le lecteur 'mpd'. C'est un peu plus complexe à tuner.
Globalement, si votre machine n'a pas 15 ans ou que vous ne faites pas tourner de process hyper gourmand en ressource dessus, vous pouvez vous passer du RT et laisser linux faire son travail admirablement.

J'espere que c'était assez clair ;-)

Hors ligne

#7 Le 23/02/2016, à 07:26

philippe010

Re : problème avec DAC TEAC UD503

Bonjour

Merci pour ce message clair et bien rédigé.
Il peut être intéressant de connaître mon projet pour comprendre mon problème.

Projet :
1/ Dématérialiser mes 5000 cd pour mieux les gérer, utiliser l'interface d'un lecteur pour les retrouver tous et éviter des achats en double ce qui arrive quand on a une importante collection.
2/ Me permettre d'écouter des enregistrements de type HIRES 96000 ou plus que l'on trouve notamment chez Qobuz.

Ma configuration hard et soft suite à la lecture d'innombrables posts.

Deux PC , l'un qui me sert de PC universel très puissant (i7 et 16 g mem) sur lequel j'ai ajouté les PPA de kxstudio pour avoir jack/candence qui semblait indispensable ; je lis fréquemment sur ce PC des videao youtube via firefox et j'utilise  Skype; mon dac est un microstreamer associé à un ampli casque Lehman Linear qui me sert aussi de préampli quand le connecte le PC ma chaine hifi.
j'ai installé le module qui fait un pont pour les logiciels qui ont besoin de pulseaudio et les dirige vers jack ( comme skype); clementine est mon lecteur de musique principal. 
JACK est démarré à chaque session et marche globalement assez bien;
Sur cette configuration les problèmes résiduels sont de deux types :
  1/ Quelques xrun résiduels entre 10 et 20 selon la durée de la session pas bien grave mais cela s'entend à chaque désynchronisation.
  2/ Obligation de d'arrêter et relancer Jack et clementine dès que je veux changer le rate par exemple si je passe d'un fichier de type flac 44100 à un hi res 96000; ma croyance mais non une certitude est qu'en faisant cela   je reste en bitperfect, si c'est bien la définition du bitperfect, en évitant le resampling.

Sur cette machine, j'ai essayé la solution conseillée sans jack avec la configuration alsa dans .asoundrc ; avantages : passage automatique au bon rate quand je change de morceau de musique , il y a un indicateur sur mon HRT microstreamer qui me le signifie; inconvénient adieu à skype et aux videos de type youtube ce qui pose problème sur cette machine qui se veut universelle.
Donc ma question : est-il possible sans jack juste avec .asounrc d'avoir du son youtube et skype .; à contrario serait il possible avec jack d'avoir un changement de rate automatique ?

J'ai essayé d'installer mpd sans succès; je ne doute pas d'y arriver mais est-ce vraiment utile dans mon cas ?     

Mon second PC est un vieux PC DELL de 2008 une tour Inspiron sur lequel j'ai installé KXSTUDIO suite à de nombreux échanges qui me conseillaient d'installer une distribution spécialisée pour résoudre mes problèmes de XRUN chacun y allant bien sur de sa distribution préférée.
Les problèmes de XRUN et de changement de rate non automatiques sont les mêmes; le noyau low latency ( certes la machine n'est pas très puissante) n'a pas résolu le problème de XRUN même si ceux ci ne sont pas plus catastrophiques qu'avec le premier PC; l'objectif étant à terme de changer ce PC par un plus puissant et entièrement dédié à la musique.

Dernière modification par philippe010 (Le 23/02/2016, à 08:11)

Hors ligne

#8 Le 23/02/2016, à 16:29

dja75

Re : problème avec DAC TEAC UD503

Bonjour,

Votre montage a l'air complexe sans raison.
kxstudio, je ne vois pas le but dans votre cas. C'est jackd avec interface graphique. Vous n'avez pas besoin de ca.
Et relancer un quelconque soft parce que vous changez de rate/format sur les fichiers n'est pas viable.

Est-ce que sous alsa pur, vous devez faire une opération lorsque vous changez de rate/format de fichier?
En théorie, non.
Si c'est le cas, vous avez un problème sur le layer alsa (similaire à ce que j'ai corrigé pour le ud-503 dans le kernel),
donc ca impactera n'importe quelle surcouche, jack ou pulseaudio inclus.

En alsa pur:
Youtube (google-chrome 100% sûr, sur firefox j'ai déjà eu des problèmes) fonctionne sans problème directement, si tenté que votre dac gére nativement le format, ce que je pense.
Vous devez couper la musique avant (stop) pour que votre lecteur de musique rende la main sur le device donc le dac.
Sans alsa dmixer, et donc en configuration bitperfect. C'est du direct et c'est bien le but d'ailleurs.
C'est la même configuration que j'ai à mon bureau avec le ud-501.

Pour Skype, il doit en être de même pour le playback via le dac.
Par contre il faut rajouter une ligne de configuration dans le asound pour l'entrée mic (je suppose de votre carte mère?).

La seule raison d'avoir une deuxième machine serait d'avoir besoin d'un NAS pour stocker de manière pereine vos fichiers.
Pour ma part, chez moi, j'ai une machine qui fait office de nas raid10 8To efficace, dans un placard, et une machine qui fait lecteur en fanless, totalement silencieuse avec un petit ssd.

MPD gére une base de donnée de l'ensemble du catalogue de musique, multi format, mp3, flac, dsf.
C'est ultra pratique. MPD est un serveur donc est live tout le temps. Vous lui dites via le client de charger tel ou tel playlist, de rafraichir sa base de fichiers, etc..
Chez moi, il gére de manière totalement transparente 2.5To de musique sur un simple pentium G3258 et aucune charge à signaler.

Hors ligne

#9 Le 23/02/2016, à 16:50

philippe010

Re : problème avec DAC TEAC UD503

Bonjour,
Sous alsa pur je n'ai pas besoin d'arrêter et relancer pour changer de rate et ce fut vraiment le point positif suite à votre post mais skype et youtube ou autre video ne semblent plus marcher ( ce n'est peut-être pas difficile à corriger)..
j'ai cru comprendre que Skype  avait besoin de Pulseaudio .
"Skype pour Linux prend en charge les systèmes audio PulseAudio et ALSA. Depuis la version 4.3, le système audio ALSA n’est plus pris en charge sans PulseAudio."
https://support.skype.com/fr/faq/FA1096 … pour-linux

Oui j'ai besoin d'une entrée micro mais comment peut-on l'ajouter dans asoundrc.?

La complexité du soft vient des divers forum sur lesquels j'ai été français et anglais; quand on est nouveau on écoute on essaie ce qu'on nous conseille avant d'apprendre et pour beaucoup point de salut sans version audio spécialisée d'où mon test avec KXSTUDIO.

Si j'ai l'occasion d'alléger tout ce soft et rendre ma configuration plus simple, je fonce .. mais encore faut il savoir le faire ....

Hors ligne

#10 Le 23/02/2016, à 17:49

philippe010

Re : problème avec DAC TEAC UD503

Après d'autres essais les videos marchent sous chrome mais pas encore sous Firefox

Hors ligne

#11 Le 24/02/2016, à 11:45

dja75

Re : problème avec DAC TEAC UD503

Bonjour Philippe,

ok, donc skype avec pulseaudio seulement, c'est "foutu"...
Pulseaudio n'autorisant pas de mode sans resampling.
Le problème c'est que pour faire cohabiter les deux, il faudra couper pulseaudio et le réactiver ensuite.
Pulseaudio se comporte comme un soft de playback et monopolise l'interface alsa.

Je n'ai pas trop de solution miraculeuse pour rester en alsa bit-perfect et faire cohabiter les deux alors.
Il reste la solution bête et efficace de séparer les activités physiquement par un petit nuc qui serait dédié
au player de musique en bitperfect... et rester en pulseaudio pour votre desktop.
MPD prend tout son sens dans ce contexte, headless (sans écran).
Le plus petit processeur intel (ou arm) suffit pour jouer de la musique en bitperfect, il n'y a pas de resampling donc
aucun travail. Il faut juste un usb2 stable.
J'en suis arrivé à cette solution chez moi pour être tranquille, séparer les fonctions physiquement pour
que ce soit pereine. Ca m'a permis en plus de mettre une alimentation linéaire dédiée au nuc.

Tenez moi au courant ;-) et bon courage dans votre quête.

Hors ligne

#12 Le 24/02/2016, à 18:04

philippe010

Re : problème avec DAC TEAC UD503

Bonjour Guillaume,

Vos conseils ( encore merci !) ont permis à la solution de prendre forme; avant de tester avec MPD, je pense que je vais continuer de tourner avec JACK ( que j'ai déjà) sur ma machine universelle que je n'activerais et Pulseaudio avec qu'en cas de besoin Skype ce qui est rare en mode audio par rapport aux besoins d'écoute de la musique et l'arrêter quand je n'ai plus de besoin du même Skype; et puis sur un autre pc un solution simple avec Alsa sans Jack sans distribution spécialisée sans Skype sans Pulseaudio où je mettrais tous mes CD.
J'ai encore un petit problème que vous semblez avoir résolu : si l'utilisation de Skype est rare, celle liée à la lecture de vidéos sous Firefox l'est moins; ces mêmes vidéos tournent sous Chrome; quelle est la solution que vous avez trouvé avec FIrefox sans Pulseaudio ?

Hors ligne

#13 Le 25/02/2016, à 19:59

dja75

Re : problème avec DAC TEAC UD503

Bonjour,

Ca a marché... un jour... sur firefox. Mais effectivement impossible de le refaire marcher depuis environ un an.
J'avais essayé pas mal de trucs et laissé tomber, j'étais à l'époque sur le micromega mydac.
Ma solution de rempli a été de mettre un script pour passer en dmixer <=> bitperfect sur mon asound.conf... mais c'est nul.
... et comme ca marche sous chrome, je me dis que c'est firefox deconne.

J'avais:
- mis les defaults.* dans asound.conf... c'était pas ca.
- renuméroté la carte (le snd_usb_audio: 'modprobe snd slots=snd-usb-audio') en '0' dans alsa... c'était pas ca.
- vérifié les packages gstreamer, ffmpeg, c'était pas ca.

Mais c'est un mal pour un bien, une vie sans youtube, ca fait gagner beaucoup de temps ;-)

Hors ligne

#14 Le 26/02/2016, à 08:33

philippe010

Re : problème avec DAC TEAC UD503

Bonjour,

Dans tous les échanges, j'ai oublié de préciser que la solution de Guillaume m'a permis de totalement éliminer les XRUN.
Conclusion pour ceux qui découvrent : si vous voulez utiliser votre PC uniquement pour écouter de la musique en bitperfect sans resampling , oubliez les distributions spécialisées ventées sur les sites spécialisé en MAO, adieu Jack, Cadence et autres, leur utilisation génèrent les XRUN qu'ils sont censés éliminer .....   
A bon entendeur ....

Hors ligne

#15 Le 07/10/2019, à 18:03

cdr

Re : problème avec DAC TEAC UD503

dja75 a écrit :

Bonjour,

Le patch kernel a été validé et en cours de propagation sur ubuntu.

Probleme de timing usb avec l'interface du teac nt/ud-503.
Il concerne également l'UD-501 dans une moindre mesure.

Si vous êtes pressé, vous pouvez l'installer vous-même:
snd-usb-audio-patch

Bonjour, je déterre....

je possède aussi un UD-503, ce dernier est relié à un lecteur réseau Allo Usbridge sous Dietpi et un NAS Qnap pour le stockage. Je ne connais rien à tout ce qui touche Linux.

J'ai tenté de faire fonctionner tout ce petit monde, via Gmrender Minimserver et Bubbleupnp en bit perfect (j'ai uniquement des fichiers en Flac ou en DSD64 et 128) sans succès et la méthode qui fonctionne le mieux est via Squeezelite avec QLMS sur le NAS. Problème lors des changements de résolutions PCM vers DSD ou l'inverse voir même entre DSD et DSD, je me retrouve avec un bon gros claquement dans les enceintes. J'ai contacté TEAC et Allo et ce sans succès quant à leurs propositions pour enrayer le problème.

J'ai rien compris avec MPD, qui est utilisable aussi via l'Usbridge.

Est-ce que quelqu'un part ici pourrait me secourir ?

Par avance merci.

cdr

Hors ligne

#16 Le 07/10/2019, à 18:41

philippe10

Re : problème avec DAC TEAC UD503

Hello,
demander à l'expert DJA75, Guillaume.
J'en profite pour actualiser sur Firefox, apulse ca marche
"export APULSE_PLAYBACK_DEVICE=plughw:UAC2,0
apulse firefox
https://forum.ubuntu-fr.org/viewtopic.php?id=2032913

https://stackoverflow.com/questions/130 … e-in-linux


security.sandbox.content.level should be lowered from 3 to 2 (edit: this step might be unnecessary with proper whitelist settings).
security.sandbox.content.read_path_whitelist should be set to /dev/snd/,/home/username/.asoundrc
security.sandbox.content.write_path_whitelist should be set to /dev/snd/ (the trailing slashes are important)
security.sandbox.content.syscall_whitelist should be set to 16, which is the syscall number for ioctl (on x86-64, on 32bit x86 systems the ioctl number is 54).

More this one :

security.sandbox.content.level 0
security.sandbox.content.syscall_whitelist 16
security.sandbox.content.write_path_whitelist /dev/snd/"

Hors ligne

#17 Le 08/10/2019, à 18:19

cdr

Re : problème avec DAC TEAC UD503

philippe10 a écrit :

Hello,
demander à l'expert DJA75, Guillaume.

Bonsoir Philippe, merci pour la réponse, J'ai vu son site, mais pas trouvé où s'inscrire donc suis venu ici, et j'ai pas encore tout compris du fonctionnement du forum et si possibilité d'envoyer des MP ou autre àdja75/Guillaume

C

Hors ligne

#18 Le 13/11/2019, à 11:34

dja75

Re : problème avec DAC TEAC UD503

Bonjour,

Si la distrib DietPI a un kernel linux ~récent (moins de deux ans), il doit contenir le patch que j'avais soumis à l'époque.

Sur leur page: https://dietpi.com/
Le Allo a la version Debian Stretch ... donc ce n'est pas bon du tout. C'est un (trés) vieux kernel.

Si tu bricoles sous linux, tu devrais pouvoir le mettre à jour, leur channel Beta a une version recente.

Sinon, je ne pourrais que te conseiller d'oublier le Allo et potentiellement de prendre un petit player simple en Intel basse conso...
tu seras sûr de pouvoir installer la distribution que tu veux et ca marchera.

Hors ligne

#19 Le 14/11/2019, à 18:16

cdr

Re : problème avec DAC TEAC UD503

dja75 a écrit :

Bonjour,

Si la distrib DietPI a un kernel linux ~récent (moins de deux ans), il doit contenir le patch que j'avais soumis à l'époque.

Sur leur page: https://dietpi.com/
Le Allo a la version Debian Stretch ... donc ce n'est pas bon du tout. C'est un (trés) vieux kernel.

Si tu bricoles sous linux, tu devrais pouvoir le mettre à jour, leur channel Beta a une version recente.

Sinon, je ne pourrais que te conseiller d'oublier le Allo et potentiellement de prendre un petit player simple en Intel basse conso...
tu seras sûr de pouvoir installer la distribution que tu veux et ca marchera.

Bonjour Dja75,

merci pour ta réponse, ton patch est bien implanté dans le Allo.

J'ai refait des mises à jour et mon problème me semble avoir été résolu.

Merci à toi pour ton aide.

cdr

Hors ligne