Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 04/01/2017, à 01:49

krrkrr

Lubuntu sur PowerBook G4 1,33Ghz, 1,25 Go de Ram

Hello everybody !

Pour mon premier post, allons y avec une vieille brouette... j'ai donc un powerbook G4 qu'on ma refilé... les barettes de ram nazes. J'ai mis la main sur une de 1go et 1 de 256 mo... cool. La machine boote sous Os 10.4.

Je souhaiterais en faire un petit poste internet simple (consultation pages jaunes, post forum, etc...) et le fait que la machine soit trop ancienne pour moult choses actuelles me convient parfaitement, je ne veux pas qu'elle donne envie d'etre utilisé pour FB ou des jeux flash.

J'ai essayé le live ISO Lubuntu 12.04, 14.04 et 16.04. Seul le 14.04 s'est lancé... les autres m'ont tous annoncé un kernel panic rapidement. Le 14.04 s'est lancé mais la vidéo est à moitié brouillée. J'ai bien lu l'histoire qu'il faut taper une commande video dans yaboot.... sauf que... ben j'ai jamais eu le prompt yaboot ?!

Je me dit "bon, ok, on verra après" ... et je clique sur "install Lubuntu 14.04" .. et là, rien. Je peux cliquer sur l'icône tout ce que je veux, y compris l'icone dans les menus, rien. Ca donne l'impression de mouliner (les menus ne répondent plus pendant qq secondes) mais c'est tout. Je peux lancer un terminal, mais pas firefox, même moulinage. Sauf que rien ne semble mouliner... en dehors de l'attente. Le DVD gravé avec l'iso ne tourne pas spécialement... rien.

---

Je reboote, là j'ai le prompt yaboot, donc: live video=ofonly

la bureau arrive, c'est tout beau, pas de souci video... mais meme réaction. Je peux bien tenter de cliquer sur les app, la plupart ne se lancent pas. Je ne comprends pas. vu que le terminal se lance, est ce que je pourrais lancer l'install en commande ??

Merci !

Dernière modification par krrkrr (Le 08/01/2017, à 18:25)

Hors ligne

#2 Le 05/01/2017, à 00:26

krrkrr

Re : Lubuntu sur PowerBook G4 1,33Ghz, 1,25 Go de Ram

Bon je continue mes tentatives. J'ai téléchargé l'installa lternative, l'ai gravé sur CD et ai booté dessus.

Tout s'est bien passé (partition du disque et tout), puis, au cours de l'install, j'ai: "une erreur s'est produite [...] système cible. Paquet du Noyau: "linux-powerpc-smp" ....

et donc "installer le système de base" a échoué.... une idée ?

j'ai beau suivre scrupuleusement les informations... ca n'a pas l'air fonctionnel...

Hors ligne

#3 Le 05/01/2017, à 11:12

sevensky

Re : Lubuntu sur PowerBook G4 1,33Ghz, 1,25 Go de Ram

Salut il y a quelques années j'avais tenté une installation de pas mal de chose .....
Le seul truc qui fonctionne à peu près c'est MintPPC
http://mintppc.org/
Tiens nous au courant
Sevensky

Hors ligne

#4 Le 08/01/2017, à 18:22

krrkrr

Re : Lubuntu sur PowerBook G4 1,33Ghz, 1,25 Go de Ram

Aucune version de mintppc n'a réussi à booter le MacBook, meme simplement pour l'install...

Après plusieurs tentatives, c'est la version netinstall de Lubuntu 14.04 qui a fait le job, du moins pour aller jusqu'à l'install et finir celle ci.

J'ai donc pu booter sous Lubuntu mais évidemment en rentrant les paramètres video=radeonfb:1024x768-32  comme précisé dans la FAQ sur Ubuntu pour PowerPC. J'avais noté que, normalement, sur les versions plus récentes (à partir de 10.10) le souci avec les radeon ne se posaient plus.... j'ai donc rapidement lancé une mise à jour en 16.04.01 ... la mise à jour se fait, tout se lance mais quand j'arrive sur le bureau (après le splash screen qui semble fonctionner sans problème) : écran noir avec juste la souris en blanc que je peux bouger ...
Je reboote, rajoute derechef mon video=radeonfb:1024x768-32    mais ca ne change rien, meme souci. J'ai cru comprendre que le driver qui gérait la radeon, après la version 14, ce n'était plus radeonfb ... mais je ne suis pas sur d'avoir tout bien compris quand j'ai relu la FAQ..
Je parle ce celle ci: https://wiki.ubuntu.com/PowerPCFAQ#What … roblems.3F

Pour info, lspci me dit bien que j'ai une V350/M10 / V350/M11 Mobility Radeon 9600 / 9700 ...  ce qui est logique puisque le modèle que j'ai a bien une Radeon 9600 Mobility 64 Go.
J'ai du mal à comprendre ce que je devrais tester, dans les différents cas décrits dans la FAQ.

Actuellement je suis retourné en 14.04... mais dans l'idée, je souhaiterais aller en 16.04 bien sur... et pouvoir utiliser l'ordi sans avoir à rentrer des codes à chaque boot.

Hors ligne

#5 Le 09/01/2017, à 00:22

krrkrr

Re : Lubuntu sur PowerBook G4 1,33Ghz, 1,25 Go de Ram

Bon, la mise à jour en 16.04 ne smeble plus vouloir se lancer du tout.

En attendant, j'ai modifié le conf de yaboot pour ne pas avoir à rentrer le code radeonfb à chaque fois..... donc je boote en 14.04 et ca marche. C'est pas super fluide mais ca marche.

reste plus qu'à faire pareil en 16.04 éventuellement.

Est ce que certains ont une expérience démontrant que Xubuntu serait plus fluide que Lubuntu sur une machine G4 de ces époques ?

Hors ligne