Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/08/2017, à 11:58

sebastien31

Erreur lors de l'installation de postfixadmin (setup)

Bonjour à tous,
Je suis débutant et j'essaie de créer un serveur mail,
j'ai installer postfix, et mysql-serveur.
J'ai aussi installer le paquet postfixadmin,
quand je vais sur la page setup.php de postfixadmin.
il semblerai que tout soit correct niveau parametre.
voici les informations de la page.

Running software:

PHP version 7.0.18-0ubuntu0.16.04.1
Apache/2.4.18 (Ubuntu)
Checking for dependencies:

Magic Quotes: Disabled - OK
Depends on: presence config.inc.php - OK
Checking $CONF['configured'] - OK
Depends on: MySQL 4.1 - OK
Testing database connection - OK - mysqli://postfixadmin:xxxxx@localhost/postfixadmin
Depends on: session - OK
Depends on: pcre - OK
Depends on: multibyte string - OK
Depends on: IMAP functions - OK
Everything seems fine... attempting to create/update database structure

Updating database:

- old version: 0; target version: 740

updating to version 1 (MySQL)...

DEBUG INFORMATION:
Invalid query: Invalid default value for 'created'

Je ne comprends pas d'ou vient le problème? pouvez-vous m'aider s'il vous plait?

Merci pour votre lecture et votre aide.
Cordialement.
Sébastien

Hors ligne

#2 Le 03/11/2017, à 05:59

MCI225

Re : Erreur lors de l'installation de postfixadmin (setup)

salut sebastien31,
tu dois désactiver le mode "strict" de mysql-server pour cela il faut editer le fichier "/etc/mysql/my.cnf
"  pour ajouter
[mysqld]
sql_mode = ''
ensuite redemarrer la machine.

Hors ligne