Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 23/10/2017, à 18:24

Paulo CDG

[Résolu] Problème affichage LXDE seulement au 1er lancement après boot

Bonjour,

J'ai installé lubuntu sur un vieux netbook Asus EePC (1001HA) et je suis assez satisfait du résultat. Tout fonctionne parfaitement, wifi, ouverture de mes fichiers libreoffice, navigation web, lecture de vidéo, et même la télé d'Orange. J'ai juste un petit problème que j'arrive à contourner mais je préfèrerais lui trouver une vraie solution.

Lors du démarrage de la machine, le premier écran de login est illisible, il y a des lignes de caractères incompréhensibles sur fond noir à gauche et seulement une étroite partie "normale" de l'écran de connexion à droite. J'arrive à me connecter à l'aveugle mais le problème persiste.

Pour que tout aille bien il suffit, lorsque je suis sur l'écran de login corrompu, de mettre le PC en veille avec le bouton marche/arrêt de lubuntu (qui est présent sur l'étroite bande d'écran correct) ou avec la touche bleue Fn+F1 de mon clavier, puis réveiller le PC et là tout va bien je retrouve bien l'écran de login correct.

Ensuite, si je me déconnecte je retrouve bien l'écran de login, il n'y a qu'à sa première exécution après boot qu'il y a un problème.

Merci de m'avoir lu,
Paulo

Dernière modification par Paulo CDG (Le 24/10/2017, à 18:35)

Hors ligne

#2 Le 24/10/2017, à 08:20

moko138

Re : [Résolu] Problème affichage LXDE seulement au 1er lancement après boot

Montre

lsb_release -d; printenv GDMSESSION ; uname -mr
xrandr

et

cat /etc/default/grub

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#3 Le 24/10/2017, à 11:15

Paulo CDG

Re : [Résolu] Problème affichage LXDE seulement au 1er lancement après boot

Merci Moko de t'intéresser à mon petit problème. Voici les résultats :

$ lsb_release -d; printenv GDMSESSION; uname -mr
Description:	Ubuntu 17.10
Lubuntu
4.13.0-16-generic i686

$ xrandr
Screen 0: minimum 8 x 8, current 1024 x 600, maximum 32767 x 32767
LVDS1 connected primary 1024x600+0+0 (normal left inverted right x axis y axis) 220mm x 130mm
  1024x600      60.00*+  65.00  
  800x600       60.32    56.25  
  640x480       59.94  
  512x300       60.00  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
$

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 24/10/2017, à 13:09)

Hors ligne

#4 Le 24/10/2017, à 13:27

moko138

Re : [Résolu] Problème affichage LXDE seulement au 1er lancement après boot

Fais d'abord une copie de sécurité - pour pouvoir revenir facilement en arrière en cas de pépin - du fichier avant modification :

sudo cp -av /etc/default/grub  /etc/default/grub.2017-10-23

Ensuite lance leafpad, ton éditeur de texte,
crée un nouveau fichier,
copie-colles-y ceci :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480  ## ligne originelle
GRUB_GFXMODE=1024x600

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
GRUB_INIT_TUNE="480 440 1"

Enregistre ce nouveau fichier sous le nom de grub.2017-10-24, dans ton home, mais attention : directement dans /home/$USER, pas dans ton bureau ni ailleurs.

Ensuite :

sudo cp -v /home/$USER/grub.2017-10-24  /etc/default/grub; sudo update-grub && sudo mv /home/$USER/grub.2017-10-24  /etc/default/

  - -

/!\  Ne cherche surtout pas à retaper ces commandes !   Utilise
- un triple clic gauche sur une ligne pour la sélectionner tout entière et la copier,
- un clic milieu pour la coller.
  - -


Nous n'avons pas fait le test de vbeinfo, donc il faudra peut-être tâtonner encore avant de trouver le réglage adéquat.
  - -

À l'avenir,
1) merci de penser à donner des retours complets.
  Un retour complet doit contenir toutes les lignes,
depuis celle, entière, de la commande
jusqu'à la ligne attendant la commande suivante
, exemple :

moi@mon-pc~$: ma-commande
son retour
moi@mon-pc~$:

Faute de quoi, il manque souvent à ceux qui tentent de t'aider des éléments essentiels.

(Plus de détails dans ce message-ci Retour utilisable de commande.)
  - -

2) Et mets les retours entre balises-code,

comme ceci,

au moyen de
1482181232.jpg


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#5 Le 24/10/2017, à 15:14

Paulo CDG

Re : [Résolu] Problème affichage LXDE seulement au 1er lancement après boot

Mille excuses pour les balises, je ferai attention.

J'ai scrupuleusement appliqué tes consignes et ça n'a rien changé, mais ça m'a mis sur la piste et je suis allé voir ce qu'on pouvait modifier ou ajouter d'autre dans la configuration de grub. Comme mon problème ne se manifeste qu'au boot, j'ai ajouté cette ligne aux paramètres de grub :

GRUB_GFXPAYLOAD_LINUX="text"

J'ai cru comprendre que ça force l'affichage du boot en mode texte et en effet tout va bien désormais, je vois bien défiler les messages du boot, puis l'invite de login apparaît en mode texte un bref instant et elle est immédiatement remplacée par l'écran graphique de connexion.

Comme shares-admin s'obstine à prétendre à tort que samba n'est pas installé, j'ai utilisé system-config-samba pour activer mes partages de dossiers sur le réseau. Désormais tout fonctionne parfaitement et relativement vite pour un Atom 1,6 GHz avec 1Go de RAM. Une nouvelle jeunesse inattendue pour un netbook qui a failli partir à la déchèterie wink

Merci beaucoup pour ton aide Moko, salutation à tous et à la modération.
Paulo

Hors ligne