Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/04/2018, à 10:06

sinbad83

Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Bonjour à tous,
je cherche à activer au boot le clavier numérique pour entrer le mot de passe plus facilement. J'ai rajouté /usr/bin/numlockx on dans /etc/rc.local mais l'activation ne se fait qu'après le démarrage complet. Quelqu'un connaît-il la bonne astuce pour Bionic ?

Dernière modification par sinbad83 (Le 14/05/2018, à 10:59)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 18.10 et Ten,   HP Pavillon G6 U18.04 et Ten, Samsung N150 U16.04 et Seven, Ubuntu 18.04/Ntopng, Serveurs Ubuntu 16.04

Hors ligne

#2 Le 14/04/2018, à 03:53

Vobul

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Regarde dans le BIOS (UEFI), y'a peut-être une case à cocher.


Vobul

Hors ligne

#3 Le 14/04/2018, à 09:38

sinbad83

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Le BIOS est en 2501 x64. Je n'ai trouvé que Etat verrouillage numérique au démarrage qui est en mode Activé.
Quand j'étais en 16.04, le verrouillage numérique pour le boot fonctionnait avec la modification apportée selon la doc https://doc.ubuntu-fr.org/numlockx.
Je viens d'essayer également sans succès de mettre "numlockx on" dans Applications au démarrage.

Dernière modification par sinbad83 (Le 14/04/2018, à 10:30)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 18.10 et Ten,   HP Pavillon G6 U18.04 et Ten, Samsung N150 U16.04 et Seven, Ubuntu 18.04/Ntopng, Serveurs Ubuntu 16.04

Hors ligne

#4 Le 14/04/2018, à 13:07

Jesski

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Bonjour,
Chez moi, il est activé par défaut :-), c'est un vrai bonheur :-).


Ubuntu 18.04 sur mon PC, Debian 9 sur mes serveurs. Config mini ITX :
CM : ASRock Fatal1ty AB350 Gaming ITX/ac. Ram : Corsair 8GB DDR4. CPU : Ryzen 5 1600. CG : MSI GeForce GT 1030 2GH OC. 120GB SSD + 1TB pour la partition home.
Usage : programmation, bureautique, compatibilité,  photoshop (virtualisation).

Hors ligne

#5 Le 14/04/2018, à 13:09

bipede

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Jesski a écrit :

Bonjour,
Chez moi, il est activé par défaut :-), c'est un vrai bonheur :-).

Chez moi aussi sur mon fixe, mais pas sur mon portable...


Desktop: MSI - Intel® Core™ i5-3330 CPU @ 3.00GHz × 4 - RAM 8 go- Ubuntu 18.10 - Système sur SSD 64 Go - /home sur HDD 500 Go.
Laptop: DELL Inspiron-15 3567 - Intel® Core™ i5-7200 CPU @ 2.50GHz × 4 - RAM 8 go - HDD 1 To - Ubuntu 18.10 avec /home séparé.

Mon site: Les contributions du bipède

Hors ligne

#6 Le 14/04/2018, à 14:53

sinbad83

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Jesski a écrit :

Bonjour,
Chez moi, il est activé par défaut :-), c'est un vrai bonheur :-).

Tant mieux pour toi. Mais quelle est ta version Ubuntu ? 18.04 ?

Dernière modification par sinbad83 (Le 14/04/2018, à 14:54)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 18.10 et Ten,   HP Pavillon G6 U18.04 et Ten, Samsung N150 U16.04 et Seven, Ubuntu 18.04/Ntopng, Serveurs Ubuntu 16.04

Hors ligne

#7 Le 02/05/2018, à 09:11

Compte anonymisé

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Idem, plus de clavier numérique au démarrage depuis Ubuntu 18.4 et GDM3.

J'ai tout essayé mais rien ne fait. C'est très pénible car caractères num dans mot de passe et changement de PC fréquent.

Je pensais que Lightdm avait définitivement tué Gdm, mais ca n'a pas l'air d'etre le cas.

#8 Le 02/05/2018, à 09:25

yano1966

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

C'est bon à savoir pour que ceux qui utilisent des chiffres n'en mettent plus.


PC Assemblé P55-USB3 - intel i7 870 - 8Go -  AMD HD6970 - DD : 500Gb + 1Tb - Linux Mint 19 Cinnamon 64-bit "Tara".
Dell Dimension 5150 - Pentium D - 3,5Go - Radeon HD5450 - DD: 160Gb - Linux Mint 19 Cinnamon 64-bit "Tara".

Hors ligne

#9 Le 04/05/2018, à 17:53

sinbad83

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

La procédure à suivre pour s"affranchir du problème à la saisie du login, est de prendre l'habitude de rentrer les chiffres du mot de passe au clavier normal et l'ordinateur prendra en compte tout seul numlockx qui a été inséré dans le fichier /etc/rc.local (cf #1 du post) pour la suite de la session.
Il faut naturellement avoir installé numlock...

Dernière modification par sinbad83 (Le 04/05/2018, à 18:05)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 18.10 et Ten,   HP Pavillon G6 U18.04 et Ten, Samsung N150 U16.04 et Seven, Ubuntu 18.04/Ntopng, Serveurs Ubuntu 16.04

Hors ligne

#10 Le 05/05/2018, à 09:02

hyperion

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Pour moi cela fonctionne, nouvelle installe en 18.04
j'ai installé numlockx et ajouter les lignes suivantes dans /etc/gdm3/Init/Default juste avant exit 0  à la fin du fichier.

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi

Hors ligne

#11 Le 05/05/2018, à 09:49

frenchy82

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Ne fonctionne pas sous 18.04 chez moi avec une installation neuve et pourtant j'ai testé beaucoup de choses

Hors ligne

#12 Le 05/05/2018, à 11:04

lynn

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Bonjour,

Il n'y a pas besoin du paquet numlockx pour la suite.

sudo -i
su gdm -s /bin/bash
gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

Après avoir redémarré la machine, la saisie des chiffres en utilisant le pavé numérique devrait être possible.

https://askubuntu.com/questions/1028428 … gin-screen
https://askubuntu.com/questions/977903/ … 10-wayland


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

En ligne

#13 Le 05/05/2018, à 11:30

frenchy82

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Mille merci lynn smile

Effectivement, j'ai désinstallé nulockx et en changeant la valeur cela fonctionne!

Chez moi il était sur la valeur par défaut qui est "unknown"

Hors ligne

#14 Le 05/05/2018, à 11:50

lynn

Re : Bionic 18.04: clavier numérique au boot [Résolu. Merci à Lynn]

Tant mieux si ça fonctionne. smile

Ce que je ne m'explique pas, sans lancer un troll ou incriminer qui que soit, c'est que ce genre de truc ne soit pas inclus par défaut à la reconnaissance du clavier lors d'une l'installation ou après un changement de celui ci...

Et si ce n'est pas possible en détection automatique, alors une option pour modifier ce comportement aurait toute sa place dans les paramètres du clavier.

Avis aux dev d'ubuntu. smile


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

En ligne