Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 10/11/2017, à 18:38

ptitjoz

[Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Bonjour
je suis sous Lubuntu 17.10 64 bits

Au démarrage tout démarre bien, les réseaux wifi sont visibles
widi all

et je peux y rester connecté sans soucis plusieurs heures.

J'ai constaté que je ne voyais plus, au bout d'un moment qu'un seul wifi le mien alors qu'en réalité il y en d'autres, mais ça continue à fonctionner.
wifi alone

Cependant si il y a une coupure pour une raison quelconque, je suis obligé de redémarrer l'ordinateur car je ne peux plus rien faire avec les commandes dans l'applet la déconnexion/reconnexion ne fonctionne plus. !

Pire encore mais je ne sais pas si c'est lié, je n'arrive pas à redémarrer proprement, le logo Lunbutu avec des points n'en fini de tourner.
En faisant ESC  je vois que  ça bloque sur des messages style
[ ***] A stop job is running for Network Name Résolution
qui ne s'arrêtent pas !


Donc j'utilise les touches dites magiques... pour forcer le démarrage sad
avez vous des explications ?

Merci de vos conseils

Dernière modification par ptitjoz (Le 16/11/2017, à 10:18)


Lubuntu 17.10 64 Bits

Hors ligne

#2 Le 13/11/2017, à 09:33

ptitjoz

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Bonjour
un peut Up..

personne n'a d'idée pour mon problème ?


Lubuntu 17.10 64 Bits

Hors ligne

#3 Le 13/11/2017, à 20:09

metalux

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Bonjour ptitjoz,
Si tu veux de l'aide commence d'abord par lire ceci et vient poster le résultat.
Quand tu pers le réseau, as-tu essayé de décocher puis recocher "activer le réseau"?
Essaye également de relancer NetworkManager avec cette commande:

sudo systemctl restart network-manager.service

Est-ce que ça change quelque chose? Il faudra peut-être décocher/recocher la case "activer le réseau" après cette commande.

Hors ligne

#4 Le 14/11/2017, à 14:57

ptitjoz

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Bonjour @metalux ! et merci de t'interesser à ce problème
merci de ton aide et ce n'est pas faute d'avoir chercher sur le forum donc je regarde ton fil
quand je décoche activer / désactiver les réseaux ou le wifi ça ne marche pas et j'ai l'impression que le programme est figé.
quand je passe ta commande "sudo systemctl restart network-manager.service" mon ordi freeze complètement (sauf le déplacement de la souris) et je suis obligé de rebooter avec les touches magiques sad

suite

wget -N -t 5 -T 10 https://framagit.org/cracolinux/wificheck/raw/master/wificheck && chmod +x wificheck && ./wificheck
--2017-11-14 14:58:53--  https://framagit.org/cracolinux/wificheck/raw/master/wificheck
Résolution de framagit.org (framagit.org)… 144.76.206.42, 2a01:4f8:200:1302::42
Connexion à framagit.org (framagit.org)|144.76.206.42|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 2012 (2,0K) [text/plain]
Enregistre : «wificheck»

wificheck           100%[===================>]   1,96K  --.-KB/s    ds 0s      

En-tête de dernière modification manquant — horodatage arrêté.
2017-11-14 14:58:54 (54,6 MB/s) - «wificheck» enregistré [2012/2012]

[sudo] Mot de passe de joz : 

lo        no wireless extensions.

./wificheck: ligne 58: ifconfig : commande introuvable
wlp1s0    Interface doesn't support scanning : Device or resource busy

lo        Interface doesn't support scanning.

./wificheck: ligne 74: nm-tool : commande introuvable
Error: argument 'status' not understood. Try passing --help instead.
Le fichier wificheck.log a été crée dans /home/joz  
Vous n'avez plus qu'à copier/coller son contenu sur le forum
 accès →→ file://home/joz/wificheck.log

et le fichier est vide

je vois que ifconfig n'est pas installé donc

sudo apt install net-tools

je relance la commande et même résultat il n'y a pas de fichier log créé

pour info je colle le résultat de ifconfig

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 220  bytes 17608 (17.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 220  bytes 17608 (17.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.137.142  netmask 255.255.255.0  broadcast 192.168.137.255
        inet6 fe80::3c36:c8e5:9271:54c2  prefixlen 64  scopeid 0x20<link>
        ether f0:03:8c:ab:86:03  txqueuelen 1000  (Ethernet)
        RX packets 783  bytes 460450 (460.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 762  bytes 144266 (144.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[Ajout ] et  commande lspci

lspci | grep -i net
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

Dernière modification par ptitjoz (Le 14/11/2017, à 15:36)


Lubuntu 17.10 64 Bits

Hors ligne

#5 Le 14/11/2017, à 22:37

metalux

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Qualcomm Atheros QCA9377

tente l'installation de pilotes récents:
D'abord sauvegarde les anciens

cp -R /lib/firmware/ath10k/QCA9377  ~

Puis:

sudo apt-get update
sudo apt-get install git
git clone https://github.com/kvalo/ath10k-firmware.git
cd ath10k-firmware/QCA9377/hw1.0
sudo cp *  /lib/firmware/ath10k/QCA9377/hw1.0

ensuite postes moi le contenu de ce dossier que je t'indique ce qu'il faut faire:

 ls /lib/firmware/ath10k/QCA9377/hw1.0

A moins que tu saches le faire, il faut remplacer les fichiers de ce dossier par ceux télécharger tout en renommant firmware-5.bin_WLAN.TF.1.0-00002-QCATFSWPZ-5 en firmware-5.bin, la seule chose c'est que j'ai un doute du chemin exact comme je ne l'ai pas installé moi-même, voilà pourquoi j'ai besoin du ls avant la suite (dans ath10k-firmware/QCA9377/hw1.0/WLAN.TF.1.0/ ?)
Donne moi le retour du terminal lors de la procédure au cas ou j'ai oublié quelque chose.

Recharge ton module ensuite avec modprobe ou redémarre, ça revient au même.
Je ne connais pas bien le wifi, pour avoir une aide plus pertinente, tu peux donner les commandes à partir de ce sujet si tu n'as pas réussi avec wificheck.

Hors ligne

#6 Le 14/11/2017, à 23:06

xubu1957

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Bonjour,

Le fichier wificheck.log a été crée dans /home/joz  
Vous n'avez plus qu'à copier/coller son contenu sur le forum
cracolinux a écrit :

Vous trouverez ensuite un fichier wificheck.log dans votre répertoire personnel, collez l'intégralité de son contenu dans votre discussion.

Le fichier est à chercher dans le /home.

Dernière modification par xubu1957 (Le 14/11/2017, à 23:17)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

En ligne

#7 Le 15/11/2017, à 00:45

ptitjoz

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

bonjour @metalux
j'ai passé les commandes et j'en suis là

sudo cp *  /lib/firmware/ath10k/QCA9377/hw1.0
cp: -r not specified; omitting directory 'CNSS.TF.1.0'
cp: -r not specified; omitting directory 'untested'
cp: -r not specified; omitting directory 'WLAN.TF.1.0'

et

ls /lib/firmware/ath10k/QCA9377/hw1.0
board-2.bin  board.bin  firmware-5.bin  notice_ath10k_firmware-5.txt

Dernière modification par ptitjoz (Le 15/11/2017, à 00:50)


Lubuntu 17.10 64 Bits

Hors ligne

#8 Le 15/11/2017, à 07:27

metalux

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

cd ~/ath10k-firmware/QCA9377/hw1.0/WLAN.TF.1.0
cp firmware.* /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

Redémarre ensuite et vois si c'est mieux.

Hors ligne

#9 Le 15/11/2017, à 08:35

ptitjoz

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Bonjour
pour info j'ai du taper le nom de fichier complet

sudo cp firmware-5.bin_WLAN.TF.1.0-00002-QCATFSWPZ-5 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

car les jokers ne marchent pas (peut-être à cause de certains caractères dans le nom du fichier et j'ai dû passer en root car je n'avais pas les droits.
Quelques essais et tout  semble fonctionner ! :
* déconnexion / reconnexion d'un réseau
* désactiver / activer le  réseau wifi
* déconnexion / reconnexion le réseau

* L'arrêt ou redémarrage du pc fonctionne maintenant sans blocage alors je pense ne plus avoir besoin des  touches magiques !

et là je te dis Bravo ! smile

Est-ce que, dans les prochaines releases de (L)ubuntu, le problème sera-t-il réglé sans avoir à faire toutes ces manips ?

pour info mon portable est un Asus T101HA

J'ai quelques autres problèmes que j'ai résolu à ma sauce (je posterai peut-être des tickets concernant ces  sujets) mais bon, là je suis opérationnel à 99% sur cette petite machine ! encore Merci

Bien cordialement smile

Dernière modification par ptitjoz (Le 15/11/2017, à 08:38)


Lubuntu 17.10 64 Bits

Hors ligne

#10 Le 15/11/2017, à 22:29

metalux

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

Oui, bon pour les erreurs de regex, ça confirme que je ne suis décidément pas du matin! tongue l'astérisque était suffisante, pas besoin du point et là, tu pouvais copier sans le nom entier. Pour passer en root, ça me parait tellement évident que je l'ai omis, j'ai posté vite fait avant de partir au boulot et je n'ai pas pris la peine de relire et de voir ce qu'il fallait corriger/préciser.

Est-ce que, dans les prochaines releases de (L)ubuntu, le problème sera-t-il réglé sans avoir à faire toutes ces manips ?

Je n'en sais rien mais c'est possible vu qu'ici tu utilises une version plus récente du pilote. Après sur Gnu/Linux, il y a parfois des régressions également et ce qui fonctionnait sur un noyau, ne fonctionne plus sur un plus récent. Le mieux est de tester en live dans un 1er temps avec une 17.10 par exemple.
La méthode n'est pas forcément à appliquer à la lettre, il faut voir comment l'arborescence des dossiers est conçue au moment de la récupération sur Github. Tu peux te garder cette version pour l'instant si tu avais besoin de réinstaller une 16.04
Je me suis inspiré de ce lien mais comme tu vois, pas besoin de créer le répertoire qui existe déjà et le chemin vers firmware-5.bin_WLAN.TF.1.0-00002-QCATFSWPZ-5 a changé (son nom aussi d'ailleurs).

Si tu pouvais passer en résolu ton sujet en éditant ton 1er message, tu pourras éditer le titre. Indique en un plus explicite genre :
"Atheros QCA9377 obligé de rebooter si perte de connexion wifi"

J'ai quelques autres problèmes que j'ai résolu à ma sauce

En faire profiter la communauté en participant à la documentation concernant ce modèle de Pc serait une bonne idée, n'est-ce pas? wink

Hors ligne

#11 Le 16/11/2017, à 10:23

ptitjoz

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

metalux a écrit :

Si tu pouvais passer en résolu ton sujet en éditant ton 1er message, tu pourras éditer le titre. Indique en un plus explicite genre :
"Atheros QCA9377 obligé de rebooter si perte de connexion wifi"

J'ai quelques autres problèmes que j'ai résolu à ma sauce

En faire profiter la communauté en participant à la documentation concernant ce modèle de Pc serait une bonne idée, n'est-ce pas? wink

ok et encore merci !
Voila c'est passé en résolu en changeant le titre du billet.
je veux bien faire participer le communauté mais il y a un lien spécifique pour cela ?


Lubuntu 17.10 64 Bits

Hors ligne

#12 Le 16/11/2017, à 12:50

metalux

Re : [Résolu] Atheros QCA9377 obligé de rebooter si perte de connexion wifi

regarde ici, tu peux ajouter des liens vers les discussions que tu as ouvertes concernant ce modèle. Essaye de regarder le modèle exact si il y a des références après Asus T101HA car il y a déjà quelque chose dans la documentation mais ça ne parle pas de problèmes wifi, tu dois avoir une variante de ce PC, ça serait bien de préciser. Tu trouveras plus de détail avec cette commande:

cd ~
sudo lshw > matériel.txt

Ensuite tu trouveras un fichier matériel.txt dans ton dossier utilisateur avec tout le détail de ton Pc. Le modèle exact est souvent en début de fichier sous l'appellation "produit"
Pour éditer la documentation, lis d'abord ces 2 pages:
https://doc.ubuntu-fr.org/wiki/participer_wiki
https://doc.ubuntu-fr.org/wiki/syntaxe
Si comme moi tu n'es pas à l'aise avec la syntaxe, je participe occasionnellement en copiant/collant des bout de pages déjà rédigées et en changeant le contenu, ça simplifie la mise en forme (à visualiser/retoucher quand même avant de valider).
Bonne journée smile

Hors ligne