Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/04/2018, à 03:37

Ozda

[Résolu] Problème affichage et lancement Steam GTX1060

Bonjour

Pour mon travail je dois passer sur Ubuntu mais j'ai quelque problème avec ce système hmm .
J'ai donc Ubuntu 17.04 sur un SSD de 128Go et Windows sur un HDD de 1To dans mon PC portable

J'ai dû installer Steam (pour le travail donc nécessaire), mais je ne peux pas le lancer (par commande (message d'erreur plus bas) et par clique sur l'icone). j'ai fais des recherche suite à ça, et je n'ai trouvé que de mettre les pilotes propriétaire de ma carte graphiques Nvidia plutôt que ceux libre. Un problème est survenue suite à ce changement. Mon pc bootait sur ubuntu en écran noir, impossible à utiliser donc. Je suis donc repasser au pilote libre en supprimant les pilote Nvidia en mode recovery (technique trouver sur internet).
De plus lorsque l'écran s'éteint pour économiser la batterie (au bout de 5 minutes de base) il ne se rallume plus ensuite (en étant sur les pilotes libre), ce qui est très ennuyant .

Si vous avez des solutions je suis bien sure preneur big_smile et si vous voulez plus d'info n'hésitez pas à demander wink

Merci

Ozda


Configuraton PC:
OMEN by HP 17-an098nf : http://store.hp.com/FranceStore/Merch/P … BF&sel=NTB
Intel i7-7700HQ
Nvidia GTX1060-6Go
16Go RAM
Ecran du pc portable : 75Hz en FHD(1920*1080)

Message d'erreur au lancement de steam :
Running Steam on ubuntu 17.10 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

résultat de la commande : lspci -vnn | grep '\''[030[02]\]' :
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c60] (rev a1) (prog-if 00 [VGA controller])

Dernière modification par Ozda (Le 18/04/2018, à 17:41)

Hors ligne

#2 Le 15/04/2018, à 08:08

xubu1957

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Bonjour,

J'ai donc Ubuntu 17.04...

Ta version zesty est périmée.

Depuis le 13 janvier 2018, Ubuntu 17.04 est en fin de vie (end of life, EOL). Elle ne profite plus de nouvelle mise à jour de sécurité et les paquets logiciels pour cette version sont déplacés dans des serveurs d'archive. Pour continuer à recevoir des mises à jour de sécurité, veuillez mettre à niveau votre version d'Ubuntu vers une version activement soutenue.

_ _ _

Après avoir sauvegardé tes données.  Tu peux essayer de migrer vers la version 17.10 :

Le 06/03/2018, malbo a écrit :

Non. Tu passes d'abord cette commande (l'option -c permet de vérifier l'existence d'une mise à niveau possible sans la lancer réellement) :

sudo do-release-upgrade -c

Chez moi, ça donne ceci depuis une session de Ubuntu 17.04 obsolète :

malbo@monpc:~$ sudo do-release-upgrade -c
[sudo] Mot de passe de malbo : 
Recherche d'une nouvelle version d'Ubuntu
Votre version d'Ubuntu n'est plus prise en charge.
Pour plus d'informations sur la mise à jour, veuillez visiter :
http://www.ubuntu.com/releaseendoflife

Nouvelle version « 17.10 » disponible.
Lancer « do-release-upgrade » pour mettre à niveau vers celle-ci.
malbo@monpc:~$ 

Pour lancer réellement la mise à niveau, il suffit de repasser la commande mais sans l'option -c :

sudo do-release-upgrade

_ _ _

Voir aussi, la page de Doc > migration

Dernière modification par xubu1957 (Le 15/04/2018, à 08:26)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 15/04/2018, à 10:19

Naziel

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Bonjour,

Avec la nvidia GTX 1060, tu ne pourras pas compter sur le pilote libre nouveau malheureusement. C'est bizarre que tu aies pu démarrer avec le pilote libre, tu peux donner le retour de

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX

Et je confirme ce que dit xubu1957: il faut passer sur une version d'ubuntu maintenue (la 17.10 est maintenue jusqu'en juillet 2018). En plus, ça te permettra aussi de faire la transition vers la 18.04.1 (qui sortira en juillet justement)

Dernière modification par Naziel (Le 15/04/2018, à 10:20)

Hors ligne

#4 Le 15/04/2018, à 10:42

GammaDraconis

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Tu es obligé de mettre le pilote propriétaire pour pouvoir jouer avec une carte nvidia ! Le pilote opensource n'est pas du tout performant.

Sinon comme on te l'a déjà dit, la 17.04 est obsolète, tu ne dois pas l'utiliser.

Dernière modification par GammaDraconis (Le 15/04/2018, à 10:43)


PC1 (Xiaomi Air 13) : dualboot avec Ubuntu 18.04LTS/Gnome et ArchLinux/Xfce (rolling)
PC2 (Lenovo Legion Y520) : quadrupleboot avec ArchLinux/Plasma, Ubuntu 18.04LTS/Gnome, OpenSuSe Tumbleweed/Plasma (rolling), win10
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#5 Le 15/04/2018, à 15:36

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Bonjour, merci de vos réponse extrêmement rapide, je suis assez impressionné de cette communauté smile

Je suis maintenant en 17.10 mais toujours le même problème pour les pilotes propriétaire mais avec une spécification différente. Lors du boot une ligne blanche clignote en haut de l'écran avec marqué :

/dev/nvme0n1p2: clean, 188328/7782400 files, 2474474/31127296 blocks

Naziel a écrit :

tu peux donner le retour de

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX

voila ce qu'elle retourne :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Merci encore cool

Ozda

Dernière modification par Ozda (Le 15/04/2018, à 16:07)

Hors ligne

#6 Le 16/04/2018, à 19:04

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

quelqu'un aurait une solution ? big_smile

Hors ligne

#7 Le 16/04/2018, à 22:39

Naziel

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Tu peux donner le retour de

dpkg -l | grep nvidia

Le but étant de trouver la version du pilote nvidia utilisé. Peut être que ce n'est pas la bonne version qui est utilisée.

Hors ligne

#8 Le 17/04/2018, à 20:40

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Merci de ta réponse smile

voila le retour de la commande :

ozda@ozda-OMEN:~$ dpkg -l | grep nvidia
rc  nvidia-390                                 390.48-0ubuntu0~gpu17.10.2                  amd64        NVIDIA binary driver - version 390.48
rc  nvidia-opencl-icd-390                      390.48-0ubuntu0~gpu17.10.2                  amd64        NVIDIA OpenCL ICD
rc  nvidia-prime                               0.8.5                                       amd64        Tools to enable NVIDIA's Prime
rc  nvidia-settings                            396.18-0ubuntu0~gpu17.10.1                  amd64        Tool for configuring the NVIDIA graphics driver

En attente de ta réponse smile

Ozda

Hors ligne

#9 Le 17/04/2018, à 22:57

Naziel

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Une petite recherche sur https://packages.ubuntu.com/ m'indique que nvidia-390 n'est pas dans les dépôts artful (c'est à dire de la 17.10). Ca s'arrête à nvidia-384. Donc d'où sort ce paquet? Comment as tu fait pour l'installer?

Dernière modification par Naziel (Le 17/04/2018, à 22:59)

Hors ligne

#10 Le 18/04/2018, à 02:43

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Via cette commande trouver sur le net :

sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt update

Et via ce Site

Comme je devais installer vite Steam afin de récupérer des logiciel (montage, audio), j'ai chercher sur d'autre site sans rien trouver de convainquant.

Ozda

Hors ligne

#11 Le 18/04/2018, à 09:21

Naziel

Re : [Résolu] Problème affichage et lancement Steam GTX1060

J'ai trouvé ça

https://ubuntuforums.org/showthread.php?t=2376573 a écrit :

I am running a desktop GTX 1060 fine with nvidia-381

Donc pas besoin de passer par un ppa normalement (d'ailleurs je sais pas ce qu'il vaut)
Donc je conseillerais dans un premier temps de l'enlever le ppa avec

sudo add-apt-repository --remove ppa:graphics-drivers/ppa
sudo apt update

et dans Software & Updates -> Additional Driver
il y a déjà pas mal de pilotes pour cette carte graphique dans les dépôts, tu peux essayer le 381 et si ça marche pas le 384 (qui doit maintenant être le dernier des dépôts)

Hors ligne

#12 Le 18/04/2018, à 15:49

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Merci de ta réponse.
Dans Additional-Driver, je n'est que le pilote proprietare 384 et le pilote libre et le pitole 384 ne fonctionne pas pour moi.
Lorsque je veux installer le 381, je pas par la ligne de commande suivante :

sudo apt-get install nvidia-381

et elle me retourne  :

ozda@ozda-OMEN:~$ sudo apt-get install nvidia-381
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet nvidia-381 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « nvidia-381 » n'a pas de version susceptible d'être installée

Ozda

Hors ligne

#13 Le 18/04/2018, à 16:33

Naziel

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Normalement, nvidia-384 devrait passer.
Dans le bios, le secure boot est bien désactivé?

Hors ligne

#14 Le 18/04/2018, à 17:26

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Bonjour,

en effet mon secure boot été activé. Je l'avais pourtant désactiver mais je ne sais pas pourquoi il s'est réactivé, bref merci beaucoup.
Encore une fois superbe communauté à l'écoute et accueillante pour les nouveau arrivant smile

Merci encore

Ozda

Hors ligne

#15 Le 18/04/2018, à 17:33

Naziel

Re : [Résolu] Problème affichage et lancement Steam GTX1060

Pourras tu passer ton sujet en résolu? (voir ma signature)
Je vais ajouter ton pc à la doc.

Dernière modification par Naziel (Le 18/04/2018, à 17:34)

Hors ligne

#16 Le 18/04/2018, à 17:42

Ozda

Re : [Résolu] Problème affichage et lancement Steam GTX1060

C'est fait, encore merci smile

Hors ligne