Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/10/2018, à 16:14

Christophe C

[résolu] WICD ne détecte aucun réseau wifi

Mon problème est un peu particulier :

j'ai un vieux eee pc "seashell séries" avec 1 Go de mémoire vive.

J'ai installé Lubuntu 18.04, mais cela rame encore trop. Wifi parfaitement détecté, par contre.

Pour alléger, j'ai installé un minimal CD ubuntu 18.04 : une installation nue, sans interface graphique. Puis j'y ai ajouter openbox, tint2 (comme panel), chromium (firefox rame vraiment trop), et wicd (+iw), qui ne voit donc pas mes réseaux wifi.

lspci -nnk | grep -A3 Network donne :

01:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
	Subsystem: Lite-On Communications Inc AR9485 Wireless Network Adapter [11ad:6627]
	Kernel driver in use: ath9k
	Kernel modules: ath9k
02:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)

Donc le pilote Qualcomm est bien présent dans le noyau (apparemment).

sudo iwconfig donne :

wlp1s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
enp2s0    no wireless extensions.

lo        no wireless extensions.

Un peu au hasard, j'ai tenté un sudo /etc/init.d/wicd start, mais wicd ne détecte rien de mieux.

voila ce que donne sudo cat /var/log/wicd/wicd.log (fichier de log) :

2018/10/11 16:24:08 :: ---------------------------
2018/10/11 16:24:08 :: wicd initializing...
2018/10/11 16:24:08 :: ---------------------------
2018/10/11 16:24:08 :: wicd is version 1.7.4 961
2018/10/11 16:24:08 :: setting backend to external
2018/10/11 16:24:08 :: trying to load backend external
2018/10/11 16:24:08 :: successfully loaded backend external
2018/10/11 16:24:09 :: trying to load backend external
2018/10/11 16:24:09 :: successfully loaded backend external
2018/10/11 16:24:09 :: Automatically detected wireless interface wlp1s0
2018/10/11 16:24:09 :: setting wireless interface wlp1s0
2018/10/11 16:24:09 :: automatically detected wired interface enp2s0
2018/10/11 16:24:09 :: setting wired interface enp2s0
2018/10/11 16:24:09 :: setting wpa driver wext
2018/10/11 16:24:10 :: setting use global dns to False
2018/10/11 16:24:10 :: setting global dns
2018/10/11 16:24:10 :: global dns servers are None None None
2018/10/11 16:24:10 :: domain is None
2018/10/11 16:24:10 :: search domain is None
2018/10/11 16:24:10 :: setting automatically reconnect when connection drops True
2018/10/11 16:24:10 :: Setting dhcp client to 0
2018/10/11 16:24:10 :: Wireless configuration file found...
2018/10/11 16:24:10 :: Wired configuration file found...
2018/10/11 16:24:10 :: chmoding configuration files 0600...
2018/10/11 16:24:10 :: chowning configuration files root:root...
2018/10/11 16:24:10 :: Using wireless interface...wlp1s0
2018/10/11 16:24:10 :: Using wired interface...enp2s0

Je précise que je ne cherche pas à faire fonctionner mon wifi maison a grand coup de paramétrages dans les fichiers de conf. Ce mini PC est destiné à se déplacer un peu partout, il faut donc qu'il sache lire le signal wifi d'un téléphone android (en partage de connexion), un wifi de gare, etc ...

Mon problème vient bien sur du fait que j'installe openbox et wicd sur une base minimale, et que je n'ai donc pas tous les paramétrages sympa que fait Lubuntu pour nous. Mais bon, c'est quand même bien plus réactif, donc j'apprécierais de régler le problème. Là je ne peux me connecter qu'en filaire.

Les pilotes semblant ok, c'est peut être un pb de groupe utilisateur ?

Dernière modification par Christophe C (Le 11/10/2018, à 17:00)


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#2 Le 11/10/2018, à 16:25

xubu1957

Re : [résolu] WICD ne détecte aucun réseau wifi

Bonjour,

Tente :

sudo ifconfig wlp1s0 up

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 11/10/2018, à 16:32

Christophe C

Re : [résolu] WICD ne détecte aucun réseau wifi

Non j'ai toujours "aucun réseau sans fil détecté"

A noter dans le fichier de log la ligne 2018/10/11 16:24:10 :: global dns servers are None None None
qui ne semble pas très glop ?


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#4 Le 11/10/2018, à 16:36

xubu1957

Re : [résolu] WICD ne détecte aucun réseau wifi


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 11/10/2018, à 16:43

Christophe C

Re : [résolu] WICD ne détecte aucun réseau wifi

Ah, j'ai redémarré le PC, et ta commande marche, finalement. Je refais quelques tests, mais cela semble fonctionner. Si c'est bon, je passe en résolu smile
Merci.


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#6 Le 11/10/2018, à 16:59

Christophe C

Re : [résolu] WICD ne détecte aucun réseau wifi

Bon, je confirme que cela semble marcher nickel. Encore merci smile


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne