Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/04/2019, à 22:10

IcarePetibles

Xsane ne trouve pas le scanner

Bonjour,
Depuis quelques temps xsane que trouve plus le périphérique scanner.
Je suis sous Ubuntu 18.04 LTS et j'utilise une imprimante Canon MG5750 (imprimante et scanner) connectée via wifi.
La fonction impression fonctionne parfaitement.
Lorsque je lance xsane dans un terminal, j'ai les messages suivants :

[bjnp] udp_command: ERROR - no data received (timeout = 10000)
[bjnp] bjnp_init_device_structure: Cannot read mac address, skipping this scanner
[bjnp] udp_command: ERROR - no data received (timeout = 10000)
[bjnp] add_scanner: ERROR - Cannot read scanner make & model: bjnp://imprimantemg5750.home:8612/timeout=10000
[bjnp] udp_command: ERROR - no data received (timeout = 10000)
[bjnp] bjnp_init_device_structure: Cannot read mac address, skipping this scanner
[bjnp] udp_command: ERROR - no data received (timeout = 10000)
[bjnp] add_scanner: ERROR - Cannot read scanner make & model: bjnp://imprimantemg5750.home:8612/timeout=10000

Que faire pour sortir de ce non fonctionnement ?
Merci pour votre aide.

Hors ligne

#2 Le 15/04/2019, à 14:50

Arbiel

Re : Xsane ne trouve pas le scanner

Bonjour

man sane a écrit :


       If  you  have  trouble getting your scanner detected, read the PROBLEMS
       section.
……
PROBLEMS
       If your device isn't found but you know that it is supported, make sure
       that  it  is  detected by your operating system. For SCSI and USB scan‐
       ners, use the  sane-find-scanner  tool  (see  sane-find-scanner(1)  for
       details).  It prints one line for each scanner it has detected and some
       comments (#). If sane-find-scanner finds your scanner only as root  but
       not  as  normal  user,  the  permissions  for  the device files are not
       adjusted correctly. If the scanner isn't found at  all,  the  operating
       system hasn't detected it and may need some help. Depending on the type
       of your scanner, read sane-usb(5) or sane-scsi(5).  If your scanner (or
       other device) is not connected over the SCSI bus or USB, read the back‐
       end's manual page for details on how to set it up.

       Now your scanner is detected by the operating system but not  by  SANE?
       Try  scanimage  -L.   If the scanner is not found, check that the back‐
       end's name is mentioned in  @CONFIGDIR@/dll.conf.   Some  backends  are
       commented  out  by default. Remove the comment sign for your backend in
       this case. Also some backends aren't compiled at all if  one  of  their
       prerequisites  are  missing.  Examples  include dc210, dc240, canon_pp,
       hpsj5s, gphoto2, pint, qcam, v4l, net, sm3600, snapscan,  pnm.  If  you
       need  one  of  these backends and they aren't available, read the build
       instructions in the README file and the individual manual pages of  the
       backends.

       Another  reason for not being detected by scanimage -L may be a missing
       or wrong configuration in the backend's configuration file. While  SANE
       tries  to  automatically  find  most scanners, some can't be setup cor‐
       rectly without the intervention of  the  administrator.  Also  on  some
       operating systems auto-detection may not work. Check the backend's man‐
       ual page for details.

       If your scanner is still not found, try setting the various environment
       variables  that  are available to assist in debugging.  The environment
       variables are documented in the relevant manual pages.  For example, to
       get  the maximum amount of debug information when testing a Mustek SCSI
       scanner, set environment variables  SANE_DEBUG_DLL,  SANE_DEBUG_MUSTEK,
       and  SANE_DEBUG_SANEI_SCSI  to  128 and then invoke scanimage -L .  The
       debug messages for the dll backend tell if the mustek backend was found
       and  loaded at all. The mustek messages explain what the mustek backend
       is doing while the SCSI debugging shows the low level handling. If  you
       can't find out what's going on by checking the messages carefully, con‐
       tact the sane-devel mailing list for help (see REPORTING BUGS below).

       Now that your scanner is found by scanimage -L, try to do a scan: scan‐
       image  >image.pnm.   This command starts a scan for the default scanner
       with default settings. All the available options are listed by  running
       scanimage  --help.   If  scanning aborts with an error message, turn on
       debugging as mentioned above. Maybe the configuration file  needs  some
       tuning,  e.g.  to  setup  the path to a firmware that is needed by some
       scanners. See the backend's manual page for details. If you can't  find
       out what's wrong, contact sane-devel.


       To  check  that  the SANE libraries are installed correctly you can use
       the test backend, even if you  don't  have  a  scanner  or  other  SANE
       device:

              scanimage -d test -T

       You  should  get  a list of PASSed tests. You can do the same with your
       backend by changing "test" to your backend's name.

       So now scanning with scanimage works and you want to  use  one  of  the
       graphical  frontends  like  xsane, xscanimage, or quiteinsane but those
       frontends don't detect  your  scanner?  One  reason  may  be  that  you
       installed two versions of SANE.  E.g. the version that was installed by
       your distribution  in  /usr  and  one  you  installed  from  source  in
       /usr/local/.   Make  sure  that  only one version is installed. Another
       possible reason is, that your system's dynamic loader  can't  find  the
       SANE  libraries.  For  Linux,  make  sure that /etc/ld.so.conf contains
       /usr/local/lib and does not contain /usr/local/lib/sane.  See also  the
       documentation of the frontends.

Prends en connaissance et reviens le cas échéant, demander traduction ou explication

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits
J'ai abandonné azerty au profit de bépo, google au profit de Lilo et mes adresses électroniques au profit d'une messagerie réellement sécurisée, Protonmail.

Hors ligne

#3 Le 15/04/2019, à 23:27

IcarePetibles

Re : Xsane ne trouve pas le scanner

Bonjour,
Merci pour ce retour mais cela ne me permet pas de résoudre mon problème de communication réseau.
J'avais également trouvé une piste ici : https://www.canon.fr/support/consumer_p … anguage=fr
Mais pour faire mon "To build and install scangearmp2", il me demande d'installer "**Error**: You must have `libtool' installed."
Alors que libtool est présent sur mon PC dans sa dernière version. Mettre les mains dans le cambouis de autogen.sh dépasse mes compétences.
Alors j'ai résolu le problème sans le résoudre !!!
J'ai connecté l'imprimante multi-fonctions en USB est tout fonctionne et me permet de faire mes scans en attendant de trouver une solution qui soit de mon niveau.
En attendant merci pour votre aide

Hors ligne

#4 Le 16/04/2019, à 10:17

Arbiel

Re : Xsane ne trouve pas le scanner

Bonjour

Connecter l'imprimante en USB est effectivement une bonne solution temporaire.

Je ne crois cependant pas qu'il s'agisse d'un problème réseau puisque, connectée en wifi, ton imprimante fonctionne. Il s'agirait plutôt d'un problème au niveau de l'application sane. D'où ma suggestion de suivre, dans un premier temps, les indications présentées de la page du manuel.

Mais, bien évidemment, tu peux faire comme bon te semble.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits
J'ai abandonné azerty au profit de bépo, google au profit de Lilo et mes adresses électroniques au profit d'une messagerie réellement sécurisée, Protonmail.

Hors ligne

#5 Le 16/04/2019, à 13:35

IcarePetibles

Re : Xsane ne trouve pas le scanner

Bonjour,
J'ai essayé de suivre les recommandations du man sane mais cela ne me donne pas grand chose d'exploitable à mes yeux de néophyte, mais je ne laisse pas tombé.
@+

Hors ligne

#6 Le 16/04/2019, à 15:36

Arbiel

Re : Xsane ne trouve pas le scanner

Si tu désires que quelqu'un te vienne éventuellement en aide, il faut que tu affiches le retour des commandes, en utilisant la balise code comme indiquée ci-dessous, en remplaçant "«" par" [" et "»" par" ]" «code» et «/code»
«code»
invite système $ commande et paramètres
retour
invite système $ «/code»
ce qui donne sur ma configuration pour la commande sane-find-scanner

remi@remi-Vostro-3550:~$ sudo sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x138a, product=0x0011) at libusb:002:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
remi@remi-Vostro-3550:~$ 

Tu continues ton investigation jusqu'à une éventuelle incompréhension ou difficulté d'interprétation ou de traduction, et tu reviens poser tes questions, mais toujours en affichant les retours.


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits
J'ai abandonné azerty au profit de bépo, google au profit de Lilo et mes adresses électroniques au profit d'une messagerie réellement sécurisée, Protonmail.

Hors ligne

#7 Le 16/04/2019, à 15:57

IcarePetibles

Re : Xsane ne trouve pas le scanner

Bonjour,
Voici la réponse à :

sane-find-scanner
$ sudo sane-find-scanner
[
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x178e [MG5700 series]) at libusb:001:009
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Déja, il y a des messages d'erreurs ou avertissements après "found USB scanner"

et

scanimage -L

donne :

device `pixma:04A9178E_31E689' is a CANON Canon PIXMA MG5700 Series multi-function peripheral

Hors ligne

#8 Le 16/04/2019, à 21:33

Arbiel

Re : Xsane ne trouve pas le scanner

As-tu cherché "could not fetch string descriptor: Pipe error" ? Je ne pense pas, car alors, tu aurais trouvé
13.04 - How to solve Scanner Permissions issues - Ask Ubuntu
qui t'aurait conduit à
SANE - Installing a scanner that isn't auto-detected
Je ne sais pas si la solution s'y trouve, mais c'est à toi qu'il revient d'investiguer pour trouver la solution. Tout ne peut pas venir des autres.

Déjà après que je t'ai indiqué les informations présentées dans la page du manuel, tu as abandonné en te fixant sur le fait qu'il s'agissait d'un problème de réseau alors que tu pouvais te connecter par le réseau à l'imprimante. Un tout petit effort de réflexion pouvait te permettre de suspecter ton hypothèse.

Maintenant tu t'arrêtes sur l'indication d'une erreur, alors qu'une recherche conduit directement à une page qui présente une situation comparable à celle à laquelle tu es confronté.

Je ne suis pas mieux informé que toi, et je ne peux pas faire à ta place.

Cependant, je peux t'aider, dans la mesure de mes maigres moyens, si tu rencontres des difficultés de compréhension ou de traduction.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits
J'ai abandonné azerty au profit de bépo, google au profit de Lilo et mes adresses électroniques au profit d'une messagerie réellement sécurisée, Protonmail.

Hors ligne

#9 Le 17/04/2019, à 11:59

Arbiel

Re : Xsane ne trouve pas le scanner

Et n'oublie pas, s'il te plaît et si tu trouves la solution à ton problème, de revenir l'indiquer ici et de mentionner dans le titre de la conversation que le problème est résolu. Cela peut toujours servir à d'autres.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits
J'ai abandonné azerty au profit de bépo, google au profit de Lilo et mes adresses électroniques au profit d'une messagerie réellement sécurisée, Protonmail.

Hors ligne