Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/07/2019, à 11:06

cguillaumec

Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bonjour à toutes et à tous,

J'ai depuis quelques jours (semaines ?) un bug assez embêtant : lorsque mon ordinateur sort de veille, il ne trouve pas de réseau. Le wifi s'allume et tout, mais il ne détecte rien. Et lorsque je relance network manager, rien n'y fait : le seul moyen de récupérer une connexion est de rallumer l'ordinateur. Et clairement, ce n'est pas une solution de long terme.

Voici les quelques infos de base sur le wifi :

>>    cat /etc/lsb-release 

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS"
>>    lsusb 

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 13d3:3491 IMC Networks 
Bus 001 Device 002: ID 0bda:57e6 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>>    lspci -k -nn | grep -A 3 -i net 

02:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 30)
	Subsystem: AzureWave QCA9377 802.11ac Wireless Network Adapter [1a3b:2231]
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci
>>    sudo lshw -C network 

  *-network
       description: Interface réseau sans fil
       produit: QCA9377 802.11ac Wireless Network Adapter
       fabriquant: Qualcomm Atheros
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: wlp2s0
       version: 30
       numéro de série: 80:a5:89:02:26:5d
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.15.0-54-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 ip=10.1.26.127 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       ressources: irq:128 mémoire:81000000-811fffff
>>    lsmod | sort 

acpi_thermal_rel       16384  1 int3400_thermal
aesni_intel           188416  315
aes_x86_64             20480  1 aesni_intel
ak8975                 20480  0
arc4                   16384  2
asus_nb_wmi            28672  0
asus_wireless          16384  0
asus_wmi               28672  1 asus_nb_wmi
ath10k_core           360448  1 ath10k_pci
ath10k_pci             45056  0
ath                    28672  1 ath10k_core
autofs4                40960  2
binfmt_misc            20480  1
bluetooth             548864  33 btrtl,btintel,btbcm,bnep,btusb,rfcomm
bnep                   20480  2
btbcm                  16384  1 btusb
btintel                16384  1 btusb
btrfs                1122304  0
btrtl                  16384  1 btusb
btusb                  45056  0
cfg80211              622592  3 ath,mac80211,ath10k_core
cmac                   16384  1
coretemp               16384  0
crc32_pclmul           16384  0
crct10dif_pclmul       16384  0
cryptd                 24576  159 crypto_simd,ghash_clmulni_intel,aesni_intel
crypto_simd            16384  1 aesni_intel
cuse                   16384  3
dm_crypt               40960  1
drm                   401408  15 drm_kms_helper,i915
drm_kms_helper        167936  1 i915
dw_dmac                16384  0
dw_dmac_core           24576  1 dw_dmac
ecdh_generic           24576  2 bluetooth
elan_i2c               36864  0
fb_sys_fops            16384  1 drm_kms_helper
ghash_clmulni_intel    16384  0
glue_helper            16384  1 aesni_intel
hfs                    57344  0
hfsplus               106496  0
hid                   118784  2 i2c_hid,hid_multitouch
hid_multitouch         20480  0
i2c_algo_bit           16384  1 i915
i2c_hid                20480  0
i2c_mux                16384  1 inv_mpu6050_i2c
i915                 1617920  21
industrialio           69632  4 industrialio_triggered_buffer,inv_mpu6050,kfifo_buf,ak8975
industrialio_triggered_buffer    16384  2 inv_mpu6050,ak8975
input_leds             16384  0
int3400_thermal        16384  0
int340x_thermal_zone    16384  1 processor_thermal_device
intel_cstate           20480  0
intel_int0002_vgpio    16384  1
intel_powerclamp       16384  0
intel_rapl             20480  0
intel_soc_dts_iosf     16384  1 processor_thermal_device
inv_mpu6050            20480  2 inv_mpu6050_i2c
inv_mpu6050_i2c        16384  0
ip_tables              28672  0
irqbypass              16384  1 kvm
jfs                   188416  0
joydev                 24576  0
kfifo_buf              16384  1 industrialio_triggered_buffer
kvm                   598016  1 kvm_intel
kvm_intel             212992  0
libcrc32c              16384  1 xfs
lp                     20480  0
lpc_ich                24576  0
mac80211              778240  1 ath10k_core
mac_hid                16384  0
media                  40960  2 videodev,uvcvideo
mei                    90112  1 mei_txe
mei_txe                20480  0
minix                  32768  0
mmc_block              36864  4
Module                  Size  Used by
msdos                  20480  0
nls_iso8859_1          16384  1
ntfs                  102400  0
parport                49152  3 parport_pc,lp,ppdev
parport_pc             36864  0
pcbc                   16384  0
ppdev                  20480  0
processor_thermal_device    16384  0
punit_atom_debug       16384  0
pwm_lpss               16384  1 pwm_lpss_platform
pwm_lpss_platform      16384  0
qnx4                   16384  0
raid6_pq              114688  1 btrfs
rfcomm                 77824  4
sch_fq_codel           20480  5
sdhci                  49152  1 sdhci_acpi
sdhci_acpi             16384  0
serio_raw              16384  0
shpchp                 36864  0
snd                    81920  23 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
snd_hda_codec         126976  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek   106496  1
snd_hda_core           81920  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hda_intel          40960  6
snd_hwdep              20480  1 snd_hda_codec
snd_pcm                98304  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                65536  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
soundcore              16384  1 snd
sparse_keymap          16384  1 asus_wmi
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
ufs                    77824  0
uvcvideo               86016  0
video                  45056  2 asus_wmi,i915
videobuf2_core         40960  2 videobuf2_v4l2,uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 uvcvideo
videobuf2_vmalloc      16384  1 uvcvideo
videodev              184320  3 videobuf2_core,videobuf2_v4l2,uvcvideo
wmi                    24576  1 asus_wmi
xfs                  1200128  0
xor                    24576  1 btrfs
x_tables               40960  1 ip_tables
zram                   24576  2
zstd_compress         163840  1 btrfs
>>    iwconfig 

wlp2s0    IEEE 802.11  ESSID:"BNF"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: B4:5D:50:CF:41:B0   
          Bit Rate=6 Mb/s   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:359   Missed beacon:0
>>    ifconfig -a 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 1540  bytes 147221 (147.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1540  bytes 147221 (147.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.1.26.127  netmask 255.255.254.0  broadcast 10.1.27.255
        inet6 fe80::6c02:6e3a:f5dd:29b7  prefixlen 64  scopeid 0x20<link>
        ether 80:a5:89:02:26:5d  txqueuelen 1000  (Ethernet)
        RX packets 45243  bytes 28676203 (28.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5292  bytes 1189757 (1.1 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

(Toutes ces commandes étant passées alors que je viens de redémarrer l'ordinateur, donc pas en sortie de veille - mais je ne sais pas si ça change quoi que ce soit)

J'ai regardé un peu sur le forum, j'ai essayé des solutions proposées, mais pour le moment rien n'y fait. Comme je suis loin d'être un pro d'ubuntu, je me dis qu'il y a peut-être un truc que j'adapte mal à mon propre ordinateur. Si une bonne âme veut bien me guider dans le chemin tortueux qui me mènera vers un ordinateur qui fonctionne, je lui en serais très reconnaissant !

Dernière modification par cguillaumec (Le 10/07/2019, à 14:19)

Hors ligne

#2 Le 10/07/2019, à 11:10

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bonjour,

Montre :

rfkill list all
nmcli dev wifi

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 10/07/2019, à 11:14

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Salut Xubu et merci !

Voici le résultat :

$ rfkill list all

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
$ nmcli dev wifi
IN-USE  SSID  MODE   CHAN  RATE      SIGNAL  BARS  SECURITY 
*       BNF   Infra  36    540 Mo/s  63      ▂▄▆_  --     

C'est grave, docteur ?

Hors ligne

#4 Le 10/07/2019, à 11:25

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

A la prochaine déconnexion, essaye :

sudo service network-manager restart

Sinon, il faut regarder > doc.ubuntu-fr.org/veille_et_hibernation#la_connexion_reseau_ne_se_reactive_pas_en_sortie_de_veille_ou_d_hibernation


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 10/07/2019, à 11:31

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Je réessaye à chaque fois, le résultat est le même : mon ordi rame un temps, le wifi se relance, mais ne trouve toujours aucune connexion.

J'ai aussi essayé la commande

echo "SUSPEND_MODULES=ath10k_pci" | sudo tee -a /etc/pm/config.d/load

Mais j'ai droit au message

/etc/pm/config.d/load: Aucun fichier ou dossier de ce type

Hors ligne

#6 Le 10/07/2019, à 11:32

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Tente cette solution proposée par toutafai :

Le 21/01/2014, toutafai a écrit :

A tous ceux qui sont avec de l'ASUS :

Essayer cette modification, facilement "réversible" :

sudo nano /etc/modprobe.d/blacklist.conf

A la fin du fichier, rajouter la ligne suivante :

blacklist asus_nb_wmi

Enregistrer la modification, rebooter et tester si le wifi est ok

PS : Pour annuler la modification, il suffit simplement de supprimer la ligne ajoutée, enregistrer et rebooter

_ _ _

Comme dans > Connexion interrompue (Résolu)

Dernière modification par xubu1957 (Le 10/07/2019, à 11:43)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 10/07/2019, à 11:49

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Héhé, ça semble marcher. J'ai ajouté la ligne, rebooté l'ordinateur, je l'ai mis en veille, revenu de veille, et je peux envoyer ce message.

Je marque le titre en [résolu], et si jamais ça me le refait, je reposte un message de secours.

Mais je croise les doigts et te remercie, Ô Xubu !

Hors ligne

#8 Le 10/07/2019, à 14:21

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Et malheureusement ça n'a pas marché à la veille suivante, ce qui est étrange. Est-ce parce que c'était une veille plus longue ? (Mais je ne suis pas sûr qu'il existe une distinction veille / veille prolongée sur ubuntu ?)

Ou alors, si je regarde les choses qui ont changé entre les deux veilles, peut-être que l'ordinateur était débranché pour la seconde. Pas sûr que ça ait un rapport, mais comme je n'y connais rien, j'indique ça au cas où.

Bref, j'ai eu le même bug, j'ai essayé de relancer network manager, sans succès.

Hors ligne

#9 Le 10/07/2019, à 14:23

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Un retour avec :

sudo modprobe ath10k_pci

?

_ _ _

Regarde la réponse dans > askubuntu.com/questions/1109148/ubuntu-18-04-wireless-not-working-for-some-sites-after-suspend?rq=1

Dernière modification par xubu1957 (Le 10/07/2019, à 14:31)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#10 Le 10/07/2019, à 14:55

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Qu'est-ce que la commande est censée faire ? Je n'ai aucun retour. Mais peut-être que c'est dans un fichier quelque part ?

Sinon, pour la solution vers laquelle tu renvoies, c'est la première solution que j'ai essayée quand le problème a commencé, et ça ne change rien...

Hors ligne

#11 Le 10/07/2019, à 15:34

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

C'est pour désactiver l'économie d'énergie de la carte wifi.

> unix.stackexchange.com/questions/269661/how-to-turn-off-wireless-power-management-permanently

_ _ _

Tu n'es pas le seul > wifi shuts down on sleep

Dernière modification par xubu1957 (Le 10/07/2019, à 15:41)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#12 Le 10/07/2019, à 15:42

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Malheureusement, ça n'a pas marché.

J'ai même eu le bug qui est revenu alors que l'ordinateur était allumé (je suis parti passer un coup de fil, quand je suis revenu et que je me suis remis au boulot, la connexion en cours s'est interrompue, et impossible de retrouver du réseau).

(Je vais finir par revenir sur Windows, à ce rythme là !)
(Non, jamais !)
(M'enfin quand même, c'est embêtant de ne pas profiter tranquillement d'internet, surtout pour bosser)

Hors ligne

#13 Le 10/07/2019, à 17:13

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Je viens de rajouter une discussion dans le message #11, c'est pas évident.

(Edit= messages regroupés)
_ _ _
Tu pourras fournir :

dmesg | grep ath10k

?

Dernière modification par xubu1957 (Le 11/07/2019, à 08:21)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#14 Le 11/07/2019, à 09:54

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Hello !

Désolé pour le retard. Voici le retour de la commande :

[   22.272709] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   22.612043] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[   22.612081] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[   22.632406] ath10k_pci 0000:02:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 1a3b:2231
[   22.632412] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[   22.633333] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[   22.712984] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[   25.455420] ath10k_pci 0000:02:00.0: Unknown eventid: 3
[   25.470056] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
[   25.472915] ath10k_pci 0000:02:00.0: Unknown eventid: 90118
[   25.473668] ath10k_pci 0000:02:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[   25.869651] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0
[   31.371921] ath10k_pci 0000:02:00.0: Unknown eventid: 3
[   31.387245] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
[   31.390170] ath10k_pci 0000:02:00.0: Unknown eventid: 90118

Hors ligne

#15 Le 11/07/2019, à 11:48

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bonjour,

Je viens de trouver, pour d'autres distributions :

> [Solved] Oct 2018 updates caused wireless connection problem with QCA9377 network adaptor [Résolu] Les mises à jour d'octobre 2018 ont causé un problème de connexion sans fil avec la carte réseau QCA9377

et dans > Bug 1671935 - Atheros QCA9377 firmware broken

Une utilisation du > github.com/kvalo/ath10k-firmware

_ _ _

Il faudrait des avis d'autres aidants.

Je rajoute > forum.manjaro.org/t/solved-qualcomm-qca6174-unstable-after-standby-many-circumstances-lenovo-miix-520/79713 pour le pilote ath10k_pci

_ _ _

EDIT :

Montre aussi :

iw reg get

repris dans > askubuntu.com/questions/1155518/wifi-problem-acer-aspire-a114-31-c3rs

Dernière modification par xubu1957 (Le 11/07/2019, à 13:11)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#16 Le 11/07/2019, à 22:11

NicoApi73

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bonsoir,

Sur mon PC, j'ai un ath10k (que je n'utilise pas, je me connecte en filaire...)

Je viens d'essayer et je n'ai pas eu de problème.

Je n'ai pas l'impression que ça vienne du driver. Ca me fait plutôt penser à un problème réseau, pour l'attribution de l'adresse IP. Je ne suis pas assez calé dans ce domaine, je vais essayer de me renseigner. As tu essayer dans network manager de faire "Se déconnecter", puis ensuite de te reconnecter à la box?

Hors ligne

#17 Le 11/07/2019, à 22:19

xubu1957

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

@Nico

J'avais basé mes recherches sur :

firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877

Merci pour ton intervention. smile


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#18 Le 11/07/2019, à 22:22

NicoApi73

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

A la prochaine déconnexion (c'est à dire en sortie de veille et la connexion wifi qui ne se fait pas) donne :

iwconfig
nmcli dev wifi

Dernière modification par NicoApi73 (Le 11/07/2019, à 22:23)

Hors ligne

#19 Le 11/07/2019, à 23:12

ylag

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Salut,

Peut-être aussi vérifier si le fichier /etc/NetworkManager/NetworkManager.conf contient bien une section:

[device]
wifi.scan-rand-mac-address=no

?

Dernière modification par ylag (Le 11/07/2019, à 23:12)

Hors ligne

#20 Le 16/07/2019, à 13:18

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bonjour à tous,
Désolé pour le retard - j'ai fait un long weekend sans ordinateur (et donc sans problème de connexion, héhé - une solution Shadok parfaite).

@Nico : Quand tu parles de faire "se déconnecter" et de se reconnecter, c'est à quel stade ? Parce que mon problème en sortie de veille est justement qu'aucun réseau n'apparaît, donc je ne peux pas me déconnecter et me reconnecter. Par contre, éteindre le wifi et le rallumer, j'ai essayer de multiples fois.

Pour la commande iwconfig & nmcli dev wifi, je fais ça au prochain bug. Je n'avais pas vu ton message avant ma dernière déconnexion (il y a cinq minutes), après laquelle j'ai rallumé l'ordinateur.

Pour le fichier  /etc/NetworkManager/NetworkManager.conf, est-ce que tu peux m'indiquer comment faire pour vérifier ça ? (Moi, un ignorant absolu ? Non, pas du tout...)

Hors ligne

#21 Le 16/07/2019, à 13:26

NicoApi73

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bonjour,

Par déconnexion, j'entends par là quand tu rencontres ton bug. Donc effectivement, au prochain bug tape les commandes pour voir ce que cela donne.

Donne :

cat /etc/NetworkManager/NetworkManager.conf

On pourra voir ce que demande ylag

Hors ligne

#22 Le 16/07/2019, à 13:44

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Merci !

Voici le retour de la commande :

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

Hors ligne

#23 Le 16/07/2019, à 14:01

NicoApi73

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Bon ça répond à la question d'ylag.

Fais le #18 dès que ça plante...

Hors ligne

#24 Le 16/07/2019, à 16:03

ylag

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Salut,

NicoApi73 a écrit :

Fais le #18 dès que ça plante...

+1

Après, comme tentative de contournement, tu pourrais essayer: (en supposant que ton interface sans fil se nomme bien wlp2s0)

sudo ip link set wlp2s0 down

...suivi de:

sudo ip link set wlp2s0 up

...pour tenter de réactiver l'interface, et voir si ça ne te redonnerait pas accès au réseau.

?

Dernière modification par ylag (Le 16/07/2019, à 16:06)

Hors ligne

#25 Le 17/07/2019, à 16:18

cguillaumec

Re : Pas de réseau après la sortie de veille [Ubuntu 18.04.2 LTS]

Hello !

Aujourd'hui, le wifi a encore fait des siennes. Mais j'étais près pour les commandes, et voici donc les retours ! (J'ai aussi refait iwconfig, au cas où !)

~$ iwconfig
lo        no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
~$ iw reg get
global
country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
	(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)
~$ nmcli dev wifi
IN-USE  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY

@ylag : la stratégie de contournement, je la tente quand ça bug, du coup, j'imagine? (Je ne l'avais pas notée, donc je me suis retrouvé comme une andouille devant mon ordi avec internet planté, et j'ai du rebooter...)

Hors ligne