Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 14/08/2017, à 16:47

BEK89

Impossible de réinstaller MySQL

Bonjour à tous,
Je suis sous Ubuntu 16.04. J'ai installé MySQL et constaté qu'il ne fonctionnait pas.
Après avoir quelque peu galéré, j'ai finalement réussit à le réinstaller, mais à la réinstallation j'ai à nouveau un message d'erreur comme suit:

Paramétrage de mysql-server-5.7 (5.7.11-0ubuntu6) ...
update-alternatives: utilisation de « /etc/mysql/mysql.cnf » pour fournir « /etc/mysql/my.cnf » (my.cnf) en mode automatique
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.7 ; cependant :
 Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu19) ...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Je soupçonne un problème de dépendances. Quelqu'un a-t-il une piste pour débloquer ma situation?
Merci d'avance!

Hors ligne

#2 Le 14/08/2017, à 17:04

abelthorne

Re : Impossible de réinstaller MySQL

Essaie :

sudo apt-get remove --purge mysql-server mysql-server-5.7 mysql-server-core-5.7
sudo apt-get install --reinstall mysql-server mysql-server-5.7 mysql-server-core-5.7

(Attention, ça va supprimer les fichiers de config éventuels : si tu les as modifiés, fais-en une sauvegarde avant.)

Si ça ne marche pas, essaie :

sudo apt-get install -f

et/ou :

sudo dpkg --configure -a

Dernière modification par abelthorne (Le 14/08/2017, à 17:04)

Hors ligne

#3 Le 14/08/2017, à 17:05

sojoachim

Re : Impossible de réinstaller MySQL

Yo

Je ne suis pas un craque mais pour que d'autres puisse d'aider :

Comment as tu désintaller Mysql server ?

As tu essayé la commande

sudo apt-get remove --purge mysqlserver

le --purge désinstalle les paquets indiqués, les dépendances logicielles et leurs fichiers de configuration

Hors ligne

#4 Le 14/08/2017, à 17:32

BEK89

Re : Impossible de réinstaller MySQL

abelthorne a écrit :

Essaie :

sudo apt-get remove --purge mysql-server mysql-server-5.7 mysql-server-core-5.7
sudo apt-get install --reinstall mysql-server mysql-server-5.7 mysql-server-core-5.7

(Attention, ça va supprimer les fichiers de config éventuels : si tu les as modifiés, fais-en une sauvegarde avant.)

Si ça ne marche pas, essaie :

sudo apt-get install -f

et/ou :

sudo dpkg --configure -a

Alors la première commande

sudo apt-get remove --purge mysql-server mysql-server-5.7 mysql-server-core-5.7

n'a pas affiché d'erreur, en revanche les trois suivantes m'affichent le même message d'erreur que celui décrit dans mon premier post à savoir :

sudo apt-get install --reinstall mysql-server mysql-server-5.7 mysql-server-core-5.7
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  mailx tinyca
Les NOUVEAUX paquets suivants seront installés :
  mysql-server mysql-server-5.7 mysql-server-core-5.7
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/10,1 Mo dans les archives.
Après cette opération, 94,6 Mo d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
Sélection du paquet mysql-server-core-5.7 précédemment désélectionné.
(Lecture de la base de données... 269989 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mysql-server-core-5.7_5.7.11-0ubuntu6_amd64.deb ...
Dépaquetage de mysql-server-core-5.7 (5.7.11-0ubuntu6) ...
Sélection du paquet mysql-server-5.7 précédemment désélectionné.
Préparation du dépaquetage de .../mysql-server-5.7_5.7.11-0ubuntu6_amd64.deb ...
Dépaquetage de mysql-server-5.7 (5.7.11-0ubuntu6) ...
Sélection du paquet mysql-server précédemment désélectionné.
Préparation du dépaquetage de .../mysql-server_5.7.11-0ubuntu6_all.deb ...
Dépaquetage de mysql-server (5.7.11-0ubuntu6) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu19) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Paramétrage de mysql-server-core-5.7 (5.7.11-0ubuntu6) ...
Paramétrage de mysql-server-5.7 (5.7.11-0ubuntu6) ...
update-alternatives: utilisation de « /etc/mysql/mysql.cnf » pour fournir « /etc/mysql/my.cnf » (my.cnf) en mode automatique
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.7 ; cependant :
 Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu19) ...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
baptiste@junior /e/apt> sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de mysql-server-5.7 (5.7.11-0ubuntu6) ...
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.7 ; cependant :
 Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
baptiste@junior /e/apt> sudo dpkg --configure -a
Paramétrage de mysql-server-5.7 (5.7.11-0ubuntu6) ...
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.7 ; cependant :
 Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.7
 mysql-server
baptiste@junior /e/apt> 
sojoachim a écrit :

Yo

Je ne suis pas un craque mais pour que d'autres puisse d'aider :

Comment as tu désintaller Mysql server ?

As tu essayé la commande

sudo apt-get remove --purge mysqlserver

le --purge désinstalle les paquets indiqués, les dépendances logicielles et leurs fichiers de configuration

J'ai déjà essayé cette commande et le message d'erreur est resté le même jusqu'à ce que je pointe précisément sur mysql-server-5.7 et que finalement je puisse désinstaller mysql.
merci pour votre aide.

Hors ligne

#5 Le 14/08/2017, à 17:41

abelthorne

Re : Impossible de réinstaller MySQL

BEK89 a écrit :

J'ai déjà essayé cette commande et le message d'erreur est resté le même jusqu'à ce que je pointe précisément sur mysql-server-5.7 et que finalement je puisse désinstaller mysql.
merci pour votre aide.

C'est réglé ou pas ? Au vu des erreurs, je n'en ai pas l'impression, à moins que tu aies fait d'autre manips sans donner le retour ?

Sinon, essaie :

sudo dpkg --configure mysql-server mysql-server-5.7

Hors ligne

#6 Le 14/08/2017, à 18:01

BEK89

Re : Impossible de réinstaller MySQL

abelthorne a écrit :

C'est réglé ou pas ? Au vu des erreurs, je n'en ai pas l'impression, à moins que tu aies fait d'autre manips sans donner le retour ?

Sinon, essaie :

sudo dpkg --configure mysql-server mysql-server-5.7

Non, ce n'est toujours pas réglé (Pardon si je n'ai pas été très clair).
En exécutant

sudo dpkg --configure mysql-server mysql-server-5.7

le même message d'erreur revient :

baptiste@junior /> sudo sudo dpkg --configure mysql-server mysql-server-5.7
Paramétrage de mysql-server-5.7 (5.7.11-0ubuntu6) ...
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.7 ; cependant :
 Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.7
 mysql-server
baptiste@junior /> 

Et je n'ai pas fais d'autres manip depuis. Si vous avez d'autres pistes... Merci d'avance!

Hors ligne

#7 Le 14/08/2017, à 18:23

abelthorne

Re : Impossible de réinstaller MySQL

(Attention, tu as mis deux fois sudo dans ta commande − je ne pense pas que ça change quoi que soit, cela dit.)

Essaie à nouveau de supprimer les paquets :

sudo apt-get remove --purge mysql-server mysql-server-5.7

Ensuite, supprime les dépendances inutiles :

sudo apt-get autoremove --purge

Puis vérifie si tu as toujours un dossier "mysql" dans /etc et dans /usr/share (si c'est le cas, surtout, ne les supprime pas manuellement).

Et à nouveau un sudo apt-get install -f et donne le retour de ce dernier.

Dernière modification par abelthorne (Le 14/08/2017, à 18:24)

Hors ligne

#8 Le 15/08/2017, à 11:05

sojoachim

Re : Impossible de réinstaller MySQL

@abelthorne :

Me pose une question : Pourquoi il y a à la fois mysql-server et mysql-server-5.7 ?

J'avais juste installé le paquet mysql-server. Ma version de Mysql après un update et upgrade est :
version: 5.7.19-0ubuntu0.17.04.1 (Ubuntu) donc supérieur à la version 5.7.

En regardant le man de apt-get (je voulais savoir à quoi correspondait le -f) je suis tombé sur ça :

dist-upgrade
           La commande dist-upgrade effectue la fonction upgrade en y ajoutant une gestion intelligente des changements de dépendances dans les
           nouvelles versions des paquets ; apt-get possède un système « intelligent » de résolution des conflits et il essaye, quand c'est
           nécessaire, de mettre à niveau les paquets les plus importants avant les paquets les moins importants. Le fichier /etc/apt/sources.list
           contient une liste de sources où récupérer les paquets désirés. Voyez aussi apt_preferences(5) pour un mécanisme de remplacement des
           paramètres généraux pour certains paquets.

Est-ce que pour notre ami cela pourrait être intéressant :
1/ une purge des paquets,
2/ un update et un dist-upgrade pour être sur que l'environnement est bien toutes les dépendances
3/ une installation de mysql-server
(quid : de la version de mysql. Est il possible qu'il y est un conflit avec les autres paquets installés : mysql-server-5.7 mysql-server-core-5.7

Dernière modification par sojoachim (Le 15/08/2017, à 11:06)

Hors ligne

#9 Le 15/08/2017, à 11:19

abelthorne

Re : Impossible de réinstaller MySQL

Mysql-server est juste un méta-paquet qui installe la version la plus récente. Une sorte de lien, si tu veux. Si dans une prochaine version d'Ubuntu, MySQL est disponible en version 5.8 ou autre, le paquet mysql-server sera un raccourci sur cette version et plus sur la 5.7.

Pour ce qui est des numéros de version, quand on parle de MySQL 5.7, ça inclut les sous-versions, c'est la branche 5.7 dans son ensemble : la 5.7 correspond à toutes les versions 5.7.x, qui sont juste des corrections de bugs. Quand des gros changements seront apportés, MySQL passera en version 5.8.x ou 5.9.x ou autre (selon la façon dont ses développeurs gèrent leurs numéros de versions) et il y aura un nouveau paquet pour cette version générale.

Pour ce qui est d'APT, quand on fait un upgrade, les paquets sont mis à jour sauf s'ils ont besoin d'installer ou de supprimer des paquets (si la liste des dépendances a changé, quoi). La màj peut donc s'avérer incomplète. Un dist-upgrade permet de passer outre et autorise APT à installer / supprimer les paquets nécessaires.

Pour le reste :
1) la purge des paquets est justement ce que j'essaie de lui faire faire ;
2) il n'y a pas vraiment de raison que ce soit lié au problème, d'autant que la situation des paquets non configurés empêche certainement les mises à jour ;
3) ça fait partie de ce que je lui fais faire : manipuler à la fois mysql-server et mysql-server-5.7 justement parce que les deux correspondent au même paquet.

Hors ligne

#10 Le 15/08/2017, à 11:44

sojoachim

Re : Impossible de réinstaller MySQL

D'aki merci pour les précisions !
Bon j'arrête de pollué son post et suit tranquillement en tant que newbie

Hors ligne