Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/05/2018, à 11:53

ljere

[Résolu] wifi bloqué à 1M

Bonjour,
Je viens de remarquer que mon rate est bloqué à 1M et biensur pas moyen de l'augmenter, sur mon smartphone le débit est de 144M, mais si il passe à 54M, je serai déjà très content.

[~](0)jerem:~ cat /etc/lsb-release                                    12:44:33 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=17.10
DISTRIB_CODENAME=artful
DISTRIB_DESCRIPTION="Ubuntu 17.10"
[~](0)jerem:~ lspci -k -nn | grep -A 3 -i net                         12:45:26 
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
	Subsystem: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8181]
	Kernel driver in use: rtl8192ce
	Kernel modules: rtl8192ce
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 05)
	Subsystem: Toshiba America Info Systems RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [1179:fd7b]
	Kernel driver in use: r8169
	Kernel modules: r8169
sudo lshw -C network                                    12:46:13 
  *-network                 
       description: Interface réseau sans fil
       produit: RTL8188CE 802.11b/g/n WiFi Adapter
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: wlan0
       version: 01
       numéro de série: 9c:b7:0d:38:07:05
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=4.13.0-39-generic firmware=N/A ip=192.168.0.30 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       ressources: irq:17 portE/S:e000(taille=256) mémoire:fea00000-fea03fff
  *-network
       description: Ethernet interface
       produit: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:04:00.0
       nom logique: eth0
       version: 05
       numéro de série: e8:40:f2:26:0c:22
       taille: 10Mbit/s
       capacité: 100Mbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       ressources: irq:24 portE/S:d000(taille=256) mémoire:d0004000-d0004fff mémoire:d0000000-d0003fff
[~](0)jerem:~ sudo iwconfig                                           12:47:06 
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"freebox_ljeremie"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:24:D4:E8:DC:A4   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-30 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:28   Missed beacon:0
[~](0)jerem:~ cat  /etc/network/interfaces                            12:48:07 
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

j'ai donc tenté

sudo ifdown wlan0                                       12:50:41 
Unknown interface wlan0
[~](1)jerem:~ sudo iwconfig wlan0 rate 54M                            12:50:58 
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0 ; Invalid argument.
[~](250)jerem:~ sudo iwconfig wlan0 rate 54                           12:51:10 
[~](0)jerem:~ sudo iwconfig                                           12:51:15 
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"freebox_ljeremie"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:24:D4:E8:DC:A4   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-28 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:28   Missed beacon:0

Dernière modification par ljere (Le 13/05/2018, à 12:08)


astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#2 Le 06/05/2018, à 12:05

xubu1957

Re : [Résolu] wifi bloqué à 1M

Bonjour,

Vu > unable-to-change-default-bitrate-of-wireless-network-interface

Tu as lancé :

sudo ifconfig wlan0 up

?

puis :

iwlist wlan0 bitrate

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 06/05/2018, à 13:04

ljere

Re : [Résolu] wifi bloqué à 1M

je ne l'avais pas lancé vu que le down ne passait pas

[~](0)jerem:~ sudo ifconfig wlan0 down                                14:02:02 
[sudo] Mot de passe de jerem :       
[~](0)jerem:~ sudo iwconfig wlan0 rate 54                             14:02:21 
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0 ; Network is down.
[~](250)jerem:~ sudo iwconfig wlan0 rate 54m                          14:02:25 
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0 ; Network is down.
[~](250)jerem:~ sudo iwconfig wlan0 rate 54M                          14:02:30 
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0 ; Network is down.
[~](250)jerem:~ sudo ifconfig wlan0 up                                14:02:35 
[~](0)jerem:~ sudo iwlist wlan0 bitrate                               14:02:51 
wlan0     unknown bit-rate information.
          Current Bit Rate=1 Mb/s

[~](0)jerem:~                                                         14:03:21 

astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#4 Le 06/05/2018, à 13:55

xubu1957

Re : [Résolu] wifi bloqué à 1M

Vu le pilote :

configuration: broadcast=yes driver=rtl8192ce 
Le 23/08/2017, xubu a écrit :

Je suis allé voir debian.org/fr/rtl819x#rtl8192ce

rtl8192ce
Les périphériques pris en charge par ce pilote peuvent souffrir de pertes de connexion intermittente. Si c'est le cas, il peut être plus fiable de désactiver la gestion d'énergie avec les options de module ips et fwlps. Ce qui peut être fait en créant un nouveau fichier :

/etc/modprobe.d/rtl8192ce.conf
options rtl8192ce ips=0 fwlps=0

Essaie :

echo "options rtl8192ce ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf

dans > WIFI déconnecte

Regarde aussi les messages  #7 et #41 de cette discussion.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 06/05/2018, à 14:08

xubu1957

Re : [Résolu] wifi bloqué à 1M

Cet avis :

Le 27/06/2012, Eric Kranich a écrit :

Solution Radicale  : Remplacer la REALTEK par une INTEL :
il faut reconnaître que les Realtek ne  sont pas très bien détecté.
Selon les cas : un signal faible, ne se réveille pas après une mise en veille, des coupures aléatoire, trouve la borne wifi mais ne s’y connecte pas, etc..

Tous ces cas trouvent une solution et merci à la communauté pour les aides .

Moi qui travaille chez un revendeur qui distribue des Pc portables certifiés Ubuntu, on préfère remplacer systématiquement les cartes Wifi Realtek par une carte Wifi de chez Intel ; ça ne coûte pas cher et c’est directement reconnu par Ubuntu (...)

> wifi-realtek-rtl8188ce-et-rtl8192ce-avec-ubuntu-cubuntu

Dernière modification par xubu1957 (Le 06/05/2018, à 14:09)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#6 Le 06/05/2018, à 15:02

moko138

Re : [Résolu] wifi bloqué à 1M

Mais que fait le nom "wlan0" dans une Artful ???

sudo lshw -C network                                    12:46:13 
  *-network                 
       nom logique: wlan0

Cf. https://www.freedesktop.org/wiki/Softwa … faceNames/

https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#7 Le 06/05/2018, à 15:33

ljere

Re : [Résolu] wifi bloqué à 1M

Je ne pense pas que ce soit le nom wlan0 qui change quoique ce soit, le nom est resté vu que je passe de mise à jour en mise à jour.
j'ai regardé du coté de modprobe

[~](0)jerem:~ ls /etc/modprobe.d                                      16:26:16 
alsa-base.conf              blacklist-modem.conf         iwlwifi.conf
blacklist-ath_pci.conf      blacklist-oss.conf           mlx4.conf
blacklist.conf              blacklist-rare-network.conf  modesetting.conf
blacklist-firewire.conf     blacklist-watchdog.conf      rtl8191ce.conf
blacklist-framebuffer.conf  dkms.conf                    vmwgfx-fbdev.conf
[~](0)jerem:~ cat /etc/modprobe.d/rtl8191ce.conf                      16:29:14 
options rtl8191ce ips=0
[~](0)jerem:~  

et là je me dis mon pilote c'est bien rtl8188ce, je doute que ça pose problème, mais bon je vous le signal, pour la mise en veille pourquoi ne pas directement faire

[~](0)jerem:~ sudo iwconfig wlan0 power off                           16:32:18 
[~](0)jerem:~ sudo iwconfig                                           16:32:56 
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"freebox_ljeremie"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:24:D4:E8:DC:A4   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:129   Missed beacon:0

[~](0)jerem:~           

astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#8 Le 06/05/2018, à 15:37

xubu1957

Re : [Résolu] wifi bloqué à 1M

Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
	Subsystem: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8181]
	Kernel driver in use: rtl8192ce
	Kernel modules: rtl8192ce

Kernel driver in use: rtl8192ce

Pour moi, c'est un RTL8192CE.

_ _ _

Fais voir la ligne cfg80211 du lsmod.

Dernière modification par xubu1957 (Le 06/05/2018, à 15:39)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 06/05/2018, à 15:43

ljere

Re : [Résolu] wifi bloqué à 1M

oui je l'ai compris avec un peu de retard lol, j'ai suivi ton lien

[~](0)jerem:~ sudo lshw -c network | grep -i wireless                 16:33:04 
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=4.13.0-39-generic firmware=N/A ip=192.168.0.30 latency=0 link=yes multicast=yes wireless=IEEE 802.11
[~](0)jerem:~ sudo nano /etc/pm/config.d/suspend_modules              16:36:50 
[~](0)jerem:~               
[~](0)jerem:~ lsmod | grep -i cfg80211                                16:39:45 
cfg80211              614400  2 mac80211,rtlwifi
[~](0)jerem:~    

astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#10 Le 06/05/2018, à 15:44

moko138

Re : [Résolu] wifi bloqué à 1M

ljere a écrit :

Je ne pense pas que ce soit le nom wlan0 qui change quoi que ce soit, le nom est resté vu que je passe de mise à jour en mise à jour.

Précisément ! Je crois me souvenir que, dans les premières Xenial, la conservation de "wlanx" était signe que la migration s'était mal passée.

Est-ce que par hasard après migration tu réinjectes tout ou partie du précédent /etc/ ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#11 Le 06/05/2018, à 15:46

ljere

Re : [Résolu] wifi bloqué à 1M

je ne réinjecte rien j'ai juste fais la mise à jour qui s'était très bien passée


astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#12 Le 06/05/2018, à 15:50

xubu1957

Re : [Résolu] wifi bloqué à 1M

C'est dommage que toutafai, ne soit plus présent sur le forum, il a fait une brève incursion le 01/05/2018.

Je renseigne avec le stock, mais je n'ai pas ses qualifications.

   _ _ _

Et ce script ?

Zaoune a écrit :

En me baladant sur les autres sujets, j'ai trouvé la réponse.
Le script que je cherchais, et l'emplacement exact, c'est exactement ce qu'explique ce tutoriel très concis. (lien mort)

Régler le Bit Rate de la carte a 54M bits sans toucher au fichier interfaces :
Créer un fichier script avec cette commande (sans sudo) :
iwconfig wlan0 rate 54M
et le copier dans le dossier /etc/network/if-pre-up.d/

Création du fichier script en 1 seule commande :

echo -e '#!/bin/bash\niwconfig wlan0 rate 54M\nexit 0' | sudo tee /etc/network/if-pre-up.d/wlan0-rate

Rendre le fichier exécutable :

sudo chmod +x /etc/network/if-pre-up.d/wlan0-rate

Merci à vous deux pour m'avoir éclairé, et à la communauté qui fait vivre ce forum, et m'a entre autre permis de trouver cette réponse.
Problème résolu.

> Wifi : bitrate coincé à 1Mbps

Dernière modification par xubu1957 (Le 06/05/2018, à 16:06)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#13 Le 06/05/2018, à 15:58

moko138

Re : [Résolu] wifi bloqué à 1M

Que montrent

cat /etc/modprobe.d/rtl8192ce.conf

et

modinfo rtl8192ce

?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#14 Le 06/05/2018, à 16:32

ljere

Re : [Résolu] wifi bloqué à 1M

c'est gentil mais ça n'a d’intérêt que si

iwconfig wlan0 rate 54M

fonctionne hors ce n'est pas mon cas
pour le

[~](0)jerem:~ cat /etc/modprobe.d/rtl8191ce.conf                      16:29:14 
options rtl8191ce ips=0
[~](0)jerem:~  
modinfo rtl8192ce                                       17:27:52 
filename:       /lib/modules/4.13.0-39-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware:       rtlwifi/rtl8192cfwU_B.bin
firmware:       rtlwifi/rtl8192cfwU.bin
firmware:       rtlwifi/rtl8192cfw.bin
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger	<Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE	<wlanfae@realtek.com>
author:         lizhaoming	<chaoming_li@realsil.com.cn>
srcversion:     652BC11F71608AFD57EF5CA
alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,rtl8192c-common,mac80211
intree:         Y
name:           rtl8192ce
vermagic:       4.13.0-39-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
[~](0)jerem:~           

astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#15 Le 06/05/2018, à 16:40

Naziel

Re : [Résolu] wifi bloqué à 1M

Bonjour,

Le pilote en question était préinstallé sur ubuntu par défaut ou tu es passé par https://github.com/lwfinger/rtlwifi_new (ou autre)? Dans le deuxième cas, peux tu essayer de démarrer sur un ancien noyau et tester? Dans le premier cas, le problème est il survenu après une mise à jour de linux-firmware ou du noyau?

Hors ligne

#16 Le 06/05/2018, à 19:30

moko138

Re : [Résolu] wifi bloqué à 1M

En #14, on a :

modinfo rtl8192ce
fwlps:Set to 1 to use FW control power save (default 1)

  et

cat /etc/modprobe.d/rtl8191ce.conf
options rtl8191ce ips=0

EDIT :
ljere,
c'est

cat /etc/modprobe.d/rtl8192ce.conf

que je t'avais demandé !
Et que je te redemande.

Donc il manque une option : fwlps=0


Remède :

echo "options rtl8191ce ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8191ce.conf && sudo modprobe -r rtl8191ce && sudo modprobe -a rtl8191ce

Dernière modification par moko138 (Le 06/05/2018, à 19:37)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#17 Le 06/05/2018, à 19:38

moko138

Re : [Résolu] wifi bloqué à 1M

Édité message précédent.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#18 Le 06/05/2018, à 19:56

ljere

Re : [Résolu] wifi bloqué à 1M

naziel le pilote était préinstallé, je ne sais pas du tout, vu que je passai par eth, ok je test demain
moko je n'ai pas ce fichier, j'ai donné le ls de ce dossier en #7
j'anticipe

[~](0)jerem:~ echo "options rtl8192ce ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf && sudo modprobe -r rtl8192ce && sudo modprobe -a rtl8192ce
options rtl8192ce ips=0 fwlps=0
[~](0)jerem:~ modinfo rtl8192ce                                       20:58:55 
filename:       /lib/modules/4.13.0-39-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware:       rtlwifi/rtl8192cfwU_B.bin
firmware:       rtlwifi/rtl8192cfwU.bin
firmware:       rtlwifi/rtl8192cfw.bin
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger	<Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE	<wlanfae@realtek.com>
author:         lizhaoming	<chaoming_li@realsil.com.cn>
srcversion:     652BC11F71608AFD57EF5CA
alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,rtl8192c-common,mac80211
intree:         Y
name:           rtl8192ce
vermagic:       4.13.0-39-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
[~](0)jerem:~     

Dernière modification par ljere (Le 06/05/2018, à 20:00)


astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne

#19 Le 06/05/2018, à 20:42

Naziel

Re : [Résolu] wifi bloqué à 1M

D'après https://www.ubuntuupdates.org/package/c … x-firmware , la dernière version sortie sur artful date de 2018-02-05 donc d'après ce lien, ça peut pas venir d'une mise à jour de linux-firmware. Tu peux au cas où tenter de démarrer sur un ancien noyau.

Edit: j'avais pas regardé les autres dépôts... Donc ça peut venir de linux-firmware https://www.ubuntuupdates.org/package/c … x-firmware si tu as activé les dépôts proposed, donne plutôt

dpkg -l | grep linux-firmware

afin de comparer les versions

Dernière modification par Naziel (Le 06/05/2018, à 20:46)

Hors ligne

#20 Le 06/05/2018, à 20:58

moko138

Re : [Résolu] wifi bloqué à 1M

Suppression du fichier indû :
cd /etc/modprobe.d/ && sudo rm rtl8191ce.conf


Vu

ips:Set to 0 to not use link power save (default 1)
fwlps:Set to 1 to use FW control power save (default 1)

je pense qu'il faut

echo "options rtl8192ce ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf && sudo modprobe -r rtl8192ce && sudo modprobe -a rtl8192ce

et c'est ce que tu as fait.  smile

Que montre

iwconfig

?

À Naziel
  Je n'ai pas de 17.10, mais je pense que linux-firmware existe en version proposed et en version normale, non ?


Question à xubu1957 et à Naziel :
Avec Artful et systemd, est-ce que

sudo modprobe -r rtl8192ce && sudo modprobe -a rtl8192ce

suffit ou bien faut-il redémarrer ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#21 Le 06/05/2018, à 21:06

xubu1957

Re : [Résolu] wifi bloqué à 1M

@ moko138

Je viens de voir cette réponse :

le 10 octobre 2016, mgw2008 a écrit :

De plus, j'ai dû redémarrer l'ordinateur portable, car malgré l'option d'exécution finale -stop, le NM ne fonctionnait plus.

Merci! -mgw

> forum.ubuntuusers.de/topic/wlan-realtek-rtl8192ce


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#22 Le 06/05/2018, à 21:07

Naziel

Re : [Résolu] wifi bloqué à 1M

moko138 a écrit :

À Naziel
  Je n'ai pas de 17.10, mais je pense que linux-firmware existe en version proposed et en version normale, non ?

Oui, mais ce ne sont pas les mêmes versions. Comme ça marchait avant, ça pourrait venir d'une mise à jour, je me suis donc demandé s'il y avait eu des mises à jour de linux-firmware récemment. Pour info, un cas ici du passage à la 18.04, donc linux-firmware plus récent qui pose des problèmes avec des cartes wifi.

moko138 a écrit :

Question à xubu1957 et à Naziel :
Avec Artful et systemd, est-ce que

sudo modprobe -r rtl8192ce && sudo modprobe -a rtl8192ce

suffit ou bien faut-il redémarrer ?

Normalement, ça suffit

Hors ligne

#23 Le 06/05/2018, à 21:21

moko138

Re : [Résolu] wifi bloqué à 1M

Merci !
  - -

Naziel a écrit :

ça marchait avant,

ljere, tu confirmes ? Ton «Je viens de remarquer que mon rate est bloqué à 1M» est ambigu.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#24 Le 06/05/2018, à 21:32

moko138

Re : [Résolu] wifi bloqué à 1M

À une époque, Ludovic m'avait conseillé

sudo iwconfig wlan0 txpower auto

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#25 Le 07/05/2018, à 14:14

ljere

Re : [Résolu] wifi bloqué à 1M

Bonjour,
Merci pour toutes vos réponses, je m'excuse de ne pas avoir pu vous répondre mais j'étais parti bosser, alors

[~](0)jerem:~ sudo iwconfig wlan0 rate 54                             15:03:06 
[sudo] Mot de passe de jerem :       
[~](0)jerem:~ sudo iwconfig                                           15:03:16 
lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"freebox_ljeremie"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:24:D4:E8:DC:A4   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:23   Missed beacon:0

eth0      no wireless extensions.

[~](0)jerem:~                         
[~](0)jerem:~ dpkg -l | grep linux-firmware                           15:03:20 
ii  linux-firmware                             1.169.3                                     all          Firmware for Linux kernel drivers
[~](0)jerem:~      

j'ai essayé un autre noyau mais pareil,
je sais qu'avant de passer en eth j'avais déjà un souci avec le wifi (16.04) mais la commande

sudo iwconfig wlan0 rate 54M

me permettait de le résoudre (on constate qu'avant la commande exigeait un M, alors que maintenant je me retrouve avec une erreur si je le met)

[modprobe.d](0)jerem:/etc/modprobe.d sudo iwconfig wlan0 txpower auto 15:07:13 
[modprobe.d](0)jerem:/etc/modprobe.d sudo iwconfig                    15:14:03 
lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"freebox_ljeremie"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:24:D4:E8:DC:A4   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-32 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:27   Missed beacon:0

eth0      no wireless extensions.

[modprobe.d](0)jerem:/etc/modprobe.d        

astuce nvidia FX5200
Toshiba satellite_c670d-11l ubuntu 18.04 64 bit

Hors ligne