Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 07/12/2017, à 14:01

LukePerp

[Résolu] Désactiver autologin

Bonjour,

Sur une machine Ubuntu Mate 14.04 qui fonctionne bien, l'autologin a été sélectionné lors de l'installation. Au démarrage, Ubuntu démarre sans demander le mot de passe. Je souhaite désactiver cet autologin afin que l'utilisateur soit obliger de taper son mot de passe au démarrage d'Ubuntu, mais mes tentatives ont échoués.
Dans paramètres > uers and group > mot de passe > l'option de demander le mot de passe au démarrage est déjà sélectionné mais ça ne change rien. J'ai switché cette option, sans succès. Un mot de passe est bien définis pour l'utilisateur.
Pourriez-vous m'aider svp à désactiver l'autologin d'ubuntu mate 14.04, merci d'avance

Dernière modification par LukePerp (Le 07/12/2017, à 15:12)


Desktop : Ubuntu Mate 14.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

Hors ligne

#2 Le 07/12/2017, à 14:27

serged

Re : [Résolu] Désactiver autologin

Ça se règle plutôt dans "Fenêtre de connexion" onglet "Connexion automatique" (aucune idée des noms en anglais).


Linux-Mint Sonya 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#3 Le 07/12/2017, à 14:30

nam1962

Re : [Résolu] Désactiver autologin

Donne :

cat /etc/lightdm/lightdm.conf
ls /etc/lightdm/lightdm.conf.d -1

Dernière modification par nam1962 (Le 07/12/2017, à 14:30)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#4 Le 07/12/2017, à 14:42

LukePerp

Re : [Résolu] Désactiver autologin

nam1962 a écrit :

Donne :

cat /etc/lightdm/lightdm.conf
ls /etc/lightdm/lightdm.conf.d -1

Voilà :

utilisateur@utilisateur:~$ cat /etc/lightdm/lightdm.conf
[SeatDefaults]
autologin-guest=false
autologin-user=utilisateur
autologin-user-timeout=0
autologin-session=lightdm-autologin
utilisateur@utilisateur:~$ ls /etc/lightdm/lightdm.conf.d -1
ls: impossible d'accéder à /etc/lightdm/lightdm.conf.d: Aucun fichier ou dossier de ce type
utilisateur@utilisateur:~$

Desktop : Ubuntu Mate 14.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

Hors ligne

#5 Le 07/12/2017, à 14:44

LukePerp

Re : [Résolu] Désactiver autologin

serged a écrit :

Ça se règle plutôt dans "Fenêtre de connexion" .

Je ne trouve pas cette rubrique dans les paramètres d'ubuntu mate 14.04


Desktop : Ubuntu Mate 14.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

Hors ligne

#6 Le 07/12/2017, à 15:00

erresse

Re : [Résolu] Désactiver autologin

Ce sont les lignes "autologin-..." dans le fichier lightdm.conf qui règlent le démarrage automatique de "utilisateur".


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#7 Le 07/12/2017, à 15:04

nam1962

Re : [Résolu] Désactiver autologin

+1, en principe il suffit de les commenter


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#8 Le 07/12/2017, à 15:12

LukePerp

Re : [Résolu] Désactiver autologin

Ça fonctionne, merci.
J'ai commenté la ligne suivante dans ce fichier :

cat /etc/lightdm/lightdm.conf
...
#autologin-user=utilisateur

Dernière modification par LukePerp (Le 12/12/2017, à 11:08)


Desktop : Ubuntu Mate 14.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

Hors ligne

#9 Le 07/12/2017, à 18:56

serged

Re : [Résolu] Désactiver autologin

LukePerp a écrit :
serged a écrit :

Ça se règle plutôt dans "Fenêtre de connexion" .

Je ne trouve pas cette rubrique dans les paramètres d'ubuntu mate 14.04

Je suis avec LinuxMate 18.3 (basé sur Ubuntu 16.04), ça y est, et il me semble qu'avec la LM 17.x (basée sur Ubuntu 14.04) ça y était aussi. Peut-être oublié dans Ubuntu ?

Commence à chercher dans le menu "Login Window".

Effectivement avec la suite de la discussion, Ubuntu Mate utilise Lightdm qui n'a pas de programme de config. LinuxMint utilise mdm (qui a un programme de config mdmsetup).


Linux-Mint Sonya 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#10 Le 10/12/2017, à 11:09

serged

Re : [Résolu] Désactiver autologin

serged a écrit :
LukePerp a écrit :
serged a écrit :

Ça se règle plutôt dans "Fenêtre de connexion" .

Je ne trouve pas cette rubrique dans les paramètres d'ubuntu mate 14.04

Je suis avec LinuxMate 18.3 (basé sur Ubuntu 16.04), ça y est, et il me semble qu'avec la LM 17.x (basée sur Ubuntu 14.04) ça y était aussi. Peut-être oublié dans Ubuntu ?

Commence à chercher dans le menu "Login Window".

Effectivement avec la suite de la discussion, Ubuntu Mate utilise Lightdm qui n'a pas de programme de config. LinuxMint utilise mdm (qui a un programme de config mdmsetup).

En fait si, le programme de config existe :

sudo apt-get install lightdm-settings

(je n'ai pas testé étant avec mdm)


Linux-Mint Sonya 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne