Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#51 Le 13/06/2018, à 00:52

krodelabestiole

Re : [Résolu] Problème installation serveur apache/mysql

change le mot de passe root avec :

sudo mysql_secure_installation

Hors ligne

#52 Le 13/06/2018, à 16:41

oliver2004

Re : [Résolu] Problème installation serveur apache/mysql

Voici :

olivier@olivier-laptop:~$ sudo mysql_secure_installation
[sudo] Mot de passe de olivier : 

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user.  If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): 
OK, successfully used password, moving on...

Setting the root password ensures that nobody can log into the MariaDB
root user without the proper authorisation.

You already have a root password set, so you can safely answer 'n'.

Change the root password? [Y/n] y
New password: 
Re-enter new password: 
Password updated successfully!
Reloading privilege tables..
 ... Success!


By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] y
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] y
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] y
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!
olivier@olivier-laptop:~$ mysql -u root -p
Enter password: 
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
olivier@olivier-laptop:~$ mysql -u root -p
Enter password: 
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
olivier@olivier-laptop:~$ mysql -u root -p
Enter password: 
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
olivier@olivier-laptop:~$

sad


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#53 Le 13/06/2018, à 17:18

bruno

Re : [Résolu] Problème installation serveur apache/mysql

Je pense que c'est normal.
Essaie de te connecter ainsi :

sudo mysql -u root

Dernière modification par bruno (Le 13/06/2018, à 17:19)

En ligne

#54 Le 13/06/2018, à 18:36

oliver2004

Re : [Résolu] Problème installation serveur apache/mysql

bruno a écrit :

Je pense que c'est normal.
Essaie de te connecter ainsi :

sudo mysql -u root

J'ai réussi à me connecter mais toujours avec non passwd d'admin système, pas avec le mot de passe fraîchement changé. C'est normal ?

olivier@olivier-laptop:~$ sudo mysql -u root
[sudo] Mot de passe de olivier :          # ici j'ai mis le nouveau mot de passe sans succès
Désolé, essayez de nouveau.
[sudo] Mot de passe de olivier :           # ici j'ai mis le mot de passe admin système
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 121
Server version: 10.1.29-MariaDB-6 Ubuntu 18.04

Copyright (c) 2000, 2017, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> 

C'est tout de même bizarre


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#55 Le 13/06/2018, à 21:02

bruno

Re : [Résolu] Problème installation serveur apache/mysql

Oui c'est normal.

Le compte root de MariaDB a été créé avec le plugin socket_unix : l'utilisateur MySQL est authentifié par son compte système. C'est la configuration par défaut pour MariaDB et sans doute MySQL sur les dernières versions Ubuntu. Cette configuration à certains avantages au niveau pratique et au niveau de la sécurité.

Si tu veux revenir à une configuration où l'utilisateur root de MySQL s’authentifie avec un mot de passe il faut faire comme indiqué dans la doc lamp :

sudo mysql -u root
mysql> ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'le_mot_de_pass_choisi';
mysql> FLUSH PRIVILEGES;
mysql> QUIT;

Dernière modification par bruno (Le 13/06/2018, à 21:13)

En ligne

#56 Le 13/06/2018, à 23:25

oliver2004

Re : [Résolu] Problème installation serveur apache/mysql

Ok, je tente donc ceci :

MariaDB [(none)]> SELECT User, Host, HEX(authentication_string) FROM mysql.user;
+------------+-----------+----------------------------+
| User       | Host      | HEX(authentication_string) |
+------------+-----------+----------------------------+
| root       | localhost |                            |
| phpmyadmin | localhost |                            |
+------------+-----------+----------------------------+
2 rows in set (0.00 sec)

Donc j'ai renoncé à me connecter en root sur phpmyadmin, mais comme je me connecte en console, c'est pas trop un problème finalement.
J'ai donc vu que je me connectais avec le user phpmyadmin sur phpmyadmin. J'ai donc créé en console une base de données et j'ai donné des droits à phpmyadmin sur cette base...
J'ai ensuite importé le contenu de ma base de données
Ça a l'air de fonctionner, par contre j'ai toujours ces erreurs à chaque fois que je clique sur une table...

Erreur phpmyadmin

Mais bon c'est apparemment plus un Warning que quelque chose de grave. Par contre ce qui est gênant c'est que ça s'affiche à chaque fois qu'on sélectionne une table. Je vais voir un moyen pour pas l'afficher.
Je teste et je reviens... smile

Dernière modification par oliver2004 (Le 14/06/2018, à 00:32)


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#57 Le 14/06/2018, à 16:17

oliver2004

Re : [Résolu] Problème installation serveur apache/mysql

Bon, et bien à part ce warning (qui est tout de même embêtant car ça descend en bout de page à chaque sélection de table) tout semble fonctionner, enfin, parfaitement. smile
Vraiment merci à bruno et krodelabestiole pour votre investissement ! C'est super, merci, vraiment.
Mais je vais chercher de mon côté pour voir un moyen que ces warnings ne s'affichent plus à chaque sélection de table.
Je marque à résolu. big_smile

[Edit] Voilà, du coup, je suis passé par désinstaller phpmyadmin, installer adminer, mais je ne sais pas ce qui se passe, je ne vois pas les même options sur mon écran que sur les tutos que j'ai pu suivre sur cette application (pas de lien pour créer des tables, voir la structure d'une table, réaliser des relations entre table, assez bizarre), j'ai tenté de réinstaller plusieurs fois sans succès, j'ai désinstallé, réinstallé, et suis revenu à phpmyadmin, mais cette fois, plus par un sudo apt install phpmyadmin, mais par un téléchargemetn du dossier depuis le site de phpmyadmin dans le dossier/var/www/html, décompression et connexion par http://localhost/phpmyadmin...
Et voilà que je me connecte avec le user phpmyadmin, et je n'ai plus d'erreur...
Ouf !!! Je vais pouvoir enfin travailler ! cool

Encore merci à vous smile

Dernière modification par oliver2004 (Le 15/06/2018, à 06:02)


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#58 Le 15/06/2018, à 18:03

krodelabestiole

Re : [Résolu] Problème installation serveur apache/mysql

pour pas trop polluer le sujet initial j'ai déplacé la suite de la conversation là : https://forum.ubuntu-fr.org/viewtopic.php?id=2027272

Hors ligne

#59 Le 16/06/2018, à 14:17

krodelabestiole

Re : [Résolu] Problème installation serveur apache/mysql

oliver2004 a écrit :

Bon, et bien à part ce warning (qui est tout de même embêtant car ça descend en bout de page à chaque sélection de table)

perso j'ai aussi eu un warning pour chaque table avec phpMyAdmin sur Bionic.
apparemment une incompatibilité de cette version avec PHP 7.2, c'est balot !

le message d'erreur est

Warning in ./libraries/sql.lib.php#601
count(): Parameter must be an array or an object that implements Countable

et la solution est là : https://stackoverflow.com/a/49483740/3175946
remplacer

(count($analyzed_sql_results['select_expr'] == 1)

par

(count($analyzed_sql_results['select_expr']) == 1

dans /usr/share/phpmyadmin/libraries/sql.lib.php (ligne 613)

Hors ligne

#60 Le 25/06/2018, à 17:24

oliver2004

Re : [Résolu] Problème installation serveur apache/mysql

Ahh ok, c'est bon à savoir.
Là avec la version de phpmyadmin installée qui est celle que j'ai téléchargée sur le site de mysql et non celle des paquets, tout roule dans le meilleur des monde, je n'ai plus ce warning, mais c'est noté à l'occasion.
Merci


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne