Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/07/2018, à 21:36

mat1391

Perte de connexion internet au retour de mise en veille

Bonjour,

Depuis peu (et du jour au lendemain sans raison apparente, sans doute suite à une mise à jour logicielle...), mon PC (Acer Aspire-XC-780 sous Ubuntu 16.04) ne se reconnecte plus à Internet (connexion 1G Ethernet) au sortir d'une mise en veille. Dans les paramètres système, la connexion en question est en effet alors reconnue par Ubuntu comme ayant le "câble débranché". Seul un reboot permet de rétablir la connexion.

La connexion Internet du même PC via Windows fonctionne bien, et pas de souci au niveau de la box (connexions d'autres appareils OK)

Je vous joins des détails issus de commandes terminal qui peuvent éventuellement vous aider à trouver la source du problème (à moins que le problème ne se trouve dans la configuration de la mise en veille) :
_______________________________________

sudo lshw -C network
  *-network               
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: enp2s0
       version: 11
       numéro de série: 98:ee:cb:54:46:a4
       taille: 1Gbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-2_0.0.1 02/06/13 ip=192.168.0.33 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       ressources: irq:16 portE/S:d000(taille=256) mémoire:df100000-df100fff mémoire:d2100000-d2103fff


sudo ifconfig [b]<AVEC CONNEXION DEFECTUEUSE>[/b]
enp2s0    Link encap:Ethernet  HWaddr 98:ee:cb:54:46:a4  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:74881 erreurs:0 :0 overruns:0 frame:0
          TX packets:9019 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:103781135 (103.7 MB) Octets transmis:1041734 (1.0 MB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:840 erreurs:0 :0 overruns:0 frame:0
          TX packets:840 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:79894 (79.8 KB) Octets transmis:79894 (79.8 KB)


sudo ifconfig [b]<AVEC CONNEXION OPERATIONNELLE>[/b]
enp2s0    Link encap:Ethernet  HWaddr 98:ee:cb:54:46:a4  
          inet adr:192.168.0.33  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::f300:8a23:7e39:cf/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:74259 erreurs:0 :0 overruns:0 frame:0
          TX packets:8496 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:103557820 (103.5 MB) Octets transmis:950041 (950.0 KB)

lo        Link encap:Boucle locale  
[b]          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte[/b]
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:734 erreurs:0 :0 overruns:0 frame:0
          TX packets:734 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:68817 (68.8 KB) Octets transmis:68817 (68.8 KB)


cat  /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

______________________________________

Merci de m'aider à résoudre ce problème. Si vous avez besoin d'autres infos dites le moi

Cordialement,
Mathieu


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 06/07/2018, à 02:45)

Hors ligne

#2 Le 11/07/2018, à 19:35

Ahote

Re : Perte de connexion internet au retour de mise en veille

Bonjour,

est tu en ip static ou en dhcp ?
colle un retour de :

cat /etc/network/interfaces

cdt

Dernière modification par Ahote (Le 11/07/2018, à 19:36)

Hors ligne

#3 Le 11/07/2018, à 19:43

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bonjour,
Voici :

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Merci,
Mathieu

Hors ligne

#4 Le 11/07/2018, à 19:57

Ahote

Re : Perte de connexion internet au retour de mise en veille

ok il te manque les lignes


si tu est bien en DHCP et pas en ip static

fait

sudo gedit /etc/network/interfaces

puis ajoute les lignes suivante :

auto eth0
iface eth0 inet dhcp

en remplaçant "eth0" par le nom de ta connexion

pour connaître le nom de ta connexion

ifconfig

ca doit ressemblé a qqch du genre enp*s*

ensuite redémarre le réseau avec

/etc/init.d/networking restart

ca devrais réglé le problème

Hors ligne

#5 Le 11/07/2018, à 20:35

Ahote

Re : Perte de connexion internet au retour de mise en veille

je n’avais pas vue ton retour ifconig

du coup ca donne :

auto enp2s0
iface enp2s0 inet dhcp

Dernière modification par Ahote (Le 11/07/2018, à 20:35)

Hors ligne

#6 Le 11/07/2018, à 21:15

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bonjour,

J'ai bien rajouté les lignes avec enp2s0 dans network/interfaces (à la suite de celles avec lo). Le fichier interfaces ressemble donc à cela :

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
auto enp2s0
iface enp2s0 inet dhcp

Mais ça ne résout pas le problème. Pire, j'ai le pictogramme des 2 flèches indiquant une connexion active au retour de mise en veille, mais dans les faits elle ne l'est pas (toujours pareil, elle revient en rebootant), alors qu'avant j'avais le picto de l'éventail WiFi vide quand ça ne marchait pas (et bien les 2 flèches quand ça marchait)...

Le fichier est bon ? J'ai peut-être oublié ou mal fait quelque chose... Notamment j'ai l'impression que quelque chose n'a pas fonctionné correctement en sauvant le fichier interfaces. J'ai en effet ce message ds la console :

** (gedit:2425): WARNING **: Set document metadata failed: La définition de l’attribut metadata::gedit-encoding n’est pas prise en charge

Merci encore

Hors ligne

#7 Le 11/07/2018, à 22:55

Ahote

Re : Perte de connexion internet au retour de mise en veille

a tu réessayé d'ouvrir le fichier interface pour voir si ca a bien sauvegardé ?
que donne un ifconfig maintenant ?
comment est tu raccordé a internet ?


a tu utilisé le SUDO pour modifier le fichier interfaces ?

Dernière modification par Ahote (Le 11/07/2018, à 22:59)

Hors ligne

#8 Le 12/07/2018, à 09:44

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bonjour,

1. Oui j'ai ouvert le fichier interface et a priori il a bien été sauvegardé, il correspond bien à ce que j'ai écrit dans le post précédent

2. Le ifconfig semble dire que la connexion est opérationnelle :

enp2s0    Link encap:Ethernet  HWaddr 98:ee:cb:54:46:a4  
          inet adr:192.168.0.33  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::9aee:cbff:fe54:46a4/64 Scope:Lien
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:27544 erreurs:0 :0 overruns:0 frame:0
          TX packets:9880 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:34678281 (34.6 MB) Octets transmis:2515877 (2.5 MB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:319 erreurs:0 :0 overruns:0 frame:0
          TX packets:319 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:29269 (29.2 KB) Octets transmis:29269 (29.2 KB)

Ma connexion internet est une connexion filaire Ethernet

Par contre, c'est peut-être là que le bat blesse, j'ai rajouté les lignes du fichier interfaces directement dans l'éditeur de texte, que j'ai bien ouvert par la commande

sudo gedit /etc/network/interfaces

. Et c'est au moment de la sauvegarde (via l'éditeur de texte également) que j'ai l'impression que qqchose n'est pas bien passé, même si comme je l'ai dit plus haut, le fichier est bien sauvé (maintenant est-ce qu'il est lu correctement au moment d'établir la connexion, ça je ne sais pas...)

Merci de ton aide

Hors ligne

#9 Le 12/07/2018, à 10:47

Ahote

Re : Perte de connexion internet au retour de mise en veille

a priori ta connexion est bien active mais est limité au réseau local
peut être un problème de passerelle
essaye :

ip route show

et colle le retour stp

quelle et ta box ?
connais tu son ip(local 192.168.x.x) ?

non le problème ne vient pas de la sauvegarde du fichier a priori


ps: je sais que c'est un problème récurent sous Ubuntu

Dernière modification par Ahote (Le 12/07/2018, à 10:48)

Hors ligne

#10 Le 12/07/2018, à 11:38

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bonjour,
ip route show donne

default via 192.168.0.254 dev enp2s0 
169.254.0.0/16 dev enp2s0  scope link  metric 1000 
192.168.0.0/24 dev enp2s0  proto kernel  scope link  src 192.168.0.33 

Le même commande lorsque la connexion ne marche pas (on a bien des linkdown en plus) :

default via 192.168.0.254 dev enp2s0 linkdown 
169.254.0.0/16 dev enp2s0  scope link  metric 1000 linkdown 
192.168.0.0/24 dev enp2s0  proto kernel  scope link  src 192.168.0.33 linkdown

J'ai une freebox revolution, connectée également à ma TV en ethernet, et occasionnellement à mon smartphone et mon autre PC en wifi, et toutes ces autres connexions marchent bien

Autre chose : lorsque je vais voir les infos sur la connexion à partir du picto double flèche, il me dit qu'aucune connexion valide n'est trouvée, même lorsqu'elle marche !

Merci de ton aide !
Mathieu

PS : je vais m'absenter quelques jours à partir de cette après-midi donc je ne répondrai sans doute pas rapidement, mais n'hésite pas à laisser quand même des message sur ce fil

Hors ligne

#11 Le 12/07/2018, à 12:38

Ahote

Re : Perte de connexion internet au retour de mise en veille

honnêtement je sèche un peut
plein de monde a ce probleme sous ubuntu

je suis tombé la dessus en cherchant un peu :
https://forum.ubuntu-fr.org/viewtopic.php?id=319502

il semblerait que le problème vienne plus du coté gestion de l'alimentation que du coté gestion réseau
si je tombe sur qqch d'intéressant je te le posterait ici

Hors ligne

#12 Le 12/07/2018, à 12:41

mat1391

Re : Perte de connexion internet au retour de mise en veille

ok merci

Hors ligne

#13 Le 12/07/2018, à 12:53

ylag

Re : Perte de connexion internet au retour de mise en veille

Bonjour,

Après une sortie de veille où tu ne retrouves pas ta connexion, essaie les commandes:

sudo modprobe -rv r8169

...suivi de:

sudo modprobe -v r8169

Ces deux commandes servent à successivement décharger et recharger le module du pilote de ta carte réseau.
Si ça te semble fonctionner et que ton réseau est réactivé, tu pourrais suivre les indications au #15 de cette discussion pour automatiser le tout:

[RÉSOLU] Sortie de veille perte réseau

Il est possible, pour des raisons qui m'échappent, que tu aies parfois à refaire quand même à la main les deux commandes modprobe malgré la présence du script proposé dans le lien.
Il serait aussi peut-être bon de revenir à la configuration par défaut de ton fichier /etc/network/interfaces comme dans le retour au #3.

A+

Ajout:
Quelquefois, la simple réinitialisation de ton interface réseau peut suffire. Pour ce faire:

sudo ip link set enp2s0 down

...suivi de:

sudo ip link set enp2s0 up

Dernière modification par ylag (Le 13/07/2018, à 22:37)

Hors ligne

#14 Le 17/07/2018, à 10:44

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bon j'ai essayé les 2 commandes sudo modprobe et ça ne marche pas.
Tout juste la première commande (-rv) me remet dans une situation "normale" d'une connexion qui ne marche pas, à savoir l'éventail WiFi vide au lieu des 2 flèches sur le picto de la connexion (cf post #6), et une commande ip route show qui ne renvoie rien, et je n'ai vu aucun effet de la 2e commande -v...
Je n'ai vu aucun effet non plus des commandes set enp2s0 down & up...

Tout cela avec la nouvelle ou l'ancienne version du fichier interfaces...

Donc là je sais pas quoi vous dire de plus...
Si vous avez d'autres idées... Merci pour votre aide

Mathieu

Dernière modification par mat1391 (Le 17/07/2018, à 10:45)

Hors ligne

#15 Le 17/07/2018, à 11:31

DRbuntu91

Re : Perte de connexion internet au retour de mise en veille

Bonjour
Voir ici ou il est écrit:

Il semble qu'à partir de la version 16.04 et du noyau 4.4.0-66 il faut en plus relancer NetworkManager

sudo service network-manager restart

Tu as fait ça (cad. après les commandes suggérés par ylag qui rechargent le pilote)?


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#16 Le 17/07/2018, à 12:55

ylag

Re : Perte de connexion internet au retour de mise en veille

Salut,

Si tu utilises NetworkManager, ton fichier /etc/network/interfaces devrait être comme dans le retour au commentaire #3, sinon inutile d'utiliser une commande comme celle proposée par @DRbuntu91 au commentaire #15, puisque ton interface ne serait alors pas gérée par NetworkManager ?

Par exemple chez-moi je suis en ADSL, branché en ethernet via un router TP-Link Archer C-50 et le pilote r8169 est utilisé.

Mon fichier /etc/network/interfaces:

yvan@yvan-maison:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
yvan@yvan-maison:~$

Retour de ifconfig:

yvan@yvan-maison:~$ ifconfig
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.198  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::ceb0:acc7:7a48:aecb  prefixlen 64  scopeid 0x20<link>
        ether 00:1f:d0:85:ed:5e  txqueuelen 1000  (Ethernet)
        RX packets 291327  bytes 426595284 (426.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 155956  bytes 11675888 (11.6 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 698  bytes 61502 (61.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 698  bytes 61502 (61.5 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

yvan@yvan-maison:~$ 

Retour de ip route show:

yvan@yvan-maison:~$ ip route show
default via 192.168.0.1 dev enp4s0 proto dhcp metric 100 
169.254.0.0/16 dev enp4s0 scope link metric 1000 
192.168.0.0/24 dev enp4s0 proto kernel scope link src 192.168.0.198 metric 100 
yvan@yvan-maison:~$

Retour des commandes de rechargement du module r8169:

yvan@yvan-maison:~$ sudo modprobe -rv r8169
[sudo] Mot de passe de yvan : 
rmmod r8169
rmmod mii
yvan@yvan-maison:~$
yvan@yvan-maison:~$ sudo modprobe -v r8169
insmod /lib/modules/4.15.0-24-generic/kernel/drivers/net/mii.ko 
insmod /lib/modules/4.15.0-24-generic/kernel/drivers/net/ethernet/realtek/r8169.ko 
yvan@yvan-maison:~$

...on voit que le module a été rechargé correctement.

En espérant que ça pourra t'être utile...

Ajout: Attention à la commande sudo gedit /etc/network/interfaces: Il est déconseillé d'ouvrir une application graphique telle que gedit avec sudo. Si possible, utilise plutôt nano pour modifier ce fichier en ligne de commande.

A+

Dernière modification par ylag (Le 17/07/2018, à 13:02)

Hors ligne

#17 Le 17/07/2018, à 13:43

ylag

Re : Perte de connexion internet au retour de mise en veille

Salut,

mat1391 a écrit :

Bon j'ai essayé les 2 commandes sudo modprobe et ça ne marche pas.
Tout juste la première commande (-rv) me remet dans une situation "normale" d'une connexion qui ne marche pas, à savoir l'éventail WiFi vide au lieu des 2 flèches sur le picto de la connexion (cf post #6

Tu parles de WIFi alors que les commandes suggérées ici sont relatives à ton interface ethernet, qui serait enp2s0 chez-toi...
Une fois les deux commandes modprobe passées, tu pourrais tenter, après une attente de quelques secondes, de "pinger" un site internet pour voir si ton réseau filaire est bien restauré, sans te préoccuper de l'état de l'icône réseau.

Par exemple, avec la commande: ping -c2 <un-site-internet-quelconque> :

yvan@yvan-maison:~$ ping -c2 www.google.fr
PING www.google.fr (172.217.13.131) 56(84) bytes of data.
64 bytes from yul02s05-in-f3.1e100.net (172.217.13.131): icmp_seq=1 ttl=55 time=41.0 ms
64 bytes from yul02s05-in-f3.1e100.net (172.217.13.131): icmp_seq=2 ttl=55 time=40.9 ms

--- www.google.fr ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 40.978/41.019/41.060/0.041 ms
yvan@yvan-maison:~$

...indique que ma connexion réseau est active et que je rejoins Internet correctement.

A+

Dernière modification par ylag (Le 17/07/2018, à 13:52)

Hors ligne

#18 Le 22/07/2018, à 18:57

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bon là je sèche complètement

Quand la connexion ne marche pas elle ne marche vraiment pas, les modprobe ne font rien, pas plus que le restart du network manager, pas de retour de ping, rien...

J'ai essayé de suivre la procédure présentée ici, mais je n'ai pas de driver listé dans la commande lshw -class network, et je ne vois pas quoi prendre dans la commande lsmod (que la connexion soit active ou non d'ailleurs...) :

lshw -class network
ATTENTION: ce programme devrait être lancé en tant que super-utilisateur.
  *-network               
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: enp2s0
       version: 11
       numéro de série: 98:ee:cb:54:46:a4
       taille: 1Gbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-2_0.0.1 02/06/13 ip=192.168.0.33 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       ressources: irq:16 portE/S:d000(taille=256) mémoire:df100000-df100fff mémoire:d2100000-d2103fff
ATTENTION: les informations sont potentiellement incomplètes ou erronées, vous devriez lancer ce programme en tant que super-utilisateur.
mathieu@mathieu-Aspire-XC-780:~$ lsmod
Module                  Size  Used by
rfcomm                 77824  14
bnep                   20480  2
nls_iso8859_1          16384  1
snd_hda_codec_hdmi     49152  1
ip6t_REJECT            16384  1
nf_reject_ipv6         16384  1 ip6t_REJECT
nf_log_ipv6            16384  5
xt_hl                  16384  22
ip6t_rt                16384  3
input_leds             16384  0
joydev                 24576  0
intel_rapl             20480  0
x86_pkg_temp_thermal    16384  0
intel_powerclamp       16384  0
coretemp               16384  0
kvm_intel             208896  0
snd_seq_midi           16384  0
kvm                   598016  1 kvm_intel
irqbypass              16384  1 kvm
crct10dif_pclmul       16384  0
snd_hda_codec_realtek    98304  1
nf_conntrack_ipv6      20480  8
crc32_pclmul           16384  0
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
nf_defrag_ipv6         36864  1 nf_conntrack_ipv6
snd_seq_midi_event     16384  1 snd_seq_midi
ghash_clmulni_intel    16384  0
cryptd                 24576  1 ghash_clmulni_intel
intel_cstate           20480  0
snd_rawmidi            32768  1 snd_seq_midi
intel_rapl_perf        16384  0
ipt_REJECT             16384  1
snd_hda_intel          40960  5
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
nf_reject_ipv4         16384  1 ipt_REJECT
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
serio_raw              16384  0
snd_hwdep              20480  1 snd_hda_codec
sparse_keymap          16384  0
nf_log_ipv4            16384  5
snd_pcm                98304  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
nf_log_common          16384  2 nf_log_ipv6,nf_log_ipv4
wmi_bmof               16384  0
xt_LOG                 16384  10
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
xt_limit               16384  13
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
xt_tcpudp              16384  18
snd_timer              32768  2 snd_seq,snd_pcm
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
xt_addrtype            16384  4
snd                    81920  21 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
bluetooth             557056  41 btrtl,btintel,bnep,btbcm,rfcomm,btusb
soundcore              16384  1 snd
mei_me                 40960  0
ecdh_generic           24576  1 bluetooth
intel_pch_thermal      16384  0
mei                    90112  1 mei_me
shpchp                 36864  0
acpi_pad              180224  0
tpm_crb                16384  0
mac_hid                16384  0
nf_conntrack_ipv4      16384  8
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
xt_conntrack           16384  16
ip6table_filter        16384  1
ip6_tables             28672  1 ip6table_filter
nf_conntrack_netbios_ns    16384  0
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
nf_nat_ftp             16384  0
nf_nat                 32768  1 nf_nat_ftp
nf_conntrack_ftp       20480  1 nf_nat_ftp
nf_conntrack          131072  8 nf_conntrack_ipv6,nf_conntrack_ftp,nf_conntrack_ipv4,nf_conntrack_broadcast,nf_nat_ftp,nf_conntrack_netbios_ns,xt_conntrack,nf_nat
libcrc32c              16384  2 nf_conntrack,nf_nat
iptable_filter         16384  1
parport_pc             36864  0
ppdev                  20480  0
ip_tables              28672  1 iptable_filter
x_tables               40960  13 xt_LOG,ipt_REJECT,ip_tables,iptable_filter,xt_tcpudp,xt_limit,ip6t_REJECT,ip6table_filter,xt_addrtype,ip6t_rt,xt_conntrack,ip6_tables,xt_hl
lp                     20480  0
parport                49152  3 lp,parport_pc,ppdev
autofs4                40960  2
hid_generic            16384  0
uas                    24576  0
usb_storage            69632  1 uas
usbhid                 49152  0
hid                   118784  2 hid_generic,usbhid
nouveau              1724416  3
mxm_wmi                16384  1 nouveau
i2c_algo_bit           16384  1 nouveau
ttm                   106496  1 nouveau
drm_kms_helper        172032  1 nouveau
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
r8169                  86016  0
psmouse               147456  0
mii                    16384  1 r8169
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
ahci                   36864  4
drm                   401408  6 nouveau,ttm,drm_kms_helper
libahci                32768  1 ahci
wmi                    24576  3 wmi_bmof,mxm_wmi,nouveau
video                  45056  1 nouveau
mathieu@mathieu-Aspire-XC-780:~$ D

D'autres idées ?
Car pour le moment je fais en sorte que le PC ne se mette pas en veille, ou je le reboote tout le temps... C'est pas ce qu'il y a de meilleur pour l'environnement ou le vieillissement de la machine...

Merci de votre aide
Mathieu

PS : et on m'avait dit que Linux ça plantait jamais... smile smile

Hors ligne

#19 Le 22/07/2018, à 19:39

ylag

Re : Perte de connexion internet au retour de mise en veille

Salut,

mat1391 a écrit :

mais je n'ai pas de driver listé dans la commande lshw -class network, et je ne vois pas quoi prendre dans la commande lsmod

Ben, ton driver éthernet est bien r8169, non? Le même que pour moi d'ailleurs. On le voit dans ton retour de lsmod et de lshw:

 configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI ... 

C'est cette la valeur à utiliser avec le tuto que tu cites...

Pourrais-tu nous donner quand même le retour complet des deux premières commandes du commentaire #13 après une sortie de veille ?

A+

Dernière modification par ylag (Le 22/07/2018, à 19:49)

Hors ligne

#20 Le 22/07/2018, à 20:22

mat1391

Re : Perte de connexion internet au retour de mise en veille

Ah ok le driver était bien caché smile. J'ai suivi la procédure décrite avec, mais sans plus de succès...

Voici les retours des commandes :

sudo modprobe -rv r8169
[sudo] Mot de passe de mathieu : 
rmmod r8169
rmmod mii
mathieu@mathieu-Aspire-XC-780:~$ sudo modprobe -v r8169
insmod /lib/modules/4.15.0-24-generic/kernel/drivers/net/mii.ko 
insmod /lib/modules/4.15.0-24-generic/kernel/drivers/net/ethernet/realtek/r8169.ko 
mathieu@mathieu-Aspire-XC-780:~$ ip route show
mathieu@mathieu-Aspire-XC-780:~$ 

Pour info, c'est la même chose quand la connexion marche au départ (sauf le ip route show que j'ai ajouté après, qui renvoie quelque chose ds ce cas et qui ne renvoie rien en sortie de veille)...
Comme déjà dit, ces commandes n'ont aucun effet pour réactiver la connexion au retour de veille, mais elles marchent bien quand la connexion est active au départ (désactivation puis réactivation).

Des idées ?...

Merci,
Mathieu

Dernière modification par mat1391 (Le 22/07/2018, à 20:25)

Hors ligne

#21 Le 22/07/2018, à 22:56

ylag

Re : Perte de connexion internet au retour de mise en veille

Salut,

On voit bien au #20 que les commandes s'accomplissent normalement, rien à signaler de ce côté.

Que donnerait:

sudo dhclient enp2s0

...immédiatement après les deux commandes modprobe ?

Si tu utilises Network-Manager et que ton fichier /etc/network/interfaces a été modifié: Après en avoir fait une copie de sauvegarde, tu pourrais tenter de le restaurer aux valeurs par défaut (comme dans le retour au commentaire #3). Puis en cliquant l'icône du réseau dans ton panneau supérieur, faire "Modifications des connexions...", repérer et détruire ta connexion réseau éthernet pour la recréer en faisant ensuite "Ajouter..." et choisir une nouvelle connexion éthernet...?

Ces connexions sont des fichiers archivés dans le dossier /etc/NetworkManager/system-connections. Si tu as repéré le nom de la tienne, avant de la détruire dans l'interface de Network-Manager, copie-en le fichier sur ton bureau par exemple, pour pouvoir le restaurer si besoin est:

sudo cp /etc/NetworkManager/system-connections/Ma-Connexion-à-sauvegarder ~/Bureau/Ma-Connexion-à-sauvegarder

On ne sait jamais, ça pourrait rétablir ton interface...

A+

Dernière modification par ylag (Le 22/07/2018, à 23:10)

Hors ligne

#22 Le 23/07/2018, à 19:40

mat1391

Re : Perte de connexion internet au retour de mise en veille

Bon, alors dhclient ne renvoie rien quand la connexion ne marche pas, et renvoie 'file exists' quand elle marche
Détruire la connexion existante et en reconstruire une nouvelle ne change rien au schmilblick (c'est le premier truc que j'avais essayé...)
J'utilise le fichier interfaces avec les valeurs par défaut depuis un petit moment, car le modifier ne changeait rien non plus...

Bref, on stagne toujours sad

Merci,
Mathieu

Hors ligne

#23 Le 23/07/2018, à 20:49

ylag

Re : Perte de connexion internet au retour de mise en veille

Salut,

Alors désolé de ne pouvoir t'aider davantage, mon but était de te dépanner pour le rechargement du module éthernet en sortie de veille. Si ça ne fonctionne pas pour toi, je ne saurai diagnostiquer l'origine de ton problème.

A+

Dernière modification par ylag (Le 15/08/2018, à 13:56)

Hors ligne

#24 Le 15/08/2018, à 13:07

xubu1957

Re : Perte de connexion internet au retour de mise en veille

[HS]   

Bonjour,

@ylag

Une idée, pour cette discussion > forum.ubuntu-fr.org/viewtopic.php?pid=21955546#p21955546 ?

Merci d'avance.

[/HS]


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#25 Le 15/08/2018, à 13:34

ylag

Re : Perte de connexion internet au retour de mise en veille

[HS]
@xubu1957:

Salut,

Désolé, je n'ai pas d'autres pistes si la connexion doit être réinitialisée après le démarrage, et non simplement en sortie de veille.

Chez-moi, il arrive à de très rares occasions autant en Ubuntu 16.04 que sur la 18.04 d'avoir à réinitialiser ma connexion ethernet au démarrage, mais je n'ai pas besion de faire la troisième commande dhclient enp4s0: les deux premières suffisent toujours. Je soupçonne dans ce cas un problème de communication entre mon router et le modem ADSL par lequel j'accède au réseau internet.

Par contre, le commentaire de @maxire au #29 de la discussion que tu cites: maxire_#29 semblerait intéressant à approfondir ?

A+
[/HS]

Dernière modification par ylag (Le 15/08/2018, à 13:48)

Hors ligne