Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/01/2021, à 12:55

alexandre_caze

[Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Bonjour à tous,

Je viens d'acheter un Asus Vivobook 14 R415 avec Windows 10 pré-installé, et j'ai suivi un tuto (https://lecrabeinfo.net/installer-ubunt … ws-10.html) pour installer Ubuntu 20.4 en dual boot à partir d'une clé USB.

Le souci
L'installation fonctionne, mais l'ordi n'affiche pas l'invite qui permet de choisir entre ubuntu et windows au démarrage (même quand j'appuie sur shift à répétition ou en continu). Windows fonctionne, mais je ne peux pas booter sur ubuntu.

Ce que j'ai essayé
Suite à mes recherches j'ai :
- désactivé le Secure Boot dans le BIOS
- désactivé le Fast Boot je ne sais plus où dans windows
- tenté boot-repair à partir d'une session "Essayer Ubuntu" (en bootant sur la clé). boot-repair ne me propose pas de réparation

Voici le rapport boot-info https://paste.ubuntu.com/p/hZzpYZJstM/

Info complémentaire
Je ne sais pas si c'est lié, mais quand je boote sur la clé usb j'ai un message "ima: error communicating to tpm chip" (exactement comme décrit ici https://forums.linuxmint.com/viewtopic.php?t=325465). J'ai cherché une option "TPM" ou "Intel Platform Trust Technology" 10 fois dans le BIOS, j'ai activé le mot de passe admin et utilisateur, sans jamais trouvé cette option.

Je suis novice dans ces problématiques de UEFI/BIOS et j'avoue que je suis perdu et ne sais plus trop quoi essayer.
Merci d'avance pour votre aide !
Alexandre

Dernière modification par alexandre_caze (Le 17/01/2021, à 15:48)

Hors ligne

#2 Le 16/01/2021, à 18:23

malbo

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Bonjour,
Ton Boot-info est là :

boot-repair-4ppa125                                              [20210116_1047]

============================== Boot Info Summary ===============================

 => Syslinux MBR (5.00 and higher) is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 6.04
    Boot sector info:  Syslinux looks at sector 32784 of /dev/sda1 for its 
                       second stage. The integrity check of Syslinux failed. 
                       No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg /syslinux.cfg 
                       /efi/BOOT/grubx64.efi /efi/BOOT/mmx64.efi /ldlinux.sys

md127: _________________________________________________________________________

    File system:       
    Boot sector type:  Unknown
    Boot sector info: 

md/imsm1: ______________________________________________________________________

    File system:       
    Boot sector type:  Unknown
    Boot sector info: 


================================ 1 OS detected =================================

OS#1:   Ubuntu 20.04.1 LTS on nvme0n1p5

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
Live-session OS is Ubuntu 64-bit (Ubuntu 20.04.1 LTS, focal, x86_64)


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0003,0004,0000
Boot0000* ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* Windows Boot Manager	HD(1,GPT,61a7ba79-ea63-4099-9e0e-a81d6f436582,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....j...............
Boot0004* UEFI: SanDisk, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,MBR,0xf2db,0x800,0xee7800)..BO



============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

nvme0n1	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes
nvme1n1	: notGPT,	no-BIOSboot,	has-noESP, 	not-usb,	not-mmc, no-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

nvme0n1p1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
nvme0n1p3	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
nvme0n1p4	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
nvme0n1p5	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

nvme0n1p1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p3	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p4	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot
nvme0n1p5	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

nvme0n1p1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p3	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p4	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p5	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1

fdisk -l (filtered): ___________________________________________________________

Disk nvme0n1: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk identifier: 481F44C2-C692-4DB9-A7CA-AC1BE00C006B
              Start        End   Sectors   Size Type
nvme0n1p1      2048     534527    532480   260M EFI System
nvme0n1p2    534528     567295     32768    16M Microsoft reserved
nvme0n1p3    567296  793457294 792889999 378.1G Microsoft basic data
nvme0n1p4 998258688 1000204287   1945600   950M Windows recovery environment
nvme0n1p5 793458688  998258687 204800000  97.7G Linux filesystem
Partition table entries are not in disk order.
Disk nvme1n1: 27.26 GiB, 29260513280 bytes, 57149440 sectors
Disk sda: 7.46 GiB, 8002732032 bytes, 15630336 sectors
Disk identifier: 0x0000f2db
      Boot Start      End  Sectors  Size Id Type
sda1  *     2048 15630335 15628288  7.5G  c W95 FAT32 (LBA)

parted -lm (filtered): _________________________________________________________

sda:8003MB:scsi:512:512:msdos:SanDisk Cruzer Force:;
1:1049kB:8003MB:8002MB:fat32::boot, lba;
nvme0n1:512GB:nvme:512:512:gpt:INTEL HBRPEKNX0202A:;
1:1049kB:274MB:273MB:fat32:EFI system partition:boot, esp;
2:274MB:290MB:16.8MB::Microsoft reserved partition:msftres;
3:290MB:406GB:406GB:ntfs:Basic data partition:msftdata;
5:406GB:511GB:105GB:ext4::;
4:511GB:512GB:996MB:ntfs::hidden, diag;
nvme1n1:29.3GB:nvme:512:512:unknown:INTEL HBRPEKNX0202AO:;

blkid (filtered): ______________________________________________________________

NAME        FSTYPE          UUID                                 PARTUUID                             LABEL       PARTLABEL
sda                                                                                                               
└─sda1      vfat            306A-FD43                            0000f2db-01                          UBUNTU 20_0 
nvme0n1     isw_raid_member                                                                                       
├─nvme0n1p1 vfat            C8E0-30E9                            61a7ba79-ea63-4099-9e0e-a81d6f436582 SYSTEM      EFI system partition
├─nvme0n1p2                                                      86344b88-211c-453b-ab95-9859733028f8             Microsoft reserved partition
├─nvme0n1p3 ntfs            22D4E208D4E1DDD3                     2d43ce60-1ac6-4871-84fc-c6dfd91e9921 OS          Basic data partition
├─nvme0n1p4 ntfs            2CCCFAC6CCFA88FA                     faace40a-5400-47cb-a055-e1b8a3fa4688 RECOVERY    Basic data partition
└─nvme0n1p5 ext4            8574c742-a197-4723-8f7e-908ec64b21d1 6a9c55ed-cc8a-490e-8319-29e0d043aa63             
nvme1n1     isw_raid_member                                                                                       

df (filtered): _________________________________________________________________

        Avail Use% Mounted on
sda1     4.9G  35% /cdrom

Mount options: __________________________________________________________________

sda1   ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro

====================== sda1/boot/grub/grub.cfg (filtered) ======================

Ubuntu
Ubuntu (safe graphics)
OEM install (for manufacturers)
Boot from next volume
UEFI Firmware Settings

========================= sda1/syslinux.cfg (filtered) =========================

DEFAULT loadconfig

LABEL loadconfig
  CONFIG /isolinux/isolinux.cfg
  APPEND /isolinux/

==================== sda1: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             boot/grub/grub.cfg                             1

================== sda1: Location of files loaded by Syslinux ==================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             syslinux.cfg                                   1
            ?? = ??             ldlinux.sys                                    1


======================== Unknown MBRs/Boot Sectors/etc =========================

Unknown BootLoader on md127


Unknown BootLoader on md/imsm1



=============================== StdErr Messages ================================

File descriptor 63 (pipe:[112383]) leaked on lvs invocation. Parent PID 19960: /bin/bash
mdadm: (IMSM): Unsupported attributes : 3000000
mdadm: Unsupported attributes in IMSM metadata.Arrays activation is blocked.
mdadm: Cannot activate member /md126/0 in /dev/md/imsm1.
mdadm: (IMSM): Unsupported attributes : 3000000
mdadm: Unsupported attributes in IMSM metadata.Arrays activation is blocked.
mdadm: Cannot activate member /md126/1 in /dev/md/imsm1.


=================== blkid (filtered) before raid activation: ===================
/dev/nvme0n1p1: LABEL="SYSTEM" UUID="C8E0-30E9" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="61a7ba79-ea63-4099-9e0e-a81d6f436582"
/dev/nvme0n1p3: LABEL="OS" UUID="22D4E208D4E1DDD3" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="2d43ce60-1ac6-4871-84fc-c6dfd91e9921"
/dev/nvme0n1p4: LABEL="RECOVERY" UUID="2CCCFAC6CCFA88FA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="faace40a-5400-47cb-a055-e1b8a3fa4688"
/dev/nvme0n1p5: UUID="8574c742-a197-4723-8f7e-908ec64b21d1" TYPE="ext4" PARTUUID="6a9c55ed-cc8a-490e-8319-29e0d043aa63"
/dev/nvme1n1: TYPE="isw_raid_member"
/dev/sda1: LABEL="UBUNTU 20_0" UUID="306A-FD43" TYPE="vfat" PARTUUID="0000f2db-01"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="86344b88-211c-453b-ab95-9859733028f8"
dmraid -si -c
no block devices found
dmraid -ay:
no block devices found
dmraid -sa -c:
no block devices found
mdadm --assemble --scan

mdadm --detail --scan
ARRAY /dev/md127 metadata=imsm UUID=82dd0613:66a9658a:485ce533:0fa96721
ARRAY /dev/md/imsm1 metadata=imsm UUID=3624a151:08b46605:8ba4d705:0b7419ec
Error code 32
mount -r /dev/nvme0n1p1 /mnt/boot-sav/nvme0n1p1

mount -r /dev/nvme0n1p1 : Error code 32
Error code 21
mount -r /dev/nvme0n1p3 /mnt/boot-sav/nvme0n1p3

mount -r /dev/nvme0n1p3 : Error code 21
Error code 21
mount -r /dev/nvme0n1p4 /mnt/boot-sav/nvme0n1p4

mount -r /dev/nvme0n1p4 : Error code 21
Error code 32
mount -r /dev/nvme0n1p5 /mnt/boot-sav/nvme0n1p5

mount -r /dev/nvme0n1p5 : Error code 32
Error code 32
mount -r /dev/nvme0n1p1 /mnt/boot-sav/nvme0n1p1

mount -r /dev/nvme0n1p1 : Error code 32
Error code 21
mount -r /dev/nvme0n1p3 /mnt/boot-sav/nvme0n1p3

mount -r /dev/nvme0n1p3 : Error code 21
Error code 21
mount -r /dev/nvme0n1p4 /mnt/boot-sav/nvme0n1p4

mount -r /dev/nvme0n1p4 : Error code 21
Error code 32
mount -r /dev/nvme0n1p5 /mnt/boot-sav/nvme0n1p5

mount -r /dev/nvme0n1p5 : Error code 32
Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would not act on the boot.

On y voit ceci :

nvme0n1     isw_raid_member

Cette mention "isw_raid_member" indique que Windows 10 est installé en mode RAID sur le SSD nvme0n1. Le souci est le même que dans ce fil initié par René B : https://forum.ubuntu-fr.org/viewtopic.php?id=2055725
Pour parvenir à démarrer sur Ubuntu installé, il est nécessaire de passer le SATA Mode en AHCI comme l'a fait René B dans ce post : https://forum.ubuntu-fr.org/viewtopic.p … #p22327003

EDIT : tu as noté "Asus Vivobook 14 R415" dans le post #1 mais je ne trouve rien là-dessus. Je te prie de vérifier le nom complet de ce modèle et de le donner dans ta réponse.

Dernière modification par malbo (Le 16/01/2021, à 18:27)

Hors ligne

#3 Le 16/01/2021, à 19:18

alexandre_caze

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Merci pour ta réponse ! C'est super sympa.

Alors je viens de passer le SATA en AHCI et désormais y'a plus de jaloux, Windows ne démarre plus non plus smile
Dans les options de boot du BIOS je ne vois pas Ubuntu, il n'y a que Windows Boot Manager.
Du coup si j'ai bien compris je dois maintenant reformater le disque, puis réinstaller Windows 10, puis Ubuntu ?
Pour réinstaller windows il faut que j'achète une license j'imagine ? Ou est-ce que je peux utiliser la réinit du système Asus ?

Le modèle complet de l'ordinateur est Vivobook R415JA-EK143T (https://www.boulanger.com/ref/1151504).

Hors ligne

#4 Le 17/01/2021, à 08:19

malbo

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

alexandre_caze a écrit :

Alors je viens de passer le SATA en AHCI

Peux-tu préciser ce qu'il y avait avant AHCI (c'est du genre "Intel RST with optane") ? Pour retrouver le fonctionnement de Windows 10, il faudra revenir à ce qu'il y avait avant (*). Ensuite, tu pourras tenter de désactiver Optane depuis Windows lui-même en t'appuyant sur cette vidéo : https://www.youtube.com/watch?v=6LYgLNx_3hE
C'est une vidéo pour Lenovo mais je n'ai rien trouvé pour Asus (j'ai sans doute mal cherché). Elle est adaptée pour Optane H10 qui est la technologie mise en œuvre dans ton modèle si j'en crois cette page du site LaptopSpirit : https://www.laptopspirit.fr/283057/asus … ouris.html
On peut y lire : "Côté stockage, Asus propose ici une solution Intel Optane H10 (testée par nos soins) combinant un SSD de 512 Go à un module Optane de 32 Go. "

(*) en fouillant sur la toile, j'ai trouvé cette photo issue de ce fil de discussion. Bien qu'il ne s'agisse pas du même modèle d'ordi que toi, il s'agit exactement du même Optane. On y voit pour le paramètre SATA Mode Selection que l'état par défaut est [Intel RST Premium With Intel Optane System Acceleration]. Tu confirmes ?

Dernière modification par malbo (Le 17/01/2021, à 08:50)

Hors ligne

#5 Le 17/01/2021, à 15:46

alexandre_caze

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Ca a fonctionné merci ! Je réponds depuis mon ubuntu qui tourne nickel smile

malbo a écrit :

Pour retrouver le fonctionnement de Windows 10, il faudra revenir à ce qu'il y avait avant (*). Ensuite, tu pourras tenter de désactiver Optane depuis Windows lui-même en t'appuyant sur cette vidéo : https://www.youtube.com/watch?v=6LYgLNx_3hE

Ce que j'ai fait pour que ça marche :
- J'ai restauré le PC à sa config d'origine.
- Cela n'a pas supprimé mon install ubuntu, mais juste réinitialisé mon install windows.
- Dans le BIOS, le Secure Boot et le Fast Boot étaient restés désactivés. Je n'ai rien touché.
- Sous windows, j'ai suivi la vidéo ci-dessus pour désactiver Optane (j'ai du télécharger l'app intel depuis le microsoft store)
- J'ai redémarré, booté sur ma clé usb ubuntu et lancé en mode "Essayez Ubuntu"
- J'ai lancé boot-repair, qui cette fois m'a proposé une réparation qui a fonctionné.

malbo a écrit :

On y voit pour le paramètre SATA Mode Selection que l'état par défaut est [Intel RST Premium With Intel Optane System Acceleration]. Tu confirmes ?

Je confirme. Pour info ça a marché sans que je change AHCI dans le BIOS.

Encore un grand merci malbo ! Je ne sais pas comment passer la discussion en résolu en revanche.

Hors ligne

#6 Le 17/01/2021, à 15:49

alexandre_caze

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Ca y est j'ai modifié le sujet en résolu smile

Hors ligne

#7 Le 17/01/2021, à 21:48

malbo

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

alexandre_caze a écrit :

Ce que j'ai fait pour que ça marche :
- J'ai restauré le PC à sa config d'origine.

Peux-tu préciser ce que tu as fait pour restaurer le PC à sa config d'origine ?

alexandre_caze a écrit :

Pour info ça a marché sans que je change AHCI dans le BIOS.

Je comprends qu'actuellement le paramètre SATA Mode Selection est sur AHCI. C'est bien ce qu'il faut comprendre ?


EDIT le 18 janv 2021 : pour qu'on puisse voir à quoi ça ressemble à présent  je te prie de faire un Boot-info depuis une session de ton Ubuntu installé et de donner l'URL de ce Boot-info dans ta réponse

Dernière modification par malbo (Le 18/01/2021, à 09:31)

Hors ligne

#8 Le 18/01/2021, à 11:16

alexandre_caze

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Pour restaurer le PC à sa config d'origine, j'ai redémarré, appuyé sur F12 puis selectionné une option du genre "Diagnostic" ou "Réparer" qui m'a proposé de remettre l'ordinateur dans sa config d'usine.

Bizarrement, le paramètre SATA Mode Selection n'est pas sur AHCI mais toujours sur [Intel RST Premium With Intel Optane System Acceleration].

Voici l'url de mon nouveau boot-info https://paste.ubuntu.com/p/6Yzpd3b3k5/

Hors ligne

#9 Le 18/01/2021, à 12:04

malbo

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Je colle ci-dessous le contenu du nouveau Boot-info :

boot-repair-4ppa125                                              [20210118_1012]

============================== Boot Info Summary ===============================

 => No boot loader is installed in the MBR of /dev/nvme0n1.
 => No boot loader is installed in the MBR of /dev/nvme1n1.

nvme0n1p1: _____________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/bkpbootx64.efi /efi/Boot/bootx64.efi 
                       /efi/Boot/fbx64.efi /efi/Boot/grubx64.efi 
                       /efi/Boot/mmx64.efi /efi/ubuntu/grubx64.efi 
                       /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                       /efi/ubuntu/grub.cfg /efi/Microsoft/Boot/bootmgfw.efi 
                       /efi/Microsoft/Boot/bootmgr.efi 
                       /efi/Microsoft/Boot/memtest.efi

nvme0n1p2: _____________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 

nvme0n1p3: _____________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 8 or 10
    Boot files:        /Windows/System32/winload.exe

nvme0n1p4: _____________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

nvme0n1p5: _____________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.1 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 2 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession on nvme0n1p5
OS#2:   Windows 8 or 10 on nvme0n1p3

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.8.0-38-generic root=UUID=8574c742-a197-4723-8f7e-908ec64b21d1 ro quiet splash vt.handoff=7


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0003
Boot0000* ubuntu	HD(1,GPT,61a7ba79-ea63-4099-9e0e-a81d6f436582,0x800,0x82000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0003* Windows Boot Manager	HD(1,GPT,61a7ba79-ea63-4099-9e0e-a81d6f436582,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....j...............

78415fb8fb9b909f8029858113f1335f   nvme0n1p1/Boot/bkpbootx64.efi
78415fb8fb9b909f8029858113f1335f   nvme0n1p1/Boot/bootx64.efi
2895d47544fd587b26c7e29be1295c27   nvme0n1p1/Boot/fbx64.efi
8ed07d5ee4e5e1534bcf64037b7589ff   nvme0n1p1/Boot/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   nvme0n1p1/Boot/mmx64.efi
8ed07d5ee4e5e1534bcf64037b7589ff   nvme0n1p1/ubuntu/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   nvme0n1p1/ubuntu/mmx64.efi
78415fb8fb9b909f8029858113f1335f   nvme0n1p1/ubuntu/shimx64.efi
4f0248591a11d5432380ba65f683879b   nvme0n1p1/Microsoft/Boot/bootmgfw.efi
1feb5f9427494e6f598603caa3af7d99   nvme0n1p1/Microsoft/Boot/bootmgr.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

nvme0n1	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

nvme0n1p5	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
nvme0n1p1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
nvme0n1p3	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
nvme0n1p4	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

nvme0n1p5	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p3	: isnotESP,	part-has-no-fstab,	no-nt,	haswinload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p4	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

nvme0n1p5	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	nvme0n1
nvme0n1p1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p3	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p4	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1

fdisk -l (filtered): ___________________________________________________________

Disk nvme0n1: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk identifier: 481F44C2-C692-4DB9-A7CA-AC1BE00C006B
              Start        End   Sectors   Size Type
nvme0n1p1      2048     534527    532480   260M EFI System
nvme0n1p2    534528     567295     32768    16M Microsoft reserved
nvme0n1p3    567296  793457294 792889999 378.1G Microsoft basic data
nvme0n1p4 998258688 1000204287   1945600   950M Windows recovery environment
nvme0n1p5 793458688  998258687 204800000  97.7G Linux filesystem
Partition table entries are not in disk order.
Disk nvme1n1: 27.26 GiB, 29260513280 bytes, 57149440 sectors

parted -lm (filtered): _________________________________________________________

nvme0n1:512GB:nvme:512:512:gpt:INTEL HBRPEKNX0202A:;
1:1049kB:274MB:273MB:fat32:EFI system partition:boot, esp;
2:274MB:290MB:16.8MB::Microsoft reserved partition:msftres;
3:290MB:406GB:406GB:ntfs:Basic data partition:msftdata;
5:406GB:511GB:105GB:ext4::;
4:511GB:512GB:996MB:ntfs::hidden, diag;
nvme1n1:29.3GB:nvme:512:512:unknown:INTEL HBRPEKNX0202AO:;

blkid (filtered): ______________________________________________________________

NAME        FSTYPE   UUID                                 PARTUUID                             LABEL    PARTLABEL
nvme0n1                                                                                                 
├─nvme0n1p1 vfat     C8E0-30E9                            61a7ba79-ea63-4099-9e0e-a81d6f436582 SYSTEM   EFI system partition
├─nvme0n1p2                                               86344b88-211c-453b-ab95-9859733028f8          Microsoft reserved partition
├─nvme0n1p3 ntfs     22D4E208D4E1DDD3                     2d43ce60-1ac6-4871-84fc-c6dfd91e9921 OS       Basic data partition
├─nvme0n1p4 ntfs     2CCCFAC6CCFA88FA                     faace40a-5400-47cb-a055-e1b8a3fa4688 RECOVERY Basic data partition
└─nvme0n1p5 ext4     8574c742-a197-4723-8f7e-908ec64b21d1 6a9c55ed-cc8a-490e-8319-29e0d043aa63          
nvme1n1                                                                                                 

df (filtered): _________________________________________________________________

                   Avail Use% Mounted on
nvme0n1p3         348.2G   8% /mnt/boot-sav/nvme0n1p3
nvme0n1p4         100.7M  89% /mnt/boot-sav/nvme0n1p4
nvme0n1p5          81.9G   9% /

Mount options: __________________________________________________________________

nvme0n1p3         rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
nvme0n1p4         rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
nvme0n1p5         rw,relatime,errors=remount-ro

=================== nvme0n1p1/efi/ubuntu/grub.cfg (filtered) ===================

search.fs_uuid 8574c742-a197-4723-8f7e-908ec64b21d1 root 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

=================== nvme0n1p5/boot/grub/grub.cfg (filtered) ====================

Ubuntu   8574c742-a197-4723-8f7e-908ec64b21d1
Ubuntu, with Linux 5.8.0-38-generic   8574c742-a197-4723-8f7e-908ec64b21d1
Ubuntu, with Linux 5.4.0-42-generic   8574c742-a197-4723-8f7e-908ec64b21d1
Windows Boot Manager (on nvme0n1p1)   osprober-efi-C8E0-30E9
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

======================== nvme0n1p5/etc/fstab (filtered) ========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=8574c742-a197-4723-8f7e-908ec64b21d1 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
/swapfile                                 none            swap    sw              0       0
UUID=C8E0-30E9  /boot/efi       vfat    defaults      0       1

==================== nvme0n1p5/etc/default/grub (filtered) =====================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

================= nvme0n1p5: Location of files loaded by Grub ==================

           GiB - GB             File                                 Fragment(s)
 396,480762482 = 425,717977088  boot/grub/grub.cfg                             1
 384,664321899 = 413,030170624  boot/vmlinuz                                   1
 382,728633881 = 410,951741440  boot/vmlinuz-5.4.0-42-generic                  2
 384,664321899 = 413,030170624  boot/vmlinuz-5.8.0-38-generic                  1
 382,728633881 = 410,951741440  boot/vmlinuz.old                               2
 384,967769623 = 413,355995136  boot/initrd.img                                3
 384,951393127 = 413,338411008  boot/initrd.img-5.4.0-42-generic               2
 384,967769623 = 413,355995136  boot/initrd.img-5.8.0-38-generic               3
 384,951393127 = 413,338411008  boot/initrd.img.old                            2

=================== nvme0n1p5: ls -l /etc/grub.d/ (filtered) ===================

-rwxr-xr-x 1 root root 17622 nov.  13 00:15 10_linux
-rwxr-xr-x 1 root root 42359 nov.  13 00:15 10_linux_zfs
-rwxr-xr-x 1 root root 12894 juil. 31 02:34 20_linux_xen
-rwxr-xr-x 1 root root 12059 juil. 31 02:34 30_os-prober
-rwxr-xr-x 1 root root  1424 juil. 31 02:34 30_uefi-firmware
-rwxr-xr-x 1 root root   214 juil. 31 02:34 40_custom
-rwxr-xr-x 1 root root   216 juil. 31 02:34 41_custom


Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
nvme0n1p5,
using the following options:        nvme0n1p1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix use-standard-efi-file  restore-efi-backups  

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession entry (nvme0n1p1/efi/****/shim****.efi (**** will be updated in the final message) file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.

If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\****\shim****.efi (**** will be updated in the final message)

Le démarrage du système UEFI est visible dans cet extrait :

===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0003
Boot0000* ubuntu	HD(1,GPT,61a7ba79-ea63-4099-9e0e-a81d6f436582,0x800,0x82000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0003* Windows Boot Manager	HD(1,GPT,61a7ba79-ea63-4099-9e0e-a81d6f436582,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....j...............

On y voit une entrée ubuntu qui pointe vers le fichier /efi/ubuntu/shimx64.efi de la partition EFI (nvme0n1p1), ce qui est tout à fait correct. Et c'est bien différent de ce qu'on pouvait voir dans le post #2 où on avait une pauvre entrée :

Boot0000* ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)

Ce code 99e275e7-75a0-4b37-a2e6-c5385e6c00cb indique une entrée corrompue (j'en parle dans ce vieux post)

Merci pour ces infos complémentaires. J'en retire que si j'ai la chance de pouvoir conseiller un autre utilisarteur qui serait confronté à optane H10, je lui recommanderai de laisser SATA Mode Selection sur sa position par défaut [Intel RST Premium With Intel Optane System Acceleration] et d'opérer seulement depuis Windows comme tu as fait.

EDIT le 20 janv 2021 : j'ai l'explication sur la présence surprenante du noyau 5.8 dans cet extrait :

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.8.0-38-generic root=UUID=8574c742-a197-4723-8f7e-908ec64b21d1 ro quiet splash vt.handoff=7

C'est à cause du HWE stack de 20.04. Il y a cette discussion récente sur le sujet : https://forum.ubuntu-fr.org/viewtopic.php?id=2060820

Dernière modification par malbo (Le 20/01/2021, à 10:46)

Hors ligne

#10 Le 19/01/2021, à 10:48

malbo

Re : [Résolu] Problème dual boot Ubuntu 20.4 - Windows 10 sur Asus Vivobook

Bonjour,
Je viens d'ajouter une ligne R415JA-EK143T dans la Liste des portables « Asus ». Comme j'y ai noté le lien vers la présente discussion, si tu as une remarque à faire ou un conseil à donner à un éventuel futur utilisateur de ce modèle, tu peux le faire en postant à la suite dans la présente discussion.
Pour mémoire, ce modèle est décrit sur cette page du site LaptopSpirit : https://www.laptopspirit.fr/283057/asus … ouris.html
Il est équipé d'un processeur Intel Core i3-1005G1 ; la partie graphique Intel UHD 620 est intégrée au processeur (il n'y a pas de carte graphique dédiée)

Dernière modification par malbo (Le 19/01/2021, à 10:53)

Hors ligne