Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/04/2021, à 09:34

Mlgp9

Pas de son sur les vidéos

Bonjour,
Voici mon problème, toute vidéo lue dans mon navigateur internet a du son mais les vidéos lues sur un disque ou clés USB n’ont plus de son.
Mon périphérique de sortie "Sortie ligne-Audio interne" fonctionne pour mon navigateur, les sons du PC et pour les fichiers musicaux
Par contre pour les vidéos enregistrées sur le HDD le périphérique de sortie passe par "HDMI/DisplayPort2..."
Comment basculer le son des vidéos sur la sortie "Sortie ligne-Audio interne" ?
Merci d'avance de vos conseils.

Ubuntu 20.04.2
5.8.0-49
Nvidia Geforce GTX 750 Ti

Hors ligne

#2 Le 13/04/2021, à 09:43

xubu1957

Re : Pas de son sur les vidéos

Bonjour,

Avais-tu installé : pavucontrol ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 13/04/2021, à 10:16

Mlgp9

Re : Pas de son sur les vidéos

Dans "pavucontrol" j'ai désactivé la sotie HDMI et le son de la vidéo est revenu
Mais après un reboot le problème persiste.
J'ai désactivé la sotie HDMI puis éteint le PC et rallumé, maintenant cela fonctionne smile, mais dans "pavucontrol" puis onglet "Périphériques de sortie" les deux sorties son coché "Définir comme défaut" et impossible de décocher HDMI.
Cela est-il normal ?

Hors ligne

#4 Le 13/04/2021, à 10:28

xubu1957

Re : Pas de son sur les vidéos

Tu pourrais regarder dans > TUTO Problèmes de sons sous Ubuntu.

J'empile les solutions, mais je ne suis pas un spécialiste.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 24/04/2021, à 09:55

Mlgp9

Re : Pas de son sur les vidéos

Merci pour les conseils, maintenant tous fonctionne smile

Hors ligne

#6 Le 24/04/2021, à 09:59

xubu1957

Re : Pas de son sur les vidéos

Bonjour,

Montre, en te servant du Retour utilisable de commande, d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 24/04/2021, à 18:16

Mlgp9

Re : Pas de son sur les vidéos

Voici le retour de la commande :

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                           Version                              Architecture Description
+++-=============================================-====================================-============-===============================================================================
rc  linux-image-5.8.0-48-generic                  5.8.0-48.54~20.04.1                  amd64        Signed kernel image generic
rc  linux-modules-5.8.0-48-generic                5.8.0-48.54~20.04.1                  amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-48-generic          5.8.0-48.54~20.04.1                  amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP

Hors ligne

#8 Le 24/04/2021, à 18:19

xubu1957

Re : Pas de son sur les vidéos

Pour nettoyer :

Le 11/02/2017, moko138 a écrit :

Pour supprimer les fichiers de configuration devenus sans objets et marqués "rc", et uniquement ces fichiers, exécute :

dpkg -l | awk '/^rc/{print $2}' | xargs -r sudo dpkg -P

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 24/04/2021, à 18:24

Mlgp9

Re : Pas de son sur les vidéos

(Lecture de la base de données... 280986 fichiers et répertoires déjà installés.)
Purge des fichiers de configuration de linux-image-5.8.0-48-generic (5.8.0-48.54~20.04.1) ...
rmdir: impossible de supprimer '/lib/modules/5.8.0-48-generic': Le dossier n'est pas vide
Purge des fichiers de configuration de linux-modules-5.8.0-48-generic (5.8.0-48.54~20.04.1) ...
dpkg: avertissement: lors de la suppression de linux-modules-5.8.0-48-generic, le répertoire « /lib/modules/5.8.0-48-generic » n'était pas vide, donc il n'a pas été supprimé
Purge des fichiers de configuration de linux-modules-extra-5.8.0-48-generic (5.8.0-48.54~20.04.1) ...

Hors ligne

#10 Le 24/04/2021, à 18:28

xubu1957

Re : Pas de son sur les vidéos

Fournis les noyaux présents :

echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#11 Le 24/04/2021, à 18:30

Mlgp9

Re : Pas de son sur les vidéos

ii  linux-headers-5.4.0-42                5.4.0-42.46           all
ii  linux-headers-5.4.0-42-generic        5.4.0-42.46           amd64
ii  linux-hwe-5.8-headers-5.8.0-49        5.8.0-49.55~20.04.1   all
ii  linux-headers-5.8.0-49-generic        5.8.0-49.55~20.04.1   amd64
ii  linux-image-5.8.0-49-generic          5.8.0-49.55~20.04.1   amd64
ii  linux-modules-5.8.0-49-generic        5.8.0-49.55~20.04.1   amd64
ii  linux-modules-extra-5.8.0-49-generic  5.8.0-49.55~20.04.1   amd64
ii  linux-hwe-5.8-headers-5.8.0-50        5.8.0-50.56~20.04.1   all
ii  linux-headers-5.8.0-50-generic        5.8.0-50.56~20.04.1   amd64
ii  linux-image-5.8.0-50-generic          5.8.0-50.56~20.04.1   amd64
ii  linux-modules-5.8.0-50-generic        5.8.0-50.56~20.04.1   amd64
ii  linux-modules-extra-5.8.0-50-generic  5.8.0-50.56~20.04.1   amd64
ii  linux-generic-hwe-20.04               5.8.0.50.56~20.04.34  amd64
ii  linux-headers-generic-hwe-20.04       5.8.0.50.56~20.04.34  amd64
ii  linux-image-generic-hwe-20.04         5.8.0.50.56~20.04.34  amd64

Noyau courant : 5.8.0-50-generic x86_64

Hors ligne

#12 Le 24/04/2021, à 18:34

xubu1957

Re : Pas de son sur les vidéos

Tente :

sudo apt-get autoremove --purge

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#13 Le 24/04/2021, à 18:37

Mlgp9

Re : Pas de son sur les vidéos

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.

Hors ligne

#14 Le 24/04/2021, à 18:41

xubu1957

Re : Pas de son sur les vidéos

Pour enlever les restes du noyau 5.4.0-42 :

La Doc > kernel#via_autoremove

extrait § 5.1 a écrit :

En pratique, si un ou plusieurs vieux noyaux résistent à la purge, il suffit de passer cette commande dans le terminal :

apt-mark showmanual | grep -E "linux-.*[0-9]" | grep -v "hwe" | xargs -r sudo apt-mark auto

Puis de repasser la commande de nettoyage automatique :

sudo apt autoremove --purge -y

Après cela, il ne restera que le dernier noyau et l'avant-dernier


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#15 Le 24/04/2021, à 18:42

Mlgp9

Re : Pas de son sur les vidéos

Avec Synaptic j'ai 3 MAJ : python3-distupgrade, ubuntu-release-upgrader-core, ubuntu-release-upgradeder-gtk.
Cela peut-il avoir un rapport ?

Hors ligne

#16 Le 24/04/2021, à 18:44

Mlgp9

Re : Pas de son sur les vidéos

La première commande avec sudo ?

Hors ligne

#17 Le 24/04/2021, à 18:44

xubu1957

Re : Pas de son sur les vidéos

3 non mis à jour.

Quand j'ai cette info, je passe :

sudo apt full-upgrade

_ _ _

Migp9 a écrit :

La première commande avec sudo ?

Suis les commandes en l'état.

Dernière modification par xubu1957 (Le 24/04/2021, à 18:46)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#18 Le 24/04/2021, à 18:48

Mlgp9

Re : Pas de son sur les vidéos

sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  python3-distupgrade ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk
3 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 137 ko dans les archives.
Après cette opération, 7168 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]

Hors ligne

#19 Le 24/04/2021, à 19:00

Mlgp9

Re : Pas de son sur les vidéos

Maintenant

dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                           Version                              Architecture Description
+++-=============================================-====================================-============-===============================================================================

Hors ligne

#20 Le 24/04/2021, à 19:14

cqfd93

Re : Pas de son sur les vidéos

Bonjour,

Mlgp9 a écrit :
…
Après cette opération, 7168 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]

Si tu ne réponds pas à la question…


cqfd93

Hors ligne

#21 Le 24/04/2021, à 19:17

Mlgp9

Re : Pas de son sur les vidéos

J'ai validé o

Hors ligne

#22 Le 24/04/2021, à 19:26

cqfd93

Re : Pas de son sur les vidéos

Et le retour après ce o ?


cqfd93

Hors ligne

#23 Le 25/04/2021, à 17:11

Mlgp9

Re : Pas de son sur les vidéos

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne