Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/04/2021, à 22:49

heronheronpetitpatapon

Kubuntu 20.04 plus d'autocomplétition dans le terminal

Bonjour je crois que tout est résumé dans le titre.
Voila je n'arrive plus à avoir la fonction liée à la touche "TAB" dans le terminal pour completer les commandes ou les chemins.
Je suis allé trouvé de l'aide sur ce site https://debian-facile.org/doc:programma … completion
J'ai bien suivi le tuto comme indiqué ici dans le site web dont le lien est au-dessus :

 Rechercher la ligne # enable bash completion in interactive shell et supprimer les dièses (#) sur la portion de code après cette ligne jusqu'au dernier fi. Ce qui doit donner au final :

Extrait de bash.bashrc

    # enable bash completion in interactive shells
    if ! shopt -oq posix; then
      if [ -f /usr/share/bash-completion/bash_completion ]; then
        . /usr/share/bash-completion/bash_completion
      elif [ -f /etc/bash_completion ]; then
        . /etc/bash_completion
      fi
    fi

J'ai donc modifié le fichier bash.bashrc comme demandé, voila ce que ça donne chez moi :

# System-wide .bashrc file for interactive bash(1) shells.

# To enable the settings / commands in this file for login shells as well,
# this file has to be sourced in /etc/profile.

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, overwrite the one in /etc/profile)
# but only if not SUDOing and have SUDO_PS1 set; then assume smart user.
if ! [ -n "${SUDO_USER}" -a -n "${SUDO_PS1}" ]; then
  PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi

# Commented out, don't overwrite xterm -T "title" -n "icontitle" by default.
# If this is an xterm set the title to user@host:dir
#case "$TERM" in
#xterm*|rxvt*)
#    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
#    ;;
#*)
#    ;;
#esac

# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

# sudo hint
if [ ! -e "$HOME/.sudo_as_admin_successful" ] && [ ! -e "$HOME/.hushlogin" ] ; then
    case " $(groups) " in *\ admin\ *|*\ sudo\ *)
    if [ -x /usr/bin/sudo ]; then
	cat <<-EOF
	To run a command as administrator (user "root"), use "sudo <command>".
	See "man sudo_root" for details.
	
	EOF
    fi
    esac
fi

# if the command-not-found package is installed, use it
if [ -x /usr/lib/command-not-found -o -x /usr/share/command-not-found/command-not-found ]; then
	function command_not_found_handle {
	        # check because c-n-f could've been removed in the meantime
                if [ -x /usr/lib/command-not-found ]; then
		   /usr/lib/command-not-found -- "$1"
                   return $?
                elif [ -x /usr/share/command-not-found/command-not-found ]; then
		   /usr/share/command-not-found/command-not-found -- "$1"
                   return $?
		else
		   printf "%s: command not found\n" "$1" >&2
		   return 127
		fi
	}
fi

Résultat des courses, ça ne marche pas! Auriez-vous une petite idée ?
Merci
Heronheron Petitpatapon


...Ubuntu Rocks....

Hors ligne

#2 Le 20/04/2021, à 23:37

cqfd93

Re : Kubuntu 20.04 plus d'autocomplétition dans le terminal

Bonjour,

Et ton fichier ~/.bashrc, il contient aussi ces lignes non commentées :

# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

?


cqfd93

Hors ligne

#3 Le 21/04/2021, à 18:31

heronheronpetitpatapon

Re : Kubuntu 20.04 plus d'autocomplétition dans le terminal

cqfd93 a écrit :

Bonjour,

Et ton fichier ~/.bashrc, il contient aussi ces lignes non commentées :

# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

?

Oui! ce qui veut dire ?  Car j'ai déja enlevé les # comme il était indiqué dans le tuto pour activé l'autocomplétion!


...Ubuntu Rocks....

Hors ligne