Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/05/2023, à 02:50

Zion

[Résolu] Comment mettre à jour svp ?

Bonjour,

Je tape sudo apt update
puis sudo apt upgrade

mais ça met pas à jour et ça me dit qu'il y a tout ça comme mise à jour :

niko@x:~$ apt list --upgradable
En train de lister... Fait
evolution-data-server-common/lunar-updates,lunar-updates 3.48.1-0ubuntu1 all [pouvant être mis à jour depuis : 3.48.0-1]
evolution-data-server/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libcamel-1.2-64/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libebackend-1.2-11/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libebook-1.2-21/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libebook-contacts-1.2-4/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libecal-2.0-2/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libedata-book-1.2-27/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libedata-cal-2.0-2/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libedataserver-1.2-27/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libedataserverui-1.2-4/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
libedataserverui4-1.0-0/lunar-updates 3.48.1-0ubuntu1 amd64 [pouvant être mis à jour depuis : 3.48.0-1]
niko@x:~$ 

Comment faire ? Merci ! wink

Dernière modification par Zion (Le 22/05/2023, à 19:56)

Hors ligne

#2 Le 19/05/2023, à 05:15

cqfd93

Re : [Résolu] Comment mettre à jour svp ?

Bonjour,

Essaye plutôt :

sudo apt full-upgrade

cqfd93

Hors ligne

#3 Le 20/05/2023, à 08:33

Zion

Re : [Résolu] Comment mettre à jour svp ?

niko@x:~$ sudo apt full-upgrade
[sudo] Mot de passe de niko : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
niko@x:~$ 

Hors ligne

#4 Le 20/05/2023, à 15:17

cqfd93

Re : [Résolu] Comment mettre à jour svp ?

Bonjour,

J'imagine qu'entre tes deux retours, il s'est passé quelqu chose, peut-être le gestionnaire de mises à jour, le problème ne se serait pas résolu tout seul...


cqfd93

Hors ligne

#5 Le 22/05/2023, à 19:56

Zion

Re : [Résolu] Comment mettre à jour svp ?

Ok, résolu alors !

Hors ligne

#6 Le 26/05/2023, à 00:37

Zion

Re : [Résolu] Comment mettre à jour svp ?

niko@x:~$ sudo apt update
[sudo] Mot de passe de niko : 
Atteint :1 http://fr.archive.ubuntu.com/ubuntu lunar InRelease
Atteint :2 https://deb.nodesource.com/node_16.x focal InRelease                
Atteint :3 https://linux.teamviewer.com/deb stable InRelease                   
Atteint :4 http://fr.archive.ubuntu.com/ubuntu lunar-updates InRelease         
Atteint :5 https://dl.winehq.org/wine-builds/ubuntu kinetic InRelease          
Atteint :6 https://repo.steampowered.com/steam stable InRelease                
Atteint :7 http://fr.archive.ubuntu.com/ubuntu lunar-backports InRelease
Réception de :8 http://security.ubuntu.com/ubuntu lunar-security InRelease [109 kB]
109 ko réceptionnés en 1s (126 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
6 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

Hors ligne

#7 Le 26/05/2023, à 00:53

cqfd93

Re : [Résolu] Comment mettre à jour svp ?

Et donc ?


cqfd93

Hors ligne

#8 Le 26/05/2023, à 03:54

nany

Re : [Résolu] Comment mettre à jour svp ?

Bonjour,



Et donc il s’agit très probablement de mises à jour progressives. Pour s’en convaincre :

apt policy ?upgradable | awk '/[[:alnum:]]:$/{sub(/:$/,"",$0);print $0}/phased/{print $3,$4}'

Ce qui donne actuellement chez moi six paquets tagués phased.

Dernière modification par nany (Le 26/05/2023, à 04:37)

Hors ligne

#9 Le 26/05/2023, à 08:11

Zion

Re : [Résolu] Comment mettre à jour svp ?

niko@x:~$ apt policy ?upgradable | awk '/[[:alnum:]]:$/{sub(/:$/,"",$0);print $0}/phased/{print $3,$4}'

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libcurl4-openssl-dev
(phased 10%)
libcurl4
(phased 10%)
libcurl4:i386
(phased 10%)
libcurl3-gnutls
(phased 10%)
alsa-ucm-conf
(phased 20%)
curl
(phased 10%)
niko@x:~$ 

Hors ligne

#10 Le 26/05/2023, à 08:11

Zion

Re : [Résolu] Comment mettre à jour svp ?

cqfd93 a écrit :

Et donc ?

Pourquoi ça se met pas à jour ?
J'ai du mal à comprendre... hmm

Hors ligne

#12 Le 26/05/2023, à 15:02

Zion

Re : [Résolu] Comment mettre à jour svp ?

sudo apt install ?upgradable

Hors ligne

#13 Le 26/05/2023, à 16:13

cqfd93

Re : [Résolu] Comment mettre à jour svp ?

Bonjour,

Zion a écrit :

Pourquoi ça se met pas à jour ?
J'ai du mal à comprendre... hmm

Tu as la réponse dans le message #2.


cqfd93

Hors ligne

#14 Le 26/05/2023, à 16:21

nany

Re : [Résolu] Comment mettre à jour svp ?

cqfd93 a écrit :

Tu as la réponse dans le message #2.

Je m’inscris en faux, full-upgrade ne force pas les mises à jour progressives.

Hors ligne

#15 Le 26/05/2023, à 16:26

cqfd93

Re : [Résolu] Comment mettre à jour svp ?

nany a écrit :

Je m’inscris en faux, full-upgrade ne force pas les mises à jour progressives.

Oui, mais s'arrêter à update ne risque pas de faire les mises à jour.


cqfd93

Hors ligne

#16 Le 26/05/2023, à 16:34

xubu1957

Re : [Résolu] Comment mettre à jour svp ?

Bonjour,

Il faudrait aussi que le demandeur, retienne les informations déjà fournies, et ne pas multiplie pas les discussions.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne